aboutsummaryrefslogtreecommitdiff
path: root/net/hexinject
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2017-01-18 01:29:14 +0000
committerSofian Brabez <sbz@FreeBSD.org>2017-01-18 01:29:14 +0000
commit5139548f744e4115529907a808fb8f4840f25423 (patch)
tree89e06522e25608b3c4d1acf9e26c2cf04550f768 /net/hexinject
parent51906167fd09e25573e74a3fe1584f2fc1aceb6e (diff)
downloadports-5139548f744e4115529907a808fb8f4840f25423.tar.gz
ports-5139548f744e4115529907a808fb8f4840f25423.zip
- Update to 1.6
Notes
Notes: svn path=/head/; revision=431778
Diffstat (limited to 'net/hexinject')
-rw-r--r--net/hexinject/Makefile3
-rw-r--r--net/hexinject/distinfo6
-rw-r--r--net/hexinject/files/patch-prettypacket.h38
3 files changed, 4 insertions, 43 deletions
diff --git a/net/hexinject/Makefile b/net/hexinject/Makefile
index 38b041628073..a4ce10038d4c 100644
--- a/net/hexinject/Makefile
+++ b/net/hexinject/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hexinject
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 1.6
CATEGORIES= net security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/net/hexinject/distinfo b/net/hexinject/distinfo
index 6bb6511b66dd..031bb184ced3 100644
--- a/net/hexinject/distinfo
+++ b/net/hexinject/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1470332871
-SHA256 (hexinject-1.5.tar.gz) = 329f0686069988ac0dae4a00082b205ac9669bc8e202d4b112c600bcbc198ce9
-SIZE (hexinject-1.5.tar.gz) = 14449
+TIMESTAMP = 1484702457
+SHA256 (hexinject-1.6.tar.gz) = 06e64636923af593c742129d81b717667223bff39918f26bf56809ead9700e65
+SIZE (hexinject-1.6.tar.gz) = 16876
diff --git a/net/hexinject/files/patch-prettypacket.h b/net/hexinject/files/patch-prettypacket.h
deleted file mode 100644
index 5f9ddbba0d5c..000000000000
--- a/net/hexinject/files/patch-prettypacket.h
+++ /dev/null
@@ -1,38 +0,0 @@
---- prettypacket.h.orig 2012-12-04 09:31:27 UTC
-+++ prettypacket.h
-@@ -102,7 +102,7 @@ const char *next_color() {
- * @param counter protocol number offset
- * @return protocol number in host format
- */
--inline uint8_t protocol_8bit_extract(const char *packet_buffer, int counter) {
-+uint8_t protocol_8bit_extract(const char *packet_buffer, int counter) {
- return *(packet_buffer + counter);
- }
-
-@@ -113,7 +113,7 @@ inline uint8_t protocol_8bit_extract(con
- * @param counter protocol number offset
- * @return protocol number in host format
- */
--inline uint16_t protocol_16bit_extract(const char *packet_buffer, int counter) {
-+uint16_t protocol_16bit_extract(const char *packet_buffer, int counter) {
- return ntohs(*((uint16_t *)(packet_buffer + counter)));
- }
-
-@@ -123,7 +123,7 @@ inline uint16_t protocol_16bit_extract(c
- * @param counter protocol number offset
- * @return protocol number in host format
- */
--inline uint64_t protocol_48bit_extract(const char *packet_buffer, int counter) {
-+uint64_t protocol_48bit_extract(const char *packet_buffer, int counter) {
- uint64_t value = 0;
-
- int i;
-@@ -144,7 +144,7 @@ inline uint64_t protocol_48bit_extract(c
- * @param counter read bytes counter
- * @param field_text description of the field
- */
--inline field_print (const char *packet_buffer, int field_size, int *counter, const char *field_text) {
-+void field_print (const char *packet_buffer, int field_size, int *counter, const char *field_text) {
-
- char *tmp_hexstr = raw_to_hexstr(packet_buffer + *counter, field_size);
- *counter += field_size;