aboutsummaryrefslogtreecommitdiff
path: root/net/hornetq/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-25 15:24:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-25 15:24:26 +0000
commited9c37dec74e7e91017ea3253467a6bfeaec16bd (patch)
tree847fea8caca7234ff3411330a67dbd6e48aa35c3 /net/hornetq/Makefile
parent7454984b34e8dc17de77a6d75b1b160bde31e1dd (diff)
downloadports-ed9c37dec74e7e91017ea3253467a6bfeaec16bd.tar.gz
ports-ed9c37dec74e7e91017ea3253467a6bfeaec16bd.zip
Notes
Diffstat (limited to 'net/hornetq/Makefile')
-rw-r--r--net/hornetq/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/net/hornetq/Makefile b/net/hornetq/Makefile
new file mode 100644
index 000000000000..8faab392f64f
--- /dev/null
+++ b/net/hornetq/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: hornetq
+# Date created: 2012-03-16
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= hornetq
+PORTVERSION= 2.2.14
+CATEGORIES= net java
+MASTER_SITES= http://downloads.jboss.org/hornetq/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.Final
+
+MAINTAINER= hsn@sendmail.cz
+COMMENT= Multi-protocol asynchronous messaging system
+
+LICENSE= LGPL21
+
+PORTDOCS= quickstart-guide api rest-api user-manual \
+ rest-interface-manual README.html
+
+USE_RC_SUBR= hornetq
+USE_JAVA= yes
+JAVA_VERSION= 1.6
+JAVA_VENDOR= openjdk
+
+NO_BUILD= yes
+CONFIG_DIRS= clustered non-clustered
+CONFIG_FILES= hornetq-beans.xml hornetq-users.xml hornetq-configuration.xml \
+ jndi.properties hornetq-jms.xml logging.properties
+
+CONFIGURE_WRKSRC= ${WRKSRC}/native-src
+LIBTOOLFILES= native-src/aclocal.m4
+ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal/
+AUTOMAKE_ARGS= --add-missing -c
+
+post-extract:
+ ${RM} -r ${WRKSRC}/tools ${WRKSRC}/native-src ${WRKSRC}/config/jboss-as*
+ ${RM} ${WRKSRC}/bin/*.bat ${WRKSRC}/bin/*.so ${WRKSRC}/bin/build.sh
+ ${MV} ${WRKSRC}/schemas ${WRKSRC}/config
+.for dir in ${CONFIG_DIRS}
+.for config in ${CONFIG_FILES}
+ ${MV} ${WRKSRC}/config/stand-alone/${dir}/${config} ${WRKSRC}/config/stand-alone/${dir}/${config}.sample
+.endfor
+.endfor
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${MKDIR} ${DATADIR}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/*.sh ${DATADIR}/bin
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} lib ${DATADIR}
+ ${RM} -f ${WRKSRC}/config/stand-alone/clustered/*.orig
+ ${RM} -f ${WRKSRC}/config/stand-alone/non-clustered/*.orig
+ cd ${WRKSRC} && ${COPYTREE_SHARE} config ${DATADIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+
+post-install:
+ PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>