aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 08:42:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 08:42:58 +0000
commit3263b0b11d2f00912cef2a9d1934e628d77e8e79 (patch)
tree4ba035f48705f68d6275c25479def006f62c8209 /net/hostapd
parent992de15d82d5c1b1c574cb4737199b976c227a6f (diff)
downloadports-3263b0b11d2f00912cef2a9d1934e628d77e8e79.tar.gz
ports-3263b0b11d2f00912cef2a9d1934e628d77e8e79.zip
Support staging
Notes
Notes: svn path=/head/; revision=346465
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index d55b72db8954..e9fd8ba90a81 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -12,16 +12,12 @@ COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
LICENSE= GPLv2 BSD
LICENSE_COMB= dual
-USE_GMAKE= yes
+USES= gmake
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
-MAN1= hostapd_cli.1
-MAN8= hostapd.8
+PLIST_FILES= sbin/hostapd sbin/hostapd_cli man/man1/hostapd_cli.1.gz \
+ man/man8/hostapd.8.gz
-PLIST_FILES= sbin/hostapd \
- sbin/hostapd_cli
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
@@ -36,9 +32,12 @@ do-configure:
${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN1} ${MAN1PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN8} ${MAN8PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli \
+ ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/hostapd_cli.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/hostapd.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8
.include <bsd.port.post.mk>