aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
commit5b55a8a53e383d5e641472b56a6d631e59da3967 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /net/hostapd
parent769a9f1570ce818b49b6170bf5745363ffbe79e0 (diff)
downloadports-5b55a8a53e383d5e641472b56a6d631e59da3967.tar.gz
ports-5b55a8a53e383d5e641472b56a6d631e59da3967.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Notes
Notes: svn path=/head/; revision=416966
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index b12ea5276374..f7fa07011982 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -24,16 +24,16 @@ OPTIONS_DEFINE= PORTS_SSL
PORTS_SSL_DESC= Build with OpenSSL from ports (instead of base system)
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPORTS_SSL}
-.if !defined(WITH_OPENSSL_PORT)
-IGNORE= the PORTS_SSL option not allowed when WITH_OPENSSL_PORT is not set
+.if ${SSL_DEFAULT} == base
+IGNORE= the PORTS_SSL option not allowed when using SSL from base
.endif
CONFIGURE_ARGS+= --with-ssl-dir=${PREFIX}
.else
-.if defined(WITH_OPENSSL_PORT)
-IGNORE= the PORTS_SSL option is required when WITH_OPENSSL_PORT is set
+.if ${SSL_DEFAULT} != base
+IGNORE= the PORTS_SSL option is required when using SSL from ports
.endif
.endif
@@ -52,4 +52,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/hostapd/hostapd.8 \
${STAGEDIR}${MANPREFIX}/man/man8
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>