aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2020-05-20 04:20:01 +0000
committerCy Schubert <cy@FreeBSD.org>2020-05-20 04:20:01 +0000
commita2e3d8c958bf2fa32b0619e3f20385ba426a192a (patch)
tree5220f98c06eca849ea97f3118a2af1863839e585 /net/hostapd
parentc16b608701e6db1088511fe61a6488aaec6f68d8 (diff)
downloadports-a2e3d8c958bf2fa32b0619e3f20385ba426a192a.tar.gz
ports-a2e3d8c958bf2fa32b0619e3f20385ba426a192a.zip
Chase src r361272:
Silence the once per second CTRL-EVENT-SCAN-FAILED errors when the WiFi radio is disabled through the communication device toggle key (also known as the RF raidio kill button). Only the CTRL-EVENT-DISCONNECTED will be issued. Submitted by: avg Reported by: avg MFH: 2020Q2
Notes
Notes: svn path=/head/; revision=535967
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile1
-rw-r--r--net/hostapd/files/patch-src_drivers_driver__bsd.c30
2 files changed, 27 insertions, 4 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index a51fe3989ad5..6df0044285f3 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hostapd
PORTVERSION= 2.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://w1.fi/releases/
diff --git a/net/hostapd/files/patch-src_drivers_driver__bsd.c b/net/hostapd/files/patch-src_drivers_driver__bsd.c
index 052fb6748296..d2e9abe728ef 100644
--- a/net/hostapd/files/patch-src_drivers_driver__bsd.c
+++ b/net/hostapd/files/patch-src_drivers_driver__bsd.c
@@ -1,8 +1,8 @@
---- src/drivers/driver_bsd.c.orig 2015-09-27 19:02:05 UTC
-+++ src/drivers/driver_bsd.c
-@@ -623,7 +623,11 @@ rtbuf_len(void)
+--- src/drivers/driver_bsd.c.orig2 2019-08-07 06:25:25.000000000 -0700
++++ src/drivers/driver_bsd.c 2020-05-19 21:11:18.891164000 -0700
+@@ -665,7 +665,11 @@
static int bsd_sta_deauth(void *priv, const u8 *own_addr, const u8 *addr,
- int reason_code);
+ u16 reason_code);
+#ifdef __DragonFly__
+const char *
@@ -12,3 +12,25 @@
ether_sprintf(const u8 *addr)
{
static char buf[sizeof(MACSTR)];
+@@ -1336,14 +1340,18 @@
+ drv = bsd_get_drvindex(global, ifm->ifm_index);
+ if (drv == NULL)
+ return;
+- if ((ifm->ifm_flags & IFF_UP) == 0 &&
+- (drv->flags & IFF_UP) != 0) {
++ if (((ifm->ifm_flags & IFF_UP) == 0 ||
++ (ifm->ifm_flags & IFF_RUNNING) == 0) &&
++ (drv->flags & IFF_UP) != 0 &&
++ (drv->flags & IFF_RUNNING) != 0) {
+ wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' DOWN",
+ drv->ifname);
+ wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_DISABLED,
+ NULL);
+ } else if ((ifm->ifm_flags & IFF_UP) != 0 &&
+- (drv->flags & IFF_UP) == 0) {
++ (ifm->ifm_flags & IFF_RUNNING) != 0 &&
++ ((drv->flags & IFF_UP) == 0 ||
++ (drv->flags & IFF_RUNNING) == 0)) {
+ wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
+ drv->ifname);
+ wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_ENABLED,