aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-12 04:52:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-12 04:52:47 +0000
commitdb426675f0f7f2fb6445c0032d2ca381262c37b6 (patch)
treebd64c16966032dfef9268be3566ef675bdfb7c47 /net/hostapd
parent2ed3b11bf5c67d5b7d03ca418d5f4fb0942354db (diff)
downloadports-db426675f0f7f2fb6445c0032d2ca381262c37b6.tar.gz
ports-db426675f0f7f2fb6445c0032d2ca381262c37b6.zip
hostapd is a user space daemon for access point and authentication
servers. It implements IEEE 802.11 access point management, IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server. The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211). WWW: http://hostap.epitest.fi/hostapd/ PR: ports/154621 Submitted by: leres at ee.lbl.gov
Notes
Notes: svn path=/head/; revision=268964
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile43
-rw-r--r--net/hostapd/distinfo2
-rw-r--r--net/hostapd/files/config175
-rw-r--r--net/hostapd/files/patch-src-l2_packet-l2_packet_freebsd.c11
-rw-r--r--net/hostapd/pkg-descr13
5 files changed, 244 insertions, 0 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
new file mode 100644
index 000000000000..1c89db1d8760
--- /dev/null
+++ b/net/hostapd/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: hostapd
+# Date created: 05 February 2011
+# Whom: leres@ee.lbl.gov
+#
+# $FreeBSD$
+#
+
+PORTNAME= hostapd
+PORTVERSION= 0.7.3
+CATEGORIES= net
+MASTER_SITES= http://hostap.epitest.fi/releases/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= leres@ee.lbl.gov
+COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+
+USE_GMAKE= yes
+
+MAN1= hostapd_cli.1
+MAN8= hostapd.8
+
+do-configure:
+ ${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
+
+do-build:
+ (cd ${WRKSRC}/hostapd && ${GMAKE})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN1} ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN8} ${PREFIX}/man/man8
+
+PLIST_FILES= sbin/hostapd \
+ sbin/hostapd_cli
+
+#MAKE_JOBS_SAFE= yes
+#MANCOMPRESSED= yes
+
+LICENSE= GPLv1 BSD
+LICENSE_COMB= dual
+
+.include <bsd.port.mk>
diff --git a/net/hostapd/distinfo b/net/hostapd/distinfo
new file mode 100644
index 000000000000..3a5799214c63
--- /dev/null
+++ b/net/hostapd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hostapd-0.7.3.tar.gz) = 31eb2781f37e1a4c27969d1594f8019c0ca87779349c099ab812833289961567
+SIZE (hostapd-0.7.3.tar.gz) = 1138869
diff --git a/net/hostapd/files/config b/net/hostapd/files/config
new file mode 100644
index 000000000000..8a64503b7ed9
--- /dev/null
+++ b/net/hostapd/files/config
@@ -0,0 +1,175 @@
+# FreeBSD hostapd build time configuration
+#
+# This file lists the configuration options that are used when building the
+# hostapd binary. All lines starting with # are ignored. Configuration option
+# lines must be commented out complete, if they are not to be included, i.e.,
+# just setting VARIABLE=n is not disabling that variable.
+#
+# This file is included in Makefile, so variables like CFLAGS and LIBS can also
+# be modified from here. In most cass, these lines should use += in order not
+# to override previous values of the variables.
+
+# Driver interface for Host AP driver
+#CONFIG_DRIVER_HOSTAP=y
+
+# Driver interface for wired authenticator
+#CONFIG_DRIVER_WIRED=y
+
+# Driver interface for madwifi driver
+#CONFIG_DRIVER_MADWIFI=y
+#CFLAGS += -I../../madwifi # change to the madwifi source directory
+
+# Driver interface for drivers using the nl80211 kernel interface
+#CONFIG_DRIVER_NL80211=y
+# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
+# shipped with your distribution yet. If that is the case, you need to build
+# newer libnl version and point the hostapd build to use it.
+#LIBNL=/usr/src/libnl
+#CFLAGS += -I$(LIBNL)/include
+#LIBS += -L$(LIBNL)/lib
+
+# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
+CONFIG_DRIVER_BSD=y
+CFLAGS += -I/usr/local/include
+LIBS += -L/usr/local/lib
+LIBS_p += -L/usr/local/lib
+LIBS_c += -L/usr/local/lib
+
+# Driver interface for no driver (e.g., RADIUS server only)
+#CONFIG_DRIVER_NONE=y
+
+# IEEE 802.11F/IAPP
+#CONFIG_IAPP=y
+
+# WPA2/IEEE 802.11i RSN pre-authentication
+CONFIG_RSN_PREAUTH=y
+
+# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
+#CONFIG_PEERKEY=y
+
+# IEEE 802.11w (management frame protection)
+# This version is an experimental implementation based on IEEE 802.11w/D1.0
+# draft and is subject to change since the standard has not yet been finalized.
+# Driver support is also needed for IEEE 802.11w.
+#CONFIG_IEEE80211W=y
+
+# Integrated EAP server
+CONFIG_EAP=y
+
+# EAP-MD5 for the integrated EAP server
+CONFIG_EAP_MD5=y
+
+# EAP-TLS for the integrated EAP server
+CONFIG_EAP_TLS=y
+
+# EAP-MSCHAPv2 for the integrated EAP server
+CONFIG_EAP_MSCHAPV2=y
+
+# EAP-PEAP for the integrated EAP server
+CONFIG_EAP_PEAP=y
+
+# EAP-GTC for the integrated EAP server
+CONFIG_EAP_GTC=y
+
+# EAP-TTLS for the integrated EAP server
+CONFIG_EAP_TTLS=y
+
+# EAP-SIM for the integrated EAP server
+#CONFIG_EAP_SIM=y
+
+# EAP-AKA for the integrated EAP server
+#CONFIG_EAP_AKA=y
+
+# EAP-AKA' for the integrated EAP server
+# This requires CONFIG_EAP_AKA to be enabled, too.
+#CONFIG_EAP_AKA_PRIME=y
+
+# EAP-PAX for the integrated EAP server
+#CONFIG_EAP_PAX=y
+
+# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
+#CONFIG_EAP_PSK=y
+
+# EAP-SAKE for the integrated EAP server
+#CONFIG_EAP_SAKE=y
+
+# EAP-GPSK for the integrated EAP server
+#CONFIG_EAP_GPSK=y
+# Include support for optional SHA256 cipher suite in EAP-GPSK
+#CONFIG_EAP_GPSK_SHA256=y
+
+# EAP-FAST for the integrated EAP server
+# Note: Default OpenSSL package does not include support for all the
+# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
+# the OpenSSL library must be patched (openssl-0.9.9-session-ticket.patch)
+# to add the needed functions.
+#CONFIG_EAP_FAST=y
+
+# Wi-Fi Protected Setup (WPS)
+#CONFIG_WPS=y
+# Enable UPnP support for external WPS Registrars
+#CONFIG_WPS_UPNP=y
+
+# EAP-IKEv2
+#CONFIG_EAP_IKEV2=y
+
+# Trusted Network Connect (EAP-TNC)
+#CONFIG_EAP_TNC=y
+
+# PKCS#12 (PFX) support (used to read private key and certificate file from
+# a file that usually has extension .p12 or .pfx)
+CONFIG_PKCS12=y
+
+# RADIUS authentication server. This provides access to the integrated EAP
+# server from external hosts using RADIUS.
+#CONFIG_RADIUS_SERVER=y
+
+# Build IPv6 support for RADIUS operations
+CONFIG_IPV6=y
+
+# IEEE Std 802.11r-2008 (Fast BSS Transition)
+#CONFIG_IEEE80211R=y
+
+# Use the hostapd's IEEE 802.11 authentication (ACL), but without
+# the IEEE 802.11 Management capability (e.g., madwifi or FreeBSD/net80211)
+CONFIG_DRIVER_RADIUS_ACL=y
+
+# IEEE 802.11n (High Throughput) support
+#CONFIG_IEEE80211N=y
+
+# Remove debugging code that is printing out debug messages to stdout.
+# This can be used to reduce the size of the hostapd considerably if debugging
+# code is not needed.
+#CONFIG_NO_STDOUT_DEBUG=y
+
+# Remove support for RADIUS accounting
+#CONFIG_NO_ACCOUNTING=y
+
+# Remove support for RADIUS
+#CONFIG_NO_RADIUS=y
+
+# Remove support for VLANs
+#CONFIG_NO_VLAN=y
+
+# Remove support for dumping state into a file on SIGUSR1 signal
+# This can be used to reduce binary size at the cost of disabling a debugging
+# option.
+#CONFIG_NO_DUMP_STATE=y
+
+# Enable tracing code for developer debugging
+# This tracks use of memory allocations and other registrations and reports
+# incorrect use with a backtrace of call (or allocation) location.
+#CONFIG_WPA_TRACE=y
+# For BSD, comment out these.
+#LIBS += -lexecinfo
+#LIBS_p += -lexecinfo
+#LIBS_c += -lexecinfo
+
+# Use libbfd to get more details for developer debugging
+# This enables use of libbfd to get more detailed symbols for the backtraces
+# generated by CONFIG_WPA_TRACE=y.
+#CONFIG_WPA_TRACE_BFD=y
+# For BSD, comment out these.
+#LIBS += -lbfd -liberty -lz
+#LIBS_p += -lbfd -liberty -lz
+#LIBS_c += -lbfd -liberty -lz
diff --git a/net/hostapd/files/patch-src-l2_packet-l2_packet_freebsd.c b/net/hostapd/files/patch-src-l2_packet-l2_packet_freebsd.c
new file mode 100644
index 000000000000..0811796c25cd
--- /dev/null
+++ b/net/hostapd/files/patch-src-l2_packet-l2_packet_freebsd.c
@@ -0,0 +1,11 @@
+--- src/l2_packet/l2_packet_freebsd.c.orig 2011-02-05 17:11:19.000000000 -0800
++++ src/l2_packet/l2_packet_freebsd.c 2011-02-05 17:11:35.000000000 -0800
+@@ -14,7 +14,7 @@
+ */
+
+ #include "includes.h"
+-#if defined(__APPLE__) || defined(__GLIBC__)
++#if defined(__FreeBSD__) || defined(__APPLE__) || defined(__GLIBC__)
+ #include <net/bpf.h>
+ #endif /* __APPLE__ */
+ #include <pcap.h>
diff --git a/net/hostapd/pkg-descr b/net/hostapd/pkg-descr
new file mode 100644
index 000000000000..da2c084e450e
--- /dev/null
+++ b/net/hostapd/pkg-descr
@@ -0,0 +1,13 @@
+hostapd is a user space daemon for access point and authentication
+servers. It implements IEEE 802.11 access point management, IEEE
+802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and
+RADIUS authentication server. The current version supports Linux
+(Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
+
+To use the ports version instead of the base, add:
+
+ hostapd_program="/usr/local/sbin/hostapd"
+
+to /etc/rc.conf
+
+WWW: http://hostap.epitest.fi/hostapd/