aboutsummaryrefslogtreecommitdiff
path: root/net/howl/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-01-30 04:03:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-01-30 04:03:36 +0000
commitb25dc0767d7769e97043bcb7f17a6a875dd6bc0b (patch)
treecace19d8561d9da69d93c811f9edbaa125a12612 /net/howl/Makefile
parentdccbc5efac63ce01e936b826e2fdebfca58d4a6f (diff)
downloadports-b25dc0767d7769e97043bcb7f17a6a875dd6bc0b.tar.gz
ports-b25dc0767d7769e97043bcb7f17a6a875dd6bc0b.zip
Notes
Diffstat (limited to 'net/howl/Makefile')
-rw-r--r--net/howl/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/net/howl/Makefile b/net/howl/Makefile
index fae96a4d84a6..1f61b91eb741 100644
--- a/net/howl/Makefile
+++ b/net/howl/Makefile
@@ -5,17 +5,17 @@
#
PORTNAME= howl
-PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTVERSION= 0.9.10
CATEGORIES?= net devel
MASTER_SITES= http://www.porchdogsoft.com/download/
-MAINTAINER= paul@aps.org
+MAINTAINER= marcus@FreeBSD.org
COMMENT= Zeroconf/Rendezvous implementation
USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_LIBTOOL_VER=15
+USE_RC_SUBR= yes
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
CPPFLAGS+= ${PTHREAD_CFLAGS}
USE_REINPLACE= yes
@@ -24,16 +24,19 @@ INSTALLS_SHLIB= yes
MAN8= mDNSResponder.8
PLIST_SUB= VERSION="${PORTVERSION}"
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-CPPFLAGS+= -D_LP64
-.endif
+RC_SCRIPTS_SUB= RC_SUBR=${RC_SUBR} PREFIX=${PREFIX}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+post-extract:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/mdnsresponder.sh > ${WRKSRC}/mdnsresponder.sh
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread||g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mdnsresponder.sh \
+ ${PREFIX}/etc/rc.d/mdnsresponder.sh
+
+.include <bsd.port.mk>