aboutsummaryrefslogtreecommitdiff
path: root/net/hsflowd
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2017-05-18 20:07:30 +0000
committerAlex Kozlov <ak@FreeBSD.org>2017-05-18 20:07:30 +0000
commitf32d6877bf4a070d54aac18cc28fc7a924bcc02d (patch)
tree2990ce23b051d3dbd6601987a4dbc04429fd678b /net/hsflowd
parentb98443d2c13bee58a0ff81e0e07a641a74e91373 (diff)
downloadports-f32d6877bf4a070d54aac18cc28fc7a924bcc02d.tar.gz
ports-f32d6877bf4a070d54aac18cc28fc7a924bcc02d.zip
- Fix build with bmake
- Remove SF from MASTER_SITES, upstream moved to github, but there is no distfile for 1.24.1 on it PR: 218831 Approved by: zi (maintainer)
Notes
Notes: svn path=/head/; revision=441196
Diffstat (limited to 'net/hsflowd')
-rw-r--r--net/hsflowd/Makefile4
-rw-r--r--net/hsflowd/files/patch-src_FreeBSD_Makefile38
2 files changed, 39 insertions, 3 deletions
diff --git a/net/hsflowd/Makefile b/net/hsflowd/Makefile
index 607af78c0bfe..233b875365c3 100644
--- a/net/hsflowd/Makefile
+++ b/net/hsflowd/Makefile
@@ -4,13 +4,11 @@
PORTNAME= hsflowd
PORTVERSION= 1.24.1
CATEGORIES= net
-MASTER_SITES= SF/host-sflow/Latest/ \
- http://mirrors.rit.edu/zi/
+MASTER_SITES= http://mirrors.rit.edu/zi/
MAINTAINER= zi@FreeBSD.org
COMMENT= Agent that exports metrics using the sFlow protocol
-USES= fmake
SUB_FILES= pkg-message
USE_RC_SUBR= ${PORTNAME}
MAKE_ENV= BINDIR=${PREFIX}/sbin INITDIR=${PREFIX}/etc/rc.d \
diff --git a/net/hsflowd/files/patch-src_FreeBSD_Makefile b/net/hsflowd/files/patch-src_FreeBSD_Makefile
new file mode 100644
index 000000000000..7db06ec2c9bf
--- /dev/null
+++ b/net/hsflowd/files/patch-src_FreeBSD_Makefile
@@ -0,0 +1,38 @@
+--- src/FreeBSD/Makefile.orig 2017-03-13 18:07:09 UTC
++++ src/FreeBSD/Makefile
+@@ -1,22 +1,22 @@
+ # This software is distributed under the following license:
+ # http://host-sflow.sourceforge.net/license.html
+
+-.if empty $(BINDIR)
++.if empty(BINDIR)
+ BINDIR=/usr/sbin
+ .endif
+
+-.if empty $(INITDIR)
++.if empty(INITDIR)
+ INITDIR=/etc/rc.d
+ .endif
+
+-.if empty $(CONFDIR)
++.if empty(CONFDIR)
+ CONFDIR=/etc
+ .endif
+
+ INSTALL=install
+
+ # INSTROOT may be passed in, e.g. RPM_BUILD_ROOT
+-.if empty $(INSTROOT)
++.if empty(INSTROOT)
+ BIN_D=$(BINDIR)
+ INIT_D=$(INITDIR)
+ CONF_D=$(CONFDIR)
+@@ -36,7 +36,7 @@ CC= gcc -std=gnu99
+ OPT_FULL = -O3 -DNDEBUG
+ OPT_DEBUG = -g -ggdb
+
+-.if empty $(OPT)
++.if empty(OPT)
+ OPT=$(OPT_FULL)
+ .endif
+