aboutsummaryrefslogtreecommitdiff
path: root/net/htpdate
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2019-08-12 23:07:37 +0000
committerJason Helfman <jgh@FreeBSD.org>2019-08-12 23:07:37 +0000
commit7d13de561d3d66b9c47731182cf0272186ea85ae (patch)
tree917fd6b6c6c1ae00878650005eb774bd45b7589b /net/htpdate
parentb2a5beeb2b76a8329fde912462c526434fc313f0 (diff)
downloadports-7d13de561d3d66b9c47731182cf0272186ea85ae.tar.gz
ports-7d13de561d3d66b9c47731182cf0272186ea85ae.zip
Notes
Diffstat (limited to 'net/htpdate')
-rw-r--r--net/htpdate/Makefile2
-rw-r--r--net/htpdate/files/patch-README11
-rw-r--r--net/htpdate/files/patch-htpdate.835
-rw-r--r--net/htpdate/files/patch-htpdate.c16
4 files changed, 63 insertions, 1 deletions
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index 53e6a46cc934..c118e40be093 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -3,7 +3,7 @@
PORTNAME= htpdate
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://www.vervest.org/htp/archive/c/ \
http://twekkel.home.xs4all.nl/htp/
diff --git a/net/htpdate/files/patch-README b/net/htpdate/files/patch-README
new file mode 100644
index 000000000000..dbf1923d8277
--- /dev/null
+++ b/net/htpdate/files/patch-README
@@ -0,0 +1,11 @@
+--- README.orig 2019-08-12 22:50:17 UTC
++++ README
+@@ -42,7 +42,7 @@ Usage: htpdate [-046abdhlqstxD] [-i pid file] [-m minp
+ [-p precision] [-P <proxyserver>[:port]] [-u user[:group]]
+ <host[:port]> ...
+
+- E.g. htpdate -q www.linux.org www.freebsd.org
++ E.g. htpdate -q www.example.com
+
+
+ In general, if more web servers are specified, the accuracy will increase.
diff --git a/net/htpdate/files/patch-htpdate.8 b/net/htpdate/files/patch-htpdate.8
new file mode 100644
index 000000000000..4fff86dbca48
--- /dev/null
+++ b/net/htpdate/files/patch-htpdate.8
@@ -0,0 +1,35 @@
+--- htpdate.8.orig 2019-08-12 22:48:12 UTC
++++ htpdate.8
+@@ -80,15 +80,15 @@ Portnumber (default 80 and 8080 for proxy server)
+ .SH "EXAMPLES"
+ Request time from web server (don't update local clock):
+ .br
+-\& htpdate \-q www.linux.org www.freebsd.org
++\& htpdate \-q www.example.com
+ .P
+ Verbose output (don't update local clock):
+ .br
+-\& htpdate \-d \-q www.linux.org www.freebsd.org
++\& htpdate \-d \-q www.example.com
+ .P
+ Adjust time smoothly and log output to syslog (eg. cron):
+ .br
+-\& htpdate \-a \-l www.linux.org www.freebsd.org
++\& htpdate \-a \-l www.example.com
+ .P
+ HTTP/1.0 request in IPv6 literal format (RFC 2732):
+ .br
+@@ -96,11 +96,11 @@ HTTP/1.0 request in IPv6 literal format (RFC 2732):
+ .P
+ Run htpdate as daemon:
+ .br
+-\& htpdate \-D www.linux.org www.freebsd.org
++\& htpdate \-D www.example.com
+ .P
+ Daemon mode for the security minded:
+ .br
+-\& htpdate \-D \-u nobody:nogroup www.linux.org www.freebsd.org
++\& htpdate \-D \-u nobody:nogroup www.example.com
+ .SH "AUTHOR"
+ Eddy Vervest <eddy@vervest.org>, http://www.vervest.org/htp
+ .SH "SEE ALSO"
diff --git a/net/htpdate/files/patch-htpdate.c b/net/htpdate/files/patch-htpdate.c
new file mode 100644
index 000000000000..aa00ce17ec67
--- /dev/null
+++ b/net/htpdate/files/patch-htpdate.c
@@ -0,0 +1,16 @@
+--- htpdate.c.orig 2019-08-12 22:48:19 UTC
++++ htpdate.c
+@@ -14,11 +14,11 @@
+ Debug mode (shows raw timestamps, round trip time (RTT) and
+ time difference):
+
+- ~# htpdate -d www.linux.org www.freebsd.org
++ ~# htpdate -d www.example.com
+
+ Adjust time smoothly:
+
+- ~# htpdate -a www.linux.org www.freebsd.org
++ ~# htpdate -a www.example.com
+
+ ...see man page for more details
+