aboutsummaryrefslogtreecommitdiff
path: root/net/httping
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-02 14:15:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-02 14:15:52 +0000
commitb2270f715e09eb2e0520ebdb376f19238b69996d (patch)
treef8541ea9bd06d2caa7166c685342620698273dd4 /net/httping
parente592f676dad7066556dbc7520cbd86f28be01621 (diff)
downloadports-b2270f715e09eb2e0520ebdb376f19238b69996d.tar.gz
ports-b2270f715e09eb2e0520ebdb376f19238b69996d.zip
Update to 2.3.3
Notes
Notes: svn path=/head/; revision=329048
Diffstat (limited to 'net/httping')
-rw-r--r--net/httping/Makefile6
-rw-r--r--net/httping/distinfo4
-rw-r--r--net/httping/files/patch-Makefile17
3 files changed, 16 insertions, 11 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 982159793805..f3db025de8ba 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= httping
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.3.3
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
@@ -12,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Ping-like tool for HTTP requests
-USES= gmake
+USES= gmake gettext
MAN1= httping.1
PLIST_FILES= bin/httping
@@ -22,6 +21,7 @@ OPTIONS_DEFINE= NCURSES FFTW SSL
OPTIONS_DEFAULT=NCURSES SSL
NO_STAGE= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNCURSES}
diff --git a/net/httping/distinfo b/net/httping/distinfo
index 586e4887e342..27194d8c8d09 100644
--- a/net/httping/distinfo
+++ b/net/httping/distinfo
@@ -1,2 +1,2 @@
-SHA256 (httping-2.2.1.tgz) = b5f34b1ce5a83177fc58a9c5032daa43e625271936af6d919e00f2a48cd9e541
-SIZE (httping-2.2.1.tgz) = 33104
+SHA256 (httping-2.3.3.tgz) = 00d44796a6b2efea6f071458bce943aee8f4c3b32fc14e8ab7f026ded3ec2cf8
+SIZE (httping-2.3.3.tgz) = 54376
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
index 6442e0c8b02d..24e2c1bfa04b 100644
--- a/net/httping/files/patch-Makefile
+++ b/net/httping/files/patch-Makefile
@@ -1,20 +1,25 @@
---- ./Makefile.orig 2013-04-17 22:46:50.000000000 +0200
-+++ ./Makefile 2013-04-17 23:49:01.771634044 +0200
+--- ./Makefile.orig 2013-06-07 15:18:52.000000000 +0200
++++ ./Makefile 2013-10-02 16:10:24.583316212 +0200
@@ -13,8 +13,6 @@
# files in the program, then also delete it here.
- # $Revision: 178 $
+ # $Revision: 268 $
--include makefile.inc
-
# *** configure script ***
# support for tcp fast open?
#TFO=yes
-@@ -31,7 +29,7 @@
+@@ -33,11 +31,11 @@
- TARGET=httping
+ LOCALEDIR=/usr/share/locale
-DEBUG=yes
+DEBUG?=no
WFLAGS=-Wall -W
OFLAGS=
- CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
+ CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\" -DLOCALEDIR=\"$(LOCALEDIR)\"
+-LDFLAGS+=-lm
++LDFLAGS+=-lm -lintl
+
+ PACKAGE=$(TARGET)-$(VERSION)
+ PREFIX?=/usr