aboutsummaryrefslogtreecommitdiff
path: root/net/httping
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-01-10 22:06:16 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-01-10 22:06:16 +0000
commitcd4dd5764da7e7170bb5f493be18f9816ca5bcb8 (patch)
treefa1c09751fa5e5d599c9675f1fa69493cb280feb /net/httping
parent452ef51165a3fae98fbd995833a16c8901cbc7e0 (diff)
downloadports-cd4dd5764da7e7170bb5f493be18f9816ca5bcb8.tar.gz
ports-cd4dd5764da7e7170bb5f493be18f9816ca5bcb8.zip
- Update to 1.4.1
- Unbreak port Special thanks: Folkert van Heusden <folkert@vanheusden.com> (author)
Notes
Notes: svn path=/head/; revision=247542
Diffstat (limited to 'net/httping')
-rw-r--r--net/httping/Makefile6
-rw-r--r--net/httping/distinfo6
-rw-r--r--net/httping/files/extra-patch-str.c15
-rw-r--r--net/httping/files/extra-patch-str.h11
-rw-r--r--net/httping/files/patch-Makefile20
5 files changed, 10 insertions, 48 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index ea2cf1d1952a..ba9a1113492c 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httping
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
@@ -23,10 +23,8 @@ PLIST_FILES= bin/httping
.include <bsd.port.pre.mk>
-BROKEN= does not function correctly, a solution is in progress
-
.if(${OSVERSION} >= 701101)
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-str.c ${FILESDIR}/extra-patch-str.h
+CFLAGS+= -D_GNU_SOURCE
.endif
do-install:
diff --git a/net/httping/distinfo b/net/httping/distinfo
index de22e7cc2559..42ed6b7555c6 100644
--- a/net/httping/distinfo
+++ b/net/httping/distinfo
@@ -1,3 +1,3 @@
-MD5 (httping-1.4.0.tgz) = d2bd46b12c6f2bcb5ec27bb44afd95b0
-SHA256 (httping-1.4.0.tgz) = 20975ba55b53c59dafaf1947a7b04d48608a7c13754ee81ae4e342761a9f4c1b
-SIZE (httping-1.4.0.tgz) = 13634
+MD5 (httping-1.4.1.tgz) = bde1ff3c01343d2371d8f34fbf8a1d9a
+SHA256 (httping-1.4.1.tgz) = cbd238777f975d837bbb8a64448bc5a7d79ac671ce320d60fcc2532c9b2ca4b8
+SIZE (httping-1.4.1.tgz) = 13699
diff --git a/net/httping/files/extra-patch-str.c b/net/httping/files/extra-patch-str.c
deleted file mode 100644
index b066992a2eb4..000000000000
--- a/net/httping/files/extra-patch-str.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./str.c.orig 2009-12-28 14:41:29.000000000 +0100
-+++ ./str.c 2009-12-28 14:41:55.000000000 +0100
-@@ -18,6 +18,7 @@
- #include "mem.h"
- #include "utils.h"
-
-+/*
- #ifndef _GNU_SOURCE
- char *strndup(char *in, int size)
- {
-@@ -29,3 +30,4 @@
- return out;
- }
- #endif
-+*/
diff --git a/net/httping/files/extra-patch-str.h b/net/httping/files/extra-patch-str.h
deleted file mode 100644
index 0c850baed61d..000000000000
--- a/net/httping/files/extra-patch-str.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./str.h.orig 2009-12-28 14:41:13.000000000 +0100
-+++ ./str.h 2009-12-28 14:41:23.000000000 +0100
-@@ -15,6 +15,8 @@
-
- #include <string.h>
-
-+/*
- #ifndef strndup
- char *strndup(char *in, int size);
- #endif
-+*/
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
index 2afb7e9e1fdb..622e8d442761 100644
--- a/net/httping/files/patch-Makefile
+++ b/net/httping/files/patch-Makefile
@@ -1,22 +1,12 @@
---- Makefile.orig 2009-12-28 20:52:20.000000000 +0100
-+++ Makefile 2009-12-28 20:53:00.000000000 +0100
-@@ -16,9 +16,7 @@
-
+--- ./Makefile.orig 2010-01-10 22:58:57.000000000 +0100
++++ ./Makefile 2010-01-10 22:59:30.000000000 +0100
+@@ -17,8 +17,7 @@
TARGET=httping
--WFLAGS=-Wall -W
+ WFLAGS=-Wall -W
-OFLAGS=-O2
-CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
-+CFLAGS+= -DVERSION=\"$(VERSION)\"
++CFLAGS+=$(WFLAGS) -DVERSION=\"$(VERSION)\"
PACKAGE=$(TARGET)-$(VERSION)
PREFIX=/usr
-@@ -62,7 +60,7 @@
- all: $(TARGET)
-
- $(TARGET): $(OBJS)
-- $(CC) $(WFLAGS) $(OBJS) $(LDFLAGS) -o $(TARGET)
-+ $(CC) $(OBJS) $(LDFLAGS) -o $(TARGET)
- #
- # Oh, blatant plug: http://keetweej.vanheusden.com/wishlist.html
-