aboutsummaryrefslogtreecommitdiff
path: root/net/httpry/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2012-08-07 18:37:01 +0000
committerWesley Shields <wxs@FreeBSD.org>2012-08-07 18:37:01 +0000
commit7bc4c72e78d2b32a90843c2740be23343bf64042 (patch)
treeb06eb523fb0b8f5b55a340193767af62df26870c /net/httpry/Makefile
parentea2f88b436d450d7509e707f4e72c9c2b7f65574 (diff)
downloadports-7bc4c72e78d2b32a90843c2740be23343bf64042.tar.gz
ports-7bc4c72e78d2b32a90843c2740be23343bf64042.zip
Notes
Diffstat (limited to 'net/httpry/Makefile')
-rw-r--r--net/httpry/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/httpry/Makefile b/net/httpry/Makefile
index d3a8be438157..792bc91f09ee 100644
--- a/net/httpry/Makefile
+++ b/net/httpry/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= httpry
-PORTVERSION= 0.1.5
+PORTVERSION= 0.1.7
CATEGORIES= net
MASTER_SITES= http://dumpsterventures.com/jason/httpry/
@@ -18,11 +18,12 @@ MAN1= httpry.1
USE_RC_SUBR= httpry
MAKE_JOBS_SAFE= yes
-OPTIONS= EXTRASCRIPTS "Install additional scripts" Off
+OPTIONS_DEFINE= EXTRASCRIPTS
+EXTRASCRIPTS_DESC= Install additional scripts
.include <bsd.port.pre.mk>
-.if defined(WITH_EXTRASCRIPTS)
+.if ${PORT_OPTIONS:MEXTRASCRIPTS}
PLIST_SUB= EXTRASCRIPTS=""
USE_PERL5_RUN= yes
RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
@@ -36,7 +37,7 @@ PLIST_SUB= EXTRASCRIPTS="@comment "
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
-.if defined(WITH_EXTRASCRIPTS)
+.if ${PORT_OPTIONS:MEXTRASCRIPTS}
${MKDIR} ${PREFIX}/bin/httpry-scripts
(cd ${WRKSRC}/scripts/ && \
${COPYTREE_BIN} \* ${PREFIX}/bin/httpry-scripts "! -name *.bak")