aboutsummaryrefslogtreecommitdiff
path: root/net/httpry/files
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-06-13 23:41:46 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-06-13 23:41:46 +0000
commit9308e76c8ee2e44157c12b9f9d77e5597322f494 (patch)
treef09a9f37680cc58c56d249462d01f687db4cbb99 /net/httpry/files
parentaf0631e91b00d2b2abd52ffcd9ba0a1caae31bd8 (diff)
Notes
Diffstat (limited to 'net/httpry/files')
-rw-r--r--net/httpry/files/httpry.in30
-rw-r--r--net/httpry/files/patch-Makefile12
2 files changed, 42 insertions, 0 deletions
diff --git a/net/httpry/files/httpry.in b/net/httpry/files/httpry.in
new file mode 100644
index 000000000000..f01f9b04ccbc
--- /dev/null
+++ b/net/httpry/files/httpry.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: httpry
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable httpry:
+#
+# httpry_enable (bool): Set it to "YES" to enable httpry
+# Default is "NO".
+# httpry_flags (flags): Set extra flags to httpry
+# Default is "-d -q -o /var/log/httpry.log".
+# See httpry(1) for more information.
+#
+
+. %%RC_SUBR%%
+
+name=httpry
+rcvar=${name}_enable
+
+load_rc_config $name
+
+: ${httpry_enable="NO"}
+: ${httpry_flags="-d -q -o /var/log/httpry.log"}
+
+command=%%PREFIX%%/bin/httpry
+
+run_rc_command "$1"
diff --git a/net/httpry/files/patch-Makefile b/net/httpry/files/patch-Makefile
new file mode 100644
index 000000000000..6c1bc281aa66
--- /dev/null
+++ b/net/httpry/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- ./Makefile.orig 2008-02-08 00:48:09.000000000 -0500
++++ ./Makefile 2008-06-12 18:53:14.000000000 -0400
+@@ -6,8 +6,7 @@
+ # Copyright (c) 2005-2008 Jason Bittel <jason.bittel@gmail.com>
+ #
+
+-CC = gcc
+-CCFLAGS = -Wall -O3 -funroll-loops -I/usr/include/pcap -I/usr/local/include/pcap
++CCFLAGS = ${CFLAGS} -I/usr/include/pcap -I/usr/local/include/pcap
+ DEBUGFLAGS = -Wall -g -DDEBUG -I/usr/include/pcap -I/usr/local/include/pcap
+ LIBS = -lpcap
+ PROG = httpry