aboutsummaryrefslogtreecommitdiff
path: root/net/ifstat
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-23 09:59:45 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-23 09:59:45 +0000
commitcf508b5e7551ccde7a8e711b52ef2d92a781a4e5 (patch)
tree01d26970b7ba64e013cd96bc66e87c371a686b49 /net/ifstat
parent15128d1d3830e89012358f0a9561882354a8ee1c (diff)
downloadports-cf508b5e7551ccde7a8e711b52ef2d92a781a4e5.tar.gz
ports-cf508b5e7551ccde7a8e711b52ef2d92a781a4e5.zip
1: Stagify.
2: new syntax of LIB_DEPENDS. 3: use option helper. Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=358916
Diffstat (limited to 'net/ifstat')
-rw-r--r--net/ifstat/Makefile14
-rw-r--r--net/ifstat/files/patch-Makefile.in17
2 files changed, 20 insertions, 11 deletions
diff --git a/net/ifstat/Makefile b/net/ifstat/Makefile
index c192b1c8a025..662b1c76e7d8 100644
--- a/net/ifstat/Makefile
+++ b/net/ifstat/Makefile
@@ -15,17 +15,9 @@ GNU_CONFIGURE= yes
USE_OPENSSL= yes
OPTIONS_DEFINE= SNMP
+SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+SNMP_CONFIGURE_WITH= snmp
-MAN1= ifstat.1
-PLIST_FILES= bin/ifstat
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSNMP}
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
-.else
-CONFIGURE_ARGS+= --without-snmp
-.endif
+PLIST_FILES= bin/ifstat man/man1/ifstat.1.gz
.include <bsd.port.mk>
diff --git a/net/ifstat/files/patch-Makefile.in b/net/ifstat/files/patch-Makefile.in
new file mode 100644
index 000000000000..6372bffcd9fe
--- /dev/null
+++ b/net/ifstat/files/patch-Makefile.in
@@ -0,0 +1,17 @@
+--- Makefile.in.orig 2014-06-23 17:54:49.793422514 +0800
++++ Makefile.in 2014-06-23 17:56:06.824418432 +0800
+@@ -65,10 +65,10 @@ libifstat-config: libifstat-config.in
+ install: install-$(TARGET) install-@LIBTARGET@
+
+ install-$(TARGET): $(TARGET)
+- $(INSTALL) -d -m 755 $(bindir)
+- $(INSTALL) -s -m 755 $(TARGET) $(bindir)/$(TARGET)
+- $(INSTALL) -d -m 755 $(mandir)/man1
+- $(INSTALL) -m 644 ifstat.1 $(mandir)/man1/ifstat.1
++ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
++ $(INSTALL) -s -m 755 $(TARGET) $(DESTDIR)$(bindir)/$(TARGET)
++ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -m 644 ifstat.1 $(DESTDIR)$(mandir)/man1/ifstat.1
+
+ install-$(LIBTARGET): $(LIBTARGET) libifstat-config
+ $(INSTALL) -d -m 755 $(bindir)