aboutsummaryrefslogtreecommitdiff
path: root/net/ip6_int
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-25 09:09:33 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-25 09:09:33 +0000
commitf072ef3d87faf4654323a314cbbd66a75d37e1b3 (patch)
tree613f0ca6f26d41d188099aa720f232d7807f03bd /net/ip6_int
parentd9634a5ac825ca03486cb031283035f857728620 (diff)
downloadports-f072ef3d87faf4654323a314cbbd66a75d37e1b3.tar.gz
ports-f072ef3d87faf4654323a314cbbd66a75d37e1b3.zip
Add ip6_int-1.0, convert an IPv4/IPv6 address to an in-addr.arpa/ip6.int PTR
value PR: 32178 Submitted by: Jean-Yves Lefort <jylefort@twist.frontis.net>
Notes
Notes: svn path=/head/; revision=50519
Diffstat (limited to 'net/ip6_int')
-rw-r--r--net/ip6_int/Makefile31
-rw-r--r--net/ip6_int/distinfo1
-rw-r--r--net/ip6_int/pkg-comment1
-rw-r--r--net/ip6_int/pkg-descr8
-rw-r--r--net/ip6_int/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/net/ip6_int/Makefile b/net/ip6_int/Makefile
new file mode 100644
index 000000000000..f10c2267ebf9
--- /dev/null
+++ b/net/ip6_int/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ip6_int
+# Date created: 22 November 2001
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ip6_int
+PORTVERSION= 1.0
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.bieringer.de/linux/IPv6/tools/
+DISTNAME= ip6_int
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= jylefort@brutele.be
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+post-patch:
+ @${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/ip6_int
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ip6_int ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/ip6_int/distinfo b/net/ip6_int/distinfo
new file mode 100644
index 000000000000..051f12c6e74e
--- /dev/null
+++ b/net/ip6_int/distinfo
@@ -0,0 +1 @@
+MD5 (ip6_int) = dfa6aa3f4a85051510c682dbe9b20a79
diff --git a/net/ip6_int/pkg-comment b/net/ip6_int/pkg-comment
new file mode 100644
index 000000000000..43a079ea7984
--- /dev/null
+++ b/net/ip6_int/pkg-comment
@@ -0,0 +1 @@
+Convert an IPv4/IPv6 address to an in-addr.arpa/ip6.int PTR value
diff --git a/net/ip6_int/pkg-descr b/net/ip6_int/pkg-descr
new file mode 100644
index 000000000000..a1c8d76e32af
--- /dev/null
+++ b/net/ip6_int/pkg-descr
@@ -0,0 +1,8 @@
+Convert valid IPv6 addresses to ip6.int PTR values. Convert valid
+IPv4 addresses to in-addr.arpa PTR values. Anything not valid is
+simply printed as is. Handles :: notation and embedded IPv4
+addresses. If the address is followed by /n, the PTR is truncated
+to n bits.
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/net/ip6_int/pkg-plist b/net/ip6_int/pkg-plist
new file mode 100644
index 000000000000..8ed6486f69a7
--- /dev/null
+++ b/net/ip6_int/pkg-plist
@@ -0,0 +1 @@
+bin/ip6_int