aboutsummaryrefslogtreecommitdiff
path: root/net/istgt/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-09-03 19:27:45 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-09-03 19:27:45 +0000
commit5d04a3d3628240e9218a9e0f21911ec165b2d7e3 (patch)
tree00678c3dd9d9e1466fca47672f3e1066abce2d84 /net/istgt/Makefile
parentfba658a01077ac8ebe94535da2f9de2c9ae0d122 (diff)
downloadports-5d04a3d3628240e9218a9e0f21911ec165b2d7e3.tar.gz
ports-5d04a3d3628240e9218a9e0f21911ec165b2d7e3.zip
Notes
Diffstat (limited to 'net/istgt/Makefile')
-rw-r--r--net/istgt/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/net/istgt/Makefile b/net/istgt/Makefile
index 4d9a60b45860..575758538fc9 100644
--- a/net/istgt/Makefile
+++ b/net/istgt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= istgt
-PORTVERSION= 20120811
+PORTVERSION= 20120901
CATEGORIES= net
MASTER_SITES= http://www.peach.ne.jp/archives/istgt/
@@ -36,7 +36,7 @@ DOCS= ChangeLog.jp README doc/QUICKSTART doc/QUICKSTART.jp
OPTIONS_DEFINE= SYMLNKDEV VBOXVD
OPTIONS_DEFAULT=
SYMLNKDEV_DESC= Allow symbolic link for device file
-VBOXVD_DESC= Build with VBox VirtualDisk support
+VBOXVD_DESC= Build with VBox VD support(no X11 required)
.include <bsd.port.options.mk>
@@ -45,10 +45,17 @@ CONFIGURE_ARGS+= --enable-symlink-device
.endif
.if ${PORT_OPTIONS:MVBOXVD}
+. if ${OSVERSION} < 802000
+VBOX_WRKSRC= `${MAKE} -C ${PORTSDIR}/emulators/virtualbox-ose-legacy -V WRKSRC`
+RUN_DEPENDS+= ${LOCALBASE}/lib/virtualbox/VBoxRT.so:${PORTSDIR}/emulators/virtualbox-ose-legacy
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/emulators/virtualbox-ose-legacy:patch
+CONFIGURE_ARGS+= --with-vbox=${VBOX_WRKSRC}/include
+. else
VBOX_WRKSRC= `${MAKE} -C ${PORTSDIR}/emulators/virtualbox-ose -V WRKSRC`
RUN_DEPENDS+= ${LOCALBASE}/lib/virtualbox/VBoxRT.so:${PORTSDIR}/emulators/virtualbox-ose
BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/emulators/virtualbox-ose:patch
CONFIGURE_ARGS+= --with-vbox=${VBOX_WRKSRC}/include
+. endif
.endif
post-extract: