aboutsummaryrefslogtreecommitdiff
path: root/net/jose/Makefile
diff options
context:
space:
mode:
authorHoward Holm <hdholm@alumni.iastate.edu>2021-05-10 01:05:46 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-05-10 01:23:51 +0000
commit9ed3c429038c25725a47d5bac72283fc87c4adab (patch)
treeae9fdbd7884b66f436cef32cffac4bd174cbcdca /net/jose/Makefile
parentd729d967a534ac758cc3cd51df7dc209f1207fec (diff)
downloadports-9ed3c429038c25725a47d5bac72283fc87c4adab.tar.gz
ports-9ed3c429038c25725a47d5bac72283fc87c4adab.zip
Diffstat (limited to 'net/jose/Makefile')
-rw-r--r--net/jose/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/jose/Makefile b/net/jose/Makefile
new file mode 100644
index 000000000000..0b2b8a03ab2d
--- /dev/null
+++ b/net/jose/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= jose
+DISTVERSION= 11
+CATEGORIES= net
+
+MAINTAINER= hdholm@alumni.iastate.edu
+COMMENT= Tools for JSON Object Signing and Encryption (JOSE)
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= a2x:textproc/asciidoc
+LIB_DEPENDS= libjansson.so:devel/jansson
+
+USES= compiler:c11 meson ninja pkgconfig ssl
+USE_GITHUB= yes
+GH_ACCOUNT= latchset
+GH_TAGNAME= v11
+USE_LDCONFIG= yes
+
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>