aboutsummaryrefslogtreecommitdiff
path: root/net/kafkacat
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-03-08 18:12:33 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-03-08 18:12:33 +0000
commite1ba414a27601ceac9699fab2999551ec4ae7c8d (patch)
treecaeb496a6de7ec34dc6224f345dd8a2d4976c5e4 /net/kafkacat
parentf25e40b456f17dc0d4b17ff0c6fa17037829c736 (diff)
downloadports-e1ba414a27601ceac9699fab2999551ec4ae7c8d.tar.gz
ports-e1ba414a27601ceac9699fab2999551ec4ae7c8d.zip
net/kafkacat: Update to 1.6.0
New options AVRO and JSON. AVRO broken for now because of upstream problem with pkg-config Changelog: https://github.com/edenhill/kafkacat/releases/tag/1.6.0 PR: 254093 Submitted by: Sergey Akhmatov <sergey@akhmatov.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=567864
Diffstat (limited to 'net/kafkacat')
-rw-r--r--net/kafkacat/Makefile19
-rw-r--r--net/kafkacat/distinfo6
-rw-r--r--net/kafkacat/files/patch-configure11
3 files changed, 19 insertions, 17 deletions
diff --git a/net/kafkacat/Makefile b/net/kafkacat/Makefile
index b671f673f17f..485ab2348699 100644
--- a/net/kafkacat/Makefile
+++ b/net/kafkacat/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= kafkacat
-DISTVERSION= 1.5.0
+DISTVERSION= 1.6.0
CATEGORIES= net
MAINTAINER= sergey@akhmatov.ru
@@ -12,15 +12,28 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash
-LIB_DEPENDS= librdkafka.so:net/librdkafka
+LIB_DEPENDS= librdkafka.so:net/librdkafka \
+ libyajl.so:devel/yajl
USES= gmake pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= edenhill
+GNU_CONFIGURE= yes
+
PLIST_FILES= bin/kafkacat
-GNU_CONFIGURE= yes
+OPTIONS_DEFINE= JSON AVRO
+
+AVRO_DESC= Avro/Schema-Registry support (requires libserdes) [BROKEN]
+JSON_DESC= JSON support (requires libyajl2)
+
+# avro broken due to bug: https://github.com/apache/avro/pull/1018/commits
+AVRO_BROKEN= avro support is currently broken
+AVRO_LIB_DEPENDS= libserdes.so:devel/libserdes
+AVRO_CONFIGURE_ENABLE= avro
+JSON_LIB_DEPENDS= libyajl.so:devel/yajl
+JSON_CONFIGURE_ENABLE= json
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/kafkacat
diff --git a/net/kafkacat/distinfo b/net/kafkacat/distinfo
index 770664e566ee..3e2df2ed6771 100644
--- a/net/kafkacat/distinfo
+++ b/net/kafkacat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1568414384
-SHA256 (edenhill-kafkacat-1.5.0_GH0.tar.gz) = 16f358fab258cbefc328cf642f72ee8b5dae1648657d508997279ca5bd0fbef0
-SIZE (edenhill-kafkacat-1.5.0_GH0.tar.gz) = 124682
+TIMESTAMP = 1595406133
+SHA256 (edenhill-kafkacat-1.6.0_GH0.tar.gz) = e67aecd153659d7ea0d561469a1e65038485fe9a3203fa8c9c59a9fe02164bf0
+SIZE (edenhill-kafkacat-1.6.0_GH0.tar.gz) = 131314
diff --git a/net/kafkacat/files/patch-configure b/net/kafkacat/files/patch-configure
deleted file mode 100644
index 4faa6247ba96..000000000000
--- a/net/kafkacat/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2015-06-18 17:24:07 UTC
-+++ configure
-@@ -38,7 +38,7 @@ mkl_require cc
-
-
- # Load application provided modules (in current directory), if any.
--for fname in configure.* ; do
-+for fname in configure.kafkacat ; do
- if [[ $fname = 'configure.*' ]]; then
- continue
- fi