aboutsummaryrefslogtreecommitdiff
path: root/net/kalarmcal/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
commit39fa5f95a7f2bf0a028e458c3104f66d433200e6 (patch)
treeb52ff8a578bde97936b79f311d6970fac2593475 /net/kalarmcal/Makefile
parent34e997ccb06a8f151001292998a5c99019fa9d5a (diff)
downloadports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.tar.gz
ports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.zip
Notes
Diffstat (limited to 'net/kalarmcal/Makefile')
-rw-r--r--net/kalarmcal/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net/kalarmcal/Makefile b/net/kalarmcal/Makefile
new file mode 100644
index 000000000000..cc5887f24f2d
--- /dev/null
+++ b/net/kalarmcal/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= kalarmcal
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE API for KAlarm alarms
+
+LICENSE= LGPL21
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth bookmarks codecs completion config configwidgets \
+ coreaddons crash ecm guiaddons holidays i18n iconthemes \
+ itemmodels itemviews jobwidgets kdelibs4support kio \
+ notifications parts service solid sonnet textwidgets \
+ unitconversion widgetsaddons windowsystem xmlgui
+# pim components
+USE_KDE+= akonadi calendarcore holidays identitymanagement pimtextedit
+USE_QT5= core dbus gui network printsupport widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+.include <bsd.port.mk>