aboutsummaryrefslogtreecommitdiff
path: root/net/kea
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2018-02-28 04:28:06 +0000
committerHiroki Sato <hrs@FreeBSD.org>2018-02-28 04:28:06 +0000
commita286fcc1b198907d358e8d950620486098180025 (patch)
treef680425f5da358a48df5cdbf4fafbb9899ebfe04 /net/kea
parent8663ef3761433e6d2a02c54a44fcfa6423377f06 (diff)
downloadports-a286fcc1b198907d358e8d950620486098180025.tar.gz
ports-a286fcc1b198907d358e8d950620486098180025.zip
Update to 1.3.0.
Notes
Notes: svn path=/head/; revision=463175
Diffstat (limited to 'net/kea')
-rw-r--r--net/kea/Makefile3
-rw-r--r--net/kea/distinfo6
-rw-r--r--net/kea/files/patch-Makefile.am4
-rw-r--r--net/kea/files/patch-asiolink-boost-1.6686
-rw-r--r--net/kea/files/patch-src-bin-keactrl-Makefile.am16
-rw-r--r--net/kea/files/patch-src-bin-keactrl-keactrl.in6
-rw-r--r--net/kea/files/patch-src-lib-asiolink-io_service.h15
-rw-r--r--net/kea/files/patch-src-lib-asiolink-tcp_socket.h14
-rw-r--r--net/kea/files/patch-src-lib-asiolink-udp_socket.h14
-rw-r--r--net/kea/files/patch-src-lib-asiolink-unix_domain_socket.cc14
-rw-r--r--net/kea/files/patch-src-lib-dhcpsrv-daemon.cc4
-rw-r--r--net/kea/pkg-plist237
12 files changed, 288 insertions, 131 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index 9418ceb4bc7d..73e942dcf171 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= kea
-PORTVERSION= 1.2.0
-PORTREVISION= 4
+PORTVERSION= 1.3.0
CATEGORIES= net ipv6
MASTER_SITES= ISC/kea/${PORTVERSION}
diff --git a/net/kea/distinfo b/net/kea/distinfo
index 430d21f9ce94..a231f2e522c1 100644
--- a/net/kea/distinfo
+++ b/net/kea/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494700153
-SHA256 (kea-1.2.0.tar.gz) = 22d15945b13600b56c37213797ca1f3ee9851e6119120aeae08033c4cc52d129
-SIZE (kea-1.2.0.tar.gz) = 5720941
+TIMESTAMP = 1519785969
+SHA256 (kea-1.3.0.tar.gz) = 6edfcdbf2526c218426a1d1a6a6694a4050c97bb8412953a230285d63415c391
+SIZE (kea-1.3.0.tar.gz) = 5996560
diff --git a/net/kea/files/patch-Makefile.am b/net/kea/files/patch-Makefile.am
index cb0af6bf85b9..f9c9c47b6339 100644
--- a/net/kea/files/patch-Makefile.am
+++ b/net/kea/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2015-12-28 12:18:05 UTC
+--- Makefile.am.orig 2018-02-28 03:44:09 UTC
+++ Makefile.am
-@@ -106,7 +106,7 @@ cppcheck:
+@@ -115,7 +115,7 @@ cppcheck:
# These steps are necessary during installation
install-exec-hook:
mkdir -p $(DESTDIR)${localstatedir}/log/
diff --git a/net/kea/files/patch-asiolink-boost-1.66 b/net/kea/files/patch-asiolink-boost-1.66
deleted file mode 100644
index a2667986f005..000000000000
--- a/net/kea/files/patch-asiolink-boost-1.66
+++ /dev/null
@@ -1,86 +0,0 @@
-From 4fd11ef050438adeb1e0ae0d9d2d8ec3a2cb659c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <bpiotrowski@archlinux.org>
-Date: Sat, 30 Dec 2017 14:40:24 +0100
-Subject: [PATCH] asiolink: fix build with boost 1.66
-
-- use native_handle() for getting native socket type
-- use io_context instead of io_service
----
- src/lib/asiolink/io_acceptor.h | 4 ++++
- src/lib/asiolink/io_service.h | 5 +++++
- src/lib/asiolink/tcp_socket.h | 4 ++++
- src/lib/asiolink/udp_socket.h | 4 ++++
- src/lib/asiolink/unix_domain_socket.cc | 4 ++++
- 5 files changed, 21 insertions(+)
-
---- src/lib/asiolink/io_service.h.orig 2017-04-24 23:28:20 UTC
-+++ src/lib/asiolink/io_service.h
-@@ -11,7 +11,12 @@
-
- namespace boost {
- namespace asio {
-+#if BOOST_VERSION < 106600
- class io_service;
-+#else
-+ class io_context;
-+ typedef io_context io_service;
-+#endif
- }
- }
-
---- src/lib/asiolink/tcp_acceptor.h.orig 2017-04-24 23:28:20 UTC
-+++ src/lib/asiolink/tcp_acceptor.h
-@@ -44,7 +44,11 @@ class TCPAcceptor : public IOSocket { (public)
-
- /// @brief Returns file descriptor of the underlying socket.
- virtual int getNative() const final {
-+#if BOOST_VERSION < 106600
- return (acceptor_->native());
-+#else
-+ return (acceptor_->native_handle());
-+#endif
- }
-
- /// @brief Returns protocol of the socket.
---- src/lib/asiolink/tcp_socket.h.orig 2017-04-24 23:28:20 UTC
-+++ src/lib/asiolink/tcp_socket.h
-@@ -75,7 +75,11 @@ class TCPSocket : public IOAsioSocket<C> { (public)
-
- /// \brief Return file descriptor of underlying socket
- virtual int getNative() const {
-+#if BOOST_VERSION < 106600
- return (socket_.native());
-+#else
-+ return (socket_.native_handle());
-+#endif
- }
-
- /// \brief Return protocol of socket
---- src/lib/asiolink/udp_socket.h.orig 2017-04-24 23:28:20 UTC
-+++ src/lib/asiolink/udp_socket.h
-@@ -61,7 +61,11 @@ class UDPSocket : public IOAsioSocket<C> { (public)
-
- /// \brief Return file descriptor of underlying socket
- virtual int getNative() const {
-+#if BOOST_VERSION < 106600
- return (socket_.native());
-+#else
-+ return (socket_.native_handle());
-+#endif
- }
-
- /// \brief Return protocol of socket
---- src/lib/asiolink/unix_domain_socket.cc.orig 2017-04-24 23:28:20 UTC
-+++ src/lib/asiolink/unix_domain_socket.cc
-@@ -48,7 +48,11 @@ UnixDomainSocket::UnixDomainSocket(IOService& io_servi
-
- int
- UnixDomainSocket::getNative() const {
-+#if BOOST_VERSION < 106600
- return (impl_->socket_.native());
-+#else
-+ return (impl_->socket_.native_handle());
-+#endif
- }
-
- int
diff --git a/net/kea/files/patch-src-bin-keactrl-Makefile.am b/net/kea/files/patch-src-bin-keactrl-Makefile.am
index 9225868bc42f..ca5bf96af5f1 100644
--- a/net/kea/files/patch-src-bin-keactrl-Makefile.am
+++ b/net/kea/files/patch-src-bin-keactrl-Makefile.am
@@ -1,11 +1,11 @@
---- src/bin/keactrl/Makefile.am.orig 2015-12-28 12:18:05 UTC
+--- src/bin/keactrl/Makefile.am.orig 2018-02-28 03:44:09 UTC
+++ src/bin/keactrl/Makefile.am
-@@ -38,7 +38,7 @@ install-data-local:
- $(mkinstalldirs) $(DESTDIR)/@sysconfdir@/@PACKAGE@
- for f in $(CONFIGFILES) ; do \
- if test ! -f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$$f; then \
-- ${INSTALL_DATA} $$f $(DESTDIR)$(sysconfdir)/@PACKAGE@/ ; \
-+ ${INSTALL_DATA} $$f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$${f}.sample ; \
- fi ; \
+@@ -68,7 +68,7 @@ install-data-local:
+ $(DESTDIR)$(sysconfdir)/@PACKAGE@/$$f.bak; \
+ fi; \
+ if test ! -f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$$f; then \
+- ${INSTALL_DATA} $$f $(DESTDIR)$(sysconfdir)/@PACKAGE@/; \
++ ${INSTALL_DATA} $$f $(DESTDIR)$(sysconfdir)/@PACKAGE@/$${f}.sample; \
+ fi; \
done
diff --git a/net/kea/files/patch-src-bin-keactrl-keactrl.in b/net/kea/files/patch-src-bin-keactrl-keactrl.in
index 49bfe53de92c..fad3137ccec0 100644
--- a/net/kea/files/patch-src-bin-keactrl-keactrl.in
+++ b/net/kea/files/patch-src-bin-keactrl-keactrl.in
@@ -1,6 +1,6 @@
---- src/bin/keactrl/keactrl.in.orig 2015-12-28 12:18:45 UTC
+--- src/bin/keactrl/keactrl.in.orig 2017-10-24 21:57:38 UTC
+++ src/bin/keactrl/keactrl.in
-@@ -69,7 +69,7 @@ get_pid_from_file() {
+@@ -85,7 +85,7 @@ get_pid_from_file() {
local conf_name=$(basename ${kea_config_file} | cut -f1 -d'.')
# Default the directory to --localstatedir
@@ -9,7 +9,7 @@
# Use directory override if set (primarily for testing only)
if [ ! -z $KEA_PIDFILE_DIR ]; then
-@@ -252,7 +252,7 @@ check_kea_conf() {
+@@ -271,7 +271,7 @@ run_conditional() {
# to the default file.
if [ -z ${KEA_LOGGER_DESTINATION} ]; then
prefix=@prefix@
diff --git a/net/kea/files/patch-src-lib-asiolink-io_service.h b/net/kea/files/patch-src-lib-asiolink-io_service.h
new file mode 100644
index 000000000000..d1974622743a
--- /dev/null
+++ b/net/kea/files/patch-src-lib-asiolink-io_service.h
@@ -0,0 +1,15 @@
+--- src/lib/asiolink/io_service.h.orig 2017-10-05 13:00:03 UTC
++++ src/lib/asiolink/io_service.h
+@@ -11,7 +11,12 @@
+
+ namespace boost {
+ namespace asio {
++#if BOOST_VERSION < 106600
+ class io_service;
++#else
++ class io_context;
++ typedef io_context io_service;
++#endif
+ }
+ }
+
diff --git a/net/kea/files/patch-src-lib-asiolink-tcp_socket.h b/net/kea/files/patch-src-lib-asiolink-tcp_socket.h
new file mode 100644
index 000000000000..709a2bf65c5e
--- /dev/null
+++ b/net/kea/files/patch-src-lib-asiolink-tcp_socket.h
@@ -0,0 +1,14 @@
+--- src/lib/asiolink/tcp_socket.h.orig 2017-10-05 13:00:03 UTC
++++ src/lib/asiolink/tcp_socket.h
+@@ -75,7 +75,11 @@ public:
+
+ /// \brief Return file descriptor of underlying socket
+ virtual int getNative() const {
++#if BOOST_VERSION < 106600
+ return (socket_.native());
++#else
++ return (socket_.native_handle());
++#endif
+ }
+
+ /// \brief Return protocol of socket
diff --git a/net/kea/files/patch-src-lib-asiolink-udp_socket.h b/net/kea/files/patch-src-lib-asiolink-udp_socket.h
new file mode 100644
index 000000000000..565687b9e986
--- /dev/null
+++ b/net/kea/files/patch-src-lib-asiolink-udp_socket.h
@@ -0,0 +1,14 @@
+--- src/lib/asiolink/udp_socket.h.orig 2017-10-05 13:00:03 UTC
++++ src/lib/asiolink/udp_socket.h
+@@ -61,7 +61,11 @@ public:
+
+ /// \brief Return file descriptor of underlying socket
+ virtual int getNative() const {
++#if BOOST_VERSION < 106600
+ return (socket_.native());
++#else
++ return (socket_.native_handle());
++#endif
+ }
+
+ /// \brief Return protocol of socket
diff --git a/net/kea/files/patch-src-lib-asiolink-unix_domain_socket.cc b/net/kea/files/patch-src-lib-asiolink-unix_domain_socket.cc
new file mode 100644
index 000000000000..3ea798690f25
--- /dev/null
+++ b/net/kea/files/patch-src-lib-asiolink-unix_domain_socket.cc
@@ -0,0 +1,14 @@
+--- src/lib/asiolink/unix_domain_socket.cc.orig 2017-10-05 13:00:03 UTC
++++ src/lib/asiolink/unix_domain_socket.cc
+@@ -287,7 +287,11 @@ UnixDomainSocket::UnixDomainSocket(IOSer
+
+ int
+ UnixDomainSocket::getNative() const {
++#if BOOST_VERSION < 106600
+ return (impl_->socket_.native());
++#else
++ return (impl_->socket_.native_handle());
++#endif
+ }
+
+ int
diff --git a/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc b/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc
index 1189ec61dd19..b06310126ebe 100644
--- a/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc
+++ b/net/kea/files/patch-src-lib-dhcpsrv-daemon.cc
@@ -1,6 +1,6 @@
---- src/lib/dhcpsrv/daemon.cc.orig 2015-12-28 12:18:45 UTC
+--- src/lib/dhcpsrv/daemon.cc.orig 2017-10-05 13:00:04 UTC
+++ src/lib/dhcpsrv/daemon.cc
-@@ -28,7 +28,7 @@ namespace dhcp {
+@@ -29,7 +29,7 @@ namespace dhcp {
Daemon::Daemon()
: signal_set_(), signal_handler_(), config_file_(""), proc_name_(""),
diff --git a/net/kea/pkg-plist b/net/kea/pkg-plist
index 19884247c765..aa2c7861c85f 100644
--- a/net/kea/pkg-plist
+++ b/net/kea/pkg-plist
@@ -1,21 +1,46 @@
bin/kea-msg-compiler
+include/kea/asiodns/io_fetch.h
+include/kea/asiodns/logger.h
include/kea/asiolink/asio_wrapper.h
include/kea/asiolink/asiolink.h
+include/kea/asiolink/dummy_io_cb.h
include/kea/asiolink/interval_timer.h
+include/kea/asiolink/io_acceptor.h
include/kea/asiolink/io_address.h
include/kea/asiolink/io_asio_socket.h
include/kea/asiolink/io_endpoint.h
include/kea/asiolink/io_error.h
include/kea/asiolink/io_service.h
include/kea/asiolink/io_socket.h
+include/kea/asiolink/tcp_acceptor.h
include/kea/asiolink/tcp_endpoint.h
include/kea/asiolink/tcp_socket.h
include/kea/asiolink/udp_endpoint.h
include/kea/asiolink/udp_socket.h
+include/kea/asiolink/unix_domain_socket.h
+include/kea/asiolink/unix_domain_socket_acceptor.h
+include/kea/asiolink/unix_domain_socket_endpoint.h
include/kea/cc/cfg_to_element.h
+include/kea/cc/command_interpreter.h
include/kea/cc/data.h
include/kea/cc/dhcp_config_error.h
+include/kea/cc/json_feed.h
+include/kea/cc/simple_parser.h
+include/kea/cfgrpt/config_report.h
include/kea/config.h
+include/kea/config/base_command_mgr.h
+include/kea/config/client_connection.h
+include/kea/config/cmds_impl.h
+include/kea/config/command_mgr.h
+include/kea/config/config_data.h
+include/kea/config/config_log.h
+include/kea/config/hooked_command_mgr.h
+include/kea/config/module_spec.h
+include/kea/cryptolink/crypto_hash.h
+include/kea/cryptolink/crypto_hmac.h
+include/kea/cryptolink/cryptolink.h
+include/kea/cryptolink/openssl_common.h
+include/kea/cryptolink/openssl_compat.h
include/kea/dhcp/classify.h
include/kea/dhcp/dhcp4.h
include/kea/dhcp/dhcp6.h
@@ -35,6 +60,7 @@ include/kea/dhcp/option6_client_fqdn.h
include/kea/dhcp/option6_ia.h
include/kea/dhcp/option6_iaaddr.h
include/kea/dhcp/option6_iaprefix.h
+include/kea/dhcp/option6_pdexclude.h
include/kea/dhcp/option6_status_code.h
include/kea/dhcp/option_custom.h
include/kea/dhcp/option_data_types.h
@@ -56,112 +82,269 @@ include/kea/dhcp/pkt_filter6.h
include/kea/dhcp/pkt_filter_bpf.h
include/kea/dhcp/pkt_filter_inet.h
include/kea/dhcp/pkt_filter_inet6.h
-include/kea/dhcp/pkt_filter_lpf.h
include/kea/dhcp/protocol_util.h
include/kea/dhcp/std_option_defs.h
+include/kea/dhcp_ddns/dhcp_ddns_log.h
include/kea/dhcp_ddns/ncr_io.h
include/kea/dhcp_ddns/ncr_msg.h
include/kea/dhcp_ddns/ncr_udp.h
+include/kea/dhcpsrv/addr_utilities.h
+include/kea/dhcpsrv/alloc_engine.h
+include/kea/dhcpsrv/alloc_engine_log.h
+include/kea/dhcpsrv/assignable_network.h
+include/kea/dhcpsrv/base_host_data_source.h
+include/kea/dhcpsrv/callout_handle_store.h
include/kea/dhcpsrv/cfg_4o6.h
+include/kea/dhcpsrv/cfg_db_access.h
+include/kea/dhcpsrv/cfg_duid.h
+include/kea/dhcpsrv/cfg_expiration.h
+include/kea/dhcpsrv/cfg_host_operations.h
+include/kea/dhcpsrv/cfg_hosts.h
+include/kea/dhcpsrv/cfg_hosts_util.h
+include/kea/dhcpsrv/cfg_iface.h
+include/kea/dhcpsrv/cfg_mac_source.h
include/kea/dhcpsrv/cfg_option.h
+include/kea/dhcpsrv/cfg_option_def.h
+include/kea/dhcpsrv/cfg_rsoo.h
+include/kea/dhcpsrv/cfg_shared_networks.h
+include/kea/dhcpsrv/cfg_subnets4.h
+include/kea/dhcpsrv/cfg_subnets6.h
+include/kea/dhcpsrv/cfgmgr.h
+include/kea/dhcpsrv/client_class_def.h
+include/kea/dhcpsrv/csv_lease_file4.h
+include/kea/dhcpsrv/csv_lease_file6.h
include/kea/dhcpsrv/d2_client_cfg.h
include/kea/dhcpsrv/d2_client_mgr.h
+include/kea/dhcpsrv/daemon.h
+include/kea/dhcpsrv/database_connection.h
+include/kea/dhcpsrv/db_exceptions.h
+include/kea/dhcpsrv/dhcp4o6_ipc.h
+include/kea/dhcpsrv/dhcpsrv_log.h
+include/kea/dhcpsrv/host.h
+include/kea/dhcpsrv/host_container.h
+include/kea/dhcpsrv/host_data_source_factory.h
+include/kea/dhcpsrv/host_mgr.h
+include/kea/dhcpsrv/hosts_log.h
include/kea/dhcpsrv/key_from_key.h
include/kea/dhcpsrv/lease.h
+include/kea/dhcpsrv/lease_file_loader.h
+include/kea/dhcpsrv/lease_file_stats.h
+include/kea/dhcpsrv/lease_mgr.h
+include/kea/dhcpsrv/lease_mgr_factory.h
+include/kea/dhcpsrv/logging.h
+include/kea/dhcpsrv/logging_info.h
+include/kea/dhcpsrv/memfile_lease_mgr.h
+include/kea/dhcpsrv/memfile_lease_storage.h
include/kea/dhcpsrv/ncr_generator.h
+include/kea/dhcpsrv/network.h
+include/kea/dhcpsrv/parsers/client_class_def_parser.h
+include/kea/dhcpsrv/parsers/dbaccess_parser.h
+include/kea/dhcpsrv/parsers/dhcp_parsers.h
+include/kea/dhcpsrv/parsers/duid_config_parser.h
+include/kea/dhcpsrv/parsers/expiration_config_parser.h
+include/kea/dhcpsrv/parsers/host_reservation_parser.h
+include/kea/dhcpsrv/parsers/host_reservations_list_parser.h
+include/kea/dhcpsrv/parsers/ifaces_config_parser.h
+include/kea/dhcpsrv/parsers/option_data_parser.h
+include/kea/dhcpsrv/parsers/shared_network_parser.h
+include/kea/dhcpsrv/parsers/shared_networks_list_parser.h
+include/kea/dhcpsrv/parsers/simple_parser4.h
+include/kea/dhcpsrv/parsers/simple_parser6.h
include/kea/dhcpsrv/pool.h
+include/kea/dhcpsrv/shared_network.h
+include/kea/dhcpsrv/srv_config.h
include/kea/dhcpsrv/subnet.h
include/kea/dhcpsrv/subnet_id.h
+include/kea/dhcpsrv/subnet_selector.h
+include/kea/dhcpsrv/timer_mgr.h
include/kea/dhcpsrv/triplet.h
+include/kea/dhcpsrv/utils.h
+include/kea/dhcpsrv/writable_host_data_source.h
include/kea/dns/dns_fwd.h
include/kea/dns/edns.h
include/kea/dns/exceptions.h
include/kea/dns/labelsequence.h
include/kea/dns/master_lexer.h
+include/kea/dns/master_lexer_inputsource.h
+include/kea/dns/master_lexer_state.h
include/kea/dns/master_loader.h
include/kea/dns/master_loader_callbacks.h
include/kea/dns/masterload.h
include/kea/dns/message.h
include/kea/dns/messagerenderer.h
include/kea/dns/name.h
+include/kea/dns/nsec3hash.h
include/kea/dns/opcode.h
include/kea/dns/question.h
include/kea/dns/rcode.h
include/kea/dns/rdata.h
+include/kea/dns/rdata_pimpl_holder.h
+include/kea/dns/rdataclass.h
+include/kea/dns/rdatafields.h
+include/kea/dns/rrclass.h
+include/kea/dns/rrcollator.h
include/kea/dns/rrparamregistry.h
include/kea/dns/rrset.h
include/kea/dns/rrset_collection.h
include/kea/dns/rrset_collection_base.h
include/kea/dns/rrttl.h
+include/kea/dns/rrtype.h
+include/kea/dns/serial.h
+include/kea/dns/tsig.h
+include/kea/dns/tsigerror.h
include/kea/dns/tsigkey.h
+include/kea/dns/tsigrecord.h
include/kea/dns/zone_checker.h
+include/kea/eval/eval_context.h
+include/kea/eval/eval_context_decl.h
+include/kea/eval/eval_log.h
+include/kea/eval/evaluate.h
+include/kea/eval/parser.h
+include/kea/eval/token.h
include/kea/exceptions/exceptions.h
include/kea/hooks/callout_handle.h
include/kea/hooks/callout_manager.h
include/kea/hooks/hooks.h
+include/kea/hooks/hooks_config.h
+include/kea/hooks/hooks_log.h
+include/kea/hooks/hooks_manager.h
+include/kea/hooks/hooks_parser.h
+include/kea/hooks/libinfo.h
include/kea/hooks/library_handle.h
+include/kea/hooks/library_manager.h
+include/kea/hooks/library_manager_collection.h
+include/kea/hooks/pointer_converter.h
include/kea/hooks/server_hooks.h
+include/kea/http/connection.h
+include/kea/http/connection_pool.h
+include/kea/http/date_time.h
+include/kea/http/header_context.h
+include/kea/http/http_acceptor.h
include/kea/http/http_log.h
+include/kea/http/http_types.h
+include/kea/http/listener.h
+include/kea/http/post_request.h
+include/kea/http/post_request_json.h
+include/kea/http/request.h
+include/kea/http/request_context.h
+include/kea/http/request_parser.h
+include/kea/http/response.h
+include/kea/http/response_creator.h
+include/kea/http/response_creator_factory.h
+include/kea/http/response_json.h
+include/kea/log/buffer_appender_impl.h
+include/kea/log/interprocess/interprocess_sync.h
+include/kea/log/interprocess/interprocess_sync_file.h
+include/kea/log/interprocess/interprocess_sync_null.h
include/kea/log/log_dbglevels.h
include/kea/log/log_formatter.h
+include/kea/log/log_messages.h
include/kea/log/logger.h
+include/kea/log/logger_impl.h
include/kea/log/logger_level.h
+include/kea/log/logger_level_impl.h
+include/kea/log/logger_manager.h
+include/kea/log/logger_manager_impl.h
+include/kea/log/logger_name.h
+include/kea/log/logger_specification.h
+include/kea/log/logger_support.h
+include/kea/log/logger_unittest_support.h
+include/kea/log/logimpl_messages.h
include/kea/log/macros.h
+include/kea/log/message_dictionary.h
+include/kea/log/message_exception.h
include/kea/log/message_initializer.h
+include/kea/log/message_reader.h
include/kea/log/message_types.h
+include/kea/log/output_option.h
include/kea/process/d_cfg_mgr.h
include/kea/process/d_controller.h
include/kea/process/d_log.h
include/kea/process/d_process.h
include/kea/process/io_service_signal.h
+include/kea/stats/context.h
+include/kea/stats/observation.h
include/kea/stats/stats_mgr.h
+include/kea/util/boost_time_utils.h
include/kea/util/buffer.h
+include/kea/util/csv_file.h
+include/kea/util/encode/base16_from_binary.h
+include/kea/util/encode/base32hex.h
+include/kea/util/encode/base32hex_from_binary.h
+include/kea/util/encode/base64.h
+include/kea/util/encode/binary_from_base16.h
+include/kea/util/encode/binary_from_base32hex.h
+include/kea/util/encode/hex.h
+include/kea/util/filename.h
+include/kea/util/io/fd.h
+include/kea/util/io/fd_share.h
+include/kea/util/io/pktinfo_utilities.h
+include/kea/util/io/sockaddr_util.h
+include/kea/util/io/socketsession.h
include/kea/util/io_utilities.h
+include/kea/util/labeled_value.h
+include/kea/util/memory_segment.h
+include/kea/util/memory_segment_local.h
include/kea/util/optional_value.h
+include/kea/util/pid_file.h
include/kea/util/pointer_util.h
+include/kea/util/process_spawn.h
+include/kea/util/random/qid_gen.h
+include/kea/util/random/random_number_generator.h
+include/kea/util/range_utilities.h
+include/kea/util/signal_set.h
include/kea/util/staged_value.h
+include/kea/util/state_model.h
include/kea/util/stopwatch.h
+include/kea/util/stopwatch_impl.h
include/kea/util/strutil.h
+include/kea/util/threads/sync.h
+include/kea/util/threads/thread.h
+include/kea/util/time_utilities.h
+include/kea/util/versioned_csv_file.h
+include/kea/util/watch_socket.h
+lib/hooks/libdhcp_lease_cmds.a
+lib/hooks/libdhcp_lease_cmds.so
lib/libkea-asiodns.a
lib/libkea-asiodns.so
lib/libkea-asiodns.so.0
-lib/libkea-asiodns.so.0.0.0
+lib/libkea-asiodns.so.0.0.1
lib/libkea-asiolink.a
lib/libkea-asiolink.so
-lib/libkea-asiolink.so.4
-lib/libkea-asiolink.so.4.0.0
+lib/libkea-asiolink.so.5
+lib/libkea-asiolink.so.5.0.0
lib/libkea-cc.a
lib/libkea-cc.so
-lib/libkea-cc.so.2
-lib/libkea-cc.so.2.0.0
+lib/libkea-cc.so.3
+lib/libkea-cc.so.3.0.0
lib/libkea-cfgclient.a
lib/libkea-cfgclient.so
-lib/libkea-cfgclient.so.3
-lib/libkea-cfgclient.so.3.0.0
+lib/libkea-cfgclient.so.4
+lib/libkea-cfgclient.so.4.0.0
lib/libkea-cryptolink.a
lib/libkea-cryptolink.so
lib/libkea-cryptolink.so.2
lib/libkea-cryptolink.so.2.0.0
lib/libkea-dhcp++.a
lib/libkea-dhcp++.so
-lib/libkea-dhcp++.so.5
-lib/libkea-dhcp++.so.5.0.0
+lib/libkea-dhcp++.so.6
+lib/libkea-dhcp++.so.6.0.0
lib/libkea-dhcp_ddns.a
lib/libkea-dhcp_ddns.so
lib/libkea-dhcp_ddns.so.1
lib/libkea-dhcp_ddns.so.1.0.2
lib/libkea-dhcpsrv.a
lib/libkea-dhcpsrv.so
-lib/libkea-dhcpsrv.so.7
-lib/libkea-dhcpsrv.so.7.0.0
+lib/libkea-dhcpsrv.so.8
+lib/libkea-dhcpsrv.so.8.0.0
lib/libkea-dns++.a
lib/libkea-dns++.so
-lib/libkea-dns++.so.0
-lib/libkea-dns++.so.0.1.1
+lib/libkea-dns++.so.2
+lib/libkea-dns++.so.2.0.0
lib/libkea-eval.a
lib/libkea-eval.so
-lib/libkea-eval.so.5
-lib/libkea-eval.so.5.0.0
+lib/libkea-eval.so.6
+lib/libkea-eval.so.6.0.0
lib/libkea-exceptions.a
lib/libkea-exceptions.so
lib/libkea-exceptions.so.0
@@ -169,23 +352,23 @@ lib/libkea-exceptions.so.0.0.0
lib/libkea-hooks.a
lib/libkea-hooks.so
lib/libkea-hooks.so.3
-lib/libkea-hooks.so.3.0.0
+lib/libkea-hooks.so.3.1.0
lib/libkea-http.a
lib/libkea-http.so
lib/libkea-http.so.0
-lib/libkea-http.so.0.0.0
+lib/libkea-http.so.0.0.1
lib/libkea-log.a
lib/libkea-log.so
lib/libkea-log.so.3
lib/libkea-log.so.3.0.0
lib/libkea-process.a
lib/libkea-process.so
-lib/libkea-process.so.0
-lib/libkea-process.so.0.0.0
+lib/libkea-process.so.1
+lib/libkea-process.so.1.0.0
lib/libkea-stats.a
lib/libkea-stats.so
-lib/libkea-stats.so.1
-lib/libkea-stats.so.1.0.0
+lib/libkea-stats.so.2
+lib/libkea-stats.so.2.0.0
lib/libkea-threads.a
lib/libkea-threads.so
lib/libkea-threads.so.1
@@ -205,7 +388,6 @@ man/man8/kea-dhcp-ddns.8.gz
man/man8/kea-dhcp4.8.gz
man/man8/kea-dhcp6.8.gz
man/man8/kea-lfc.8.gz
-man/man8/kea-shell.8.gz
man/man8/keactrl.8.gz
man/man8/perfdhcp.8.gz
sbin/kea-admin
@@ -222,6 +404,7 @@ sbin/perfdhcp
%%DATADIR%%/scripts/admin-utils.sh
%%DATADIR%%/scripts/cql/dhcpdb_create.cql
%%DATADIR%%/scripts/cql/dhcpdb_drop.cql
+%%DATADIR%%/scripts/cql/soft_wipe.cql
%%DATADIR%%/scripts/mysql/dhcpdb_create.mysql
%%DATADIR%%/scripts/mysql/dhcpdb_drop.mysql
%%DATADIR%%/scripts/mysql/upgrade_1.0_to_2.0.sh
@@ -229,11 +412,15 @@ sbin/perfdhcp
%%DATADIR%%/scripts/mysql/upgrade_3.0_to_4.0.sh
%%DATADIR%%/scripts/mysql/upgrade_4.0_to_4.1.sh
%%DATADIR%%/scripts/mysql/upgrade_4.1_to_5.0.sh
+%%DATADIR%%/scripts/mysql/upgrade_5.0_to_5.1.sh
%%DATADIR%%/scripts/pgsql/dhcpdb_create.pgsql
%%DATADIR%%/scripts/pgsql/dhcpdb_drop.pgsql
%%DATADIR%%/scripts/pgsql/upgrade_1.0_to_2.0.sh
%%DATADIR%%/scripts/pgsql/upgrade_2.0_to_3.0.sh
-@sample %%ETCDIR%%/kea-ca.conf.sample
-@sample %%ETCDIR%%/kea.conf.sample
+%%DATADIR%%/scripts/pgsql/upgrade_3.0_to_3.1.sh
+@sample %%ETCDIR%%/kea-ctrl-agent.conf.sample
+@sample %%ETCDIR%%/kea-dhcp-ddns.conf.sample
+@sample %%ETCDIR%%/kea-dhcp4.conf.sample
+@sample %%ETCDIR%%/kea-dhcp6.conf.sample
@sample %%ETCDIR%%/keactrl.conf.sample
@dir /var/db/kea