aboutsummaryrefslogtreecommitdiff
path: root/net/kmailtransport
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
commit39fa5f95a7f2bf0a028e458c3104f66d433200e6 (patch)
treeb52ff8a578bde97936b79f311d6970fac2593475 /net/kmailtransport
parent34e997ccb06a8f151001292998a5c99019fa9d5a (diff)
downloadports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.tar.gz
ports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.zip
New ports: KDE Applications net/ and dependencies
* deskutils/grantleetheme * deskutils/kdepim * deskutils/kdepim-apps-libs * deskutils/libkdepim * net/akonadi-calendar * net/akonadi-contacts * net/akonadi-mime * net/akonadi-notes * net/akonadi-search * net/calendarsupport * net/eventviews * net/incidenceeditor * net/kalarmcal * net/kblog * net/kcalcore * net/kcalutils * net/kcontacts * net/kdav * net/kdenetwork-filesharing * net/kget * net/kidentitymanagement * net/kimap * net/kldap * net/kmailtransport * net/kmbox * net/kmime * net/kontactinterface * net/kpimtextedit * net/krdc * net/krfb * net/ksmtp * net/ktnef * net/libgravatar * net/libkgapi * net/libksieve * net/mailcommon * net/mailimporter * net/messagelib * net/pimcommon * net/zeroconf-ioslave * security/libkleo This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This adds a slew of KDE Pim related ports and some of their dependencies. Note, that KDE Pim has a history of working poorly on FreeBSD.
Notes
Notes: svn path=/head/; revision=467007
Diffstat (limited to 'net/kmailtransport')
-rw-r--r--net/kmailtransport/Makefile25
-rw-r--r--net/kmailtransport/distinfo3
-rw-r--r--net/kmailtransport/pkg-plist111
3 files changed, 139 insertions, 0 deletions
diff --git a/net/kmailtransport/Makefile b/net/kmailtransport/Makefile
new file mode 100644
index 000000000000..5a77ecfec53c
--- /dev/null
+++ b/net/kmailtransport/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= kmailtransport
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE library to managing mail transport
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons i18n \
+ itemmodels jobwidgets kcmutils kio service wallet widgetsaddons
+# pim components
+USE_KDE+= akonadi akonadimime ksmtp mime
+USE_QT5= core dbus gui network widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/net/kmailtransport/distinfo b/net/kmailtransport/distinfo
new file mode 100644
index 000000000000..a61b44abcbe9
--- /dev/null
+++ b/net/kmailtransport/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519219
+SHA256 (KDE/applications/17.12.3/kmailtransport-17.12.3.tar.xz) = c09d049e3f0285b8809662ce2c76d2c4d1848abb0a8f956b13d105a3baf03e8c
+SIZE (KDE/applications/17.12.3/kmailtransport-17.12.3.tar.xz) = 164804
diff --git a/net/kmailtransport/pkg-plist b/net/kmailtransport/pkg-plist
new file mode 100644
index 000000000000..ffcd1e171ae9
--- /dev/null
+++ b/net/kmailtransport/pkg-plist
@@ -0,0 +1,111 @@
+etc/xdg/kmailtransport.categories
+etc/xdg/kmailtransport.renamecategories
+include/KF5/MailTransport/PrecommandJob
+include/KF5/MailTransport/ServerTest
+include/KF5/MailTransport/Transport
+include/KF5/MailTransport/TransportAbstractPlugin
+include/KF5/MailTransport/TransportComboBox
+include/KF5/MailTransport/TransportConfigWidget
+include/KF5/MailTransport/TransportJob
+include/KF5/MailTransport/TransportManagementWidget
+include/KF5/MailTransport/TransportManager
+include/KF5/MailTransport/TransportType
+include/KF5/MailTransportAkonadi/DispatchModeAttribute
+include/KF5/MailTransportAkonadi/DispatcherInterface
+include/KF5/MailTransportAkonadi/ErrorAttribute
+include/KF5/MailTransportAkonadi/MessageQueueJob
+include/KF5/MailTransportAkonadi/SentActionAttribute
+include/KF5/MailTransportAkonadi/SentBehaviourAttribute
+include/KF5/MailTransportAkonadi/TransportAttribute
+include/KF5/mailtransport/mailtransport_export.h
+include/KF5/mailtransport/precommandjob.h
+include/KF5/mailtransport/private/transportconfigwidget_p.h
+include/KF5/mailtransport/servertest.h
+include/KF5/mailtransport/transport.h
+include/KF5/mailtransport/transportabstractplugin.h
+include/KF5/mailtransport/transportbase.h
+include/KF5/mailtransport/transportcombobox.h
+include/KF5/mailtransport/transportconfigwidget.h
+include/KF5/mailtransport/transportjob.h
+include/KF5/mailtransport/transportmanagementwidget.h
+include/KF5/mailtransport/transportmanager.h
+include/KF5/mailtransport/transporttype.h
+include/KF5/mailtransport_version.h
+include/KF5/mailtransportakonadi/dispatcherinterface.h
+include/KF5/mailtransportakonadi/dispatchmodeattribute.h
+include/KF5/mailtransportakonadi/errorattribute.h
+include/KF5/mailtransportakonadi/mailtransportakonadi_export.h
+include/KF5/mailtransportakonadi/messagequeuejob.h
+include/KF5/mailtransportakonadi/sentactionattribute.h
+include/KF5/mailtransportakonadi/sentbehaviourattribute.h
+include/KF5/mailtransportakonadi/transportattribute.h
+include/KF5/mailtransportakonadi_version.h
+lib/cmake/KF5MailTransport/FindSasl2.cmake
+lib/cmake/KF5MailTransport/KF5MailTransportConfig.cmake
+lib/cmake/KF5MailTransport/KF5MailTransportConfigVersion.cmake
+lib/cmake/KF5MailTransport/KF5MailTransportTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5MailTransport/KF5MailTransportTargets.cmake
+lib/cmake/KF5MailTransportAkonadi/KF5MailTransportAkonadiConfig.cmake
+lib/cmake/KF5MailTransportAkonadi/KF5MailTransportAkonadiConfigVersion.cmake
+lib/cmake/KF5MailTransportAkonadi/KF5MailTransportAkonadiTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5MailTransportAkonadi/KF5MailTransportAkonadiTargets.cmake
+lib/libKF5MailTransport.so
+lib/libKF5MailTransport.so.5
+lib/libKF5MailTransport.so.%%KDE_APPLICATIONS_SHLIB_VER%%
+lib/libKF5MailTransportAkonadi.so
+lib/libKF5MailTransportAkonadi.so.5
+lib/libKF5MailTransportAkonadi.so.%%KDE_APPLICATIONS_SHLIB_VER%%
+%%QT_PLUGINDIR%%/mailtransport/mailtransport_akonadiplugin.so
+%%QT_PLUGINDIR%%/mailtransport/mailtransport_smtpplugin.so
+%%QT_MKSPECDIR%%/modules/qt_KMailTransport.pri
+%%QT_MKSPECDIR%%/modules/qt_KMailTransportAkonadi.pri
+%%QT_PLUGINDIR%%/kcm_mailtransport.so
+share/config.kcfg/mailtransport.kcfg
+share/kservices5/kcm_mailtransport.desktop
+share/locale/ar/LC_MESSAGES/libmailtransport5.mo
+share/locale/ast/LC_MESSAGES/libmailtransport5.mo
+share/locale/bs/LC_MESSAGES/libmailtransport5.mo
+share/locale/ca/LC_MESSAGES/libmailtransport5.mo
+share/locale/ca@valencia/LC_MESSAGES/libmailtransport5.mo
+share/locale/cs/LC_MESSAGES/libmailtransport5.mo
+share/locale/da/LC_MESSAGES/libmailtransport5.mo
+share/locale/de/LC_MESSAGES/libmailtransport5.mo
+share/locale/el/LC_MESSAGES/libmailtransport5.mo
+share/locale/en_GB/LC_MESSAGES/libmailtransport5.mo
+share/locale/eo/LC_MESSAGES/libmailtransport5.mo
+share/locale/es/LC_MESSAGES/libmailtransport5.mo
+share/locale/et/LC_MESSAGES/libmailtransport5.mo
+share/locale/fi/LC_MESSAGES/libmailtransport5.mo
+share/locale/fr/LC_MESSAGES/libmailtransport5.mo
+share/locale/ga/LC_MESSAGES/libmailtransport5.mo
+share/locale/gl/LC_MESSAGES/libmailtransport5.mo
+share/locale/hi/LC_MESSAGES/libmailtransport5.mo
+share/locale/hu/LC_MESSAGES/libmailtransport5.mo
+share/locale/ia/LC_MESSAGES/libmailtransport5.mo
+share/locale/it/LC_MESSAGES/libmailtransport5.mo
+share/locale/ja/LC_MESSAGES/libmailtransport5.mo
+share/locale/kk/LC_MESSAGES/libmailtransport5.mo
+share/locale/km/LC_MESSAGES/libmailtransport5.mo
+share/locale/ko/LC_MESSAGES/libmailtransport5.mo
+share/locale/lt/LC_MESSAGES/libmailtransport5.mo
+share/locale/lv/LC_MESSAGES/libmailtransport5.mo
+share/locale/mr/LC_MESSAGES/libmailtransport5.mo
+share/locale/nb/LC_MESSAGES/libmailtransport5.mo
+share/locale/nds/LC_MESSAGES/libmailtransport5.mo
+share/locale/nl/LC_MESSAGES/libmailtransport5.mo
+share/locale/nn/LC_MESSAGES/libmailtransport5.mo
+share/locale/pa/LC_MESSAGES/libmailtransport5.mo
+share/locale/pl/LC_MESSAGES/libmailtransport5.mo
+share/locale/pt/LC_MESSAGES/libmailtransport5.mo
+share/locale/pt_BR/LC_MESSAGES/libmailtransport5.mo
+share/locale/ro/LC_MESSAGES/libmailtransport5.mo
+share/locale/ru/LC_MESSAGES/libmailtransport5.mo
+share/locale/sk/LC_MESSAGES/libmailtransport5.mo
+share/locale/sl/LC_MESSAGES/libmailtransport5.mo
+share/locale/sr/LC_MESSAGES/libmailtransport5.mo
+share/locale/sv/LC_MESSAGES/libmailtransport5.mo
+share/locale/tr/LC_MESSAGES/libmailtransport5.mo
+share/locale/ug/LC_MESSAGES/libmailtransport5.mo
+share/locale/uk/LC_MESSAGES/libmailtransport5.mo
+share/locale/zh_CN/LC_MESSAGES/libmailtransport5.mo
+share/locale/zh_TW/LC_MESSAGES/libmailtransport5.mo