aboutsummaryrefslogtreecommitdiff
path: root/net/kpimtextedit
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:09:05 +0000
commit39fa5f95a7f2bf0a028e458c3104f66d433200e6 (patch)
treeb52ff8a578bde97936b79f311d6970fac2593475 /net/kpimtextedit
parent34e997ccb06a8f151001292998a5c99019fa9d5a (diff)
downloadports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.tar.gz
ports-39fa5f95a7f2bf0a028e458c3104f66d433200e6.zip
New ports: KDE Applications net/ and dependencies
* deskutils/grantleetheme * deskutils/kdepim * deskutils/kdepim-apps-libs * deskutils/libkdepim * net/akonadi-calendar * net/akonadi-contacts * net/akonadi-mime * net/akonadi-notes * net/akonadi-search * net/calendarsupport * net/eventviews * net/incidenceeditor * net/kalarmcal * net/kblog * net/kcalcore * net/kcalutils * net/kcontacts * net/kdav * net/kdenetwork-filesharing * net/kget * net/kidentitymanagement * net/kimap * net/kldap * net/kmailtransport * net/kmbox * net/kmime * net/kontactinterface * net/kpimtextedit * net/krdc * net/krfb * net/ksmtp * net/ktnef * net/libgravatar * net/libkgapi * net/libksieve * net/mailcommon * net/mailimporter * net/messagelib * net/pimcommon * net/zeroconf-ioslave * security/libkleo This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This adds a slew of KDE Pim related ports and some of their dependencies. Note, that KDE Pim has a history of working poorly on FreeBSD.
Notes
Notes: svn path=/head/; revision=467007
Diffstat (limited to 'net/kpimtextedit')
-rw-r--r--net/kpimtextedit/Makefile24
-rw-r--r--net/kpimtextedit/distinfo3
-rw-r--r--net/kpimtextedit/pkg-plist127
3 files changed, 154 insertions, 0 deletions
diff --git a/net/kpimtextedit/Makefile b/net/kpimtextedit/Makefile
new file mode 100644
index 000000000000..881b9f0b7e6c
--- /dev/null
+++ b/net/kpimtextedit/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= kpimtextedit
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= net kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE library for PIM-specific text editing utilities
+
+LICENSE= LGPL21
+
+USES= cmake:outsource compiler:c++11-lib gettext grantlee:5 kde:5 tar:xz
+USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
+ emoticons i18n iconthemes init itemmodels itemviews jobwidgets \
+ kdelibs4support kio service sonnet syntaxhighlighting textwidgets \
+ widgetsaddons xmlgui
+USE_QT5= core dbus gui network speech widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+
+.include <bsd.port.mk>
diff --git a/net/kpimtextedit/distinfo b/net/kpimtextedit/distinfo
new file mode 100644
index 000000000000..04e8a0bf6063
--- /dev/null
+++ b/net/kpimtextedit/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519212
+SHA256 (KDE/applications/17.12.3/kpimtextedit-17.12.3.tar.xz) = 2c3d8793959e30e306aafaac1b9ef8c1a9a94872e92b1b271d28e001350cce2c
+SIZE (KDE/applications/17.12.3/kpimtextedit-17.12.3.tar.xz) = 141572
diff --git a/net/kpimtextedit/pkg-plist b/net/kpimtextedit/pkg-plist
new file mode 100644
index 000000000000..d843049f42ce
--- /dev/null
+++ b/net/kpimtextedit/pkg-plist
@@ -0,0 +1,127 @@
+etc/xdg/kpimtextedit.categories
+include/KF5/KPIMTextEdit/KPIMTextEdit/AbstractTextToSpeechInterface
+include/KF5/KPIMTextEdit/KPIMTextEdit/EditorUtil
+include/KF5/KPIMTextEdit/KPIMTextEdit/EmoticonTextEditAction
+include/KF5/KPIMTextEdit/KPIMTextEdit/InsertHtmlDialog
+include/KF5/KPIMTextEdit/KPIMTextEdit/InsertImageDialog
+include/KF5/KPIMTextEdit/KPIMTextEdit/InsertImageWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/InsertTableDialog
+include/KF5/KPIMTextEdit/KPIMTextEdit/InsertTableWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/PlainTextEditFindBar
+include/KF5/KPIMTextEdit/KPIMTextEdit/PlainTextEditor
+include/KF5/KPIMTextEdit/KPIMTextEdit/PlainTextEditorWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/PlainTextSyntaxSpellCheckingHighlighter
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextComposer
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextComposerActions
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextComposerControler
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextComposerEmailQuoteHighlighter
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextComposerImages
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextComposerWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextEditor
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextEditorWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/RichTextExternalComposer
+include/KF5/KPIMTextEdit/KPIMTextEdit/SelectSpecialCharDialog
+include/KF5/KPIMTextEdit/KPIMTextEdit/SlideContainer
+include/KF5/KPIMTextEdit/KPIMTextEdit/TableActionMenu
+include/KF5/KPIMTextEdit/KPIMTextEdit/TableCellFormatDialog
+include/KF5/KPIMTextEdit/KPIMTextEdit/TableFormatDialog
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextEditFindBarBase
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextEditorCompleter
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextGotoLineWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextToSpeech
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextToSpeechActions
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextToSpeechInterface
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextToSpeechWidget
+include/KF5/KPIMTextEdit/KPIMTextEdit/TextUtils
+include/KF5/KPIMTextEdit/kpimtextedit/abstracttexttospeechinterface.h
+include/KF5/KPIMTextEdit/kpimtextedit/config-kpimtextedit.h
+include/KF5/KPIMTextEdit/kpimtextedit/editorutil.h
+include/KF5/KPIMTextEdit/kpimtextedit/emoticontexteditaction.h
+include/KF5/KPIMTextEdit/kpimtextedit/inserthtmldialog.h
+include/KF5/KPIMTextEdit/kpimtextedit/insertimagedialog.h
+include/KF5/KPIMTextEdit/kpimtextedit/insertimagewidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/inserttabledialog.h
+include/KF5/KPIMTextEdit/kpimtextedit/inserttablewidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/kpimtextedit_export.h
+include/KF5/KPIMTextEdit/kpimtextedit/plaintexteditfindbar.h
+include/KF5/KPIMTextEdit/kpimtextedit/plaintexteditor.h
+include/KF5/KPIMTextEdit/kpimtextedit/plaintexteditorwidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/plaintextsyntaxspellcheckinghighlighter.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextcomposer.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextcomposeractions.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextcomposercontroler.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextcomposeremailquotehighlighter.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextcomposerimages.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextcomposerwidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtexteditor.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtexteditorwidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/richtextexternalcomposer.h
+include/KF5/KPIMTextEdit/kpimtextedit/selectspecialchardialog.h
+include/KF5/KPIMTextEdit/kpimtextedit/slidecontainer.h
+include/KF5/KPIMTextEdit/kpimtextedit/tableactionmenu.h
+include/KF5/KPIMTextEdit/kpimtextedit/tablecellformatdialog.h
+include/KF5/KPIMTextEdit/kpimtextedit/tableformatdialog.h
+include/KF5/KPIMTextEdit/kpimtextedit/texteditfindbarbase.h
+include/KF5/KPIMTextEdit/kpimtextedit/texteditorcompleter.h
+include/KF5/KPIMTextEdit/kpimtextedit/textgotolinewidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/texttospeech.h
+include/KF5/KPIMTextEdit/kpimtextedit/texttospeechactions.h
+include/KF5/KPIMTextEdit/kpimtextedit/texttospeechinterface.h
+include/KF5/KPIMTextEdit/kpimtextedit/texttospeechwidget.h
+include/KF5/KPIMTextEdit/kpimtextedit/textutils.h
+include/KF5/kpimtextedit_version.h
+lib/cmake/KF5PimTextEdit/KF5PimTextEditConfig.cmake
+lib/cmake/KF5PimTextEdit/KF5PimTextEditConfigVersion.cmake
+lib/cmake/KF5PimTextEdit/KF5PimTextEditTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KF5PimTextEdit/KF5PimTextEditTargets.cmake
+lib/libKF5PimTextEdit.so
+lib/libKF5PimTextEdit.so.5
+lib/libKF5PimTextEdit.so.%%KDE_APPLICATIONS_SHLIB_VER%%
+%%QT_MKSPECDIR%%/modules/qt_KPIMTextEdit.pri
+%%QT_PLUGINDIR%%/designer/kpimtexteditwidgets.so
+share/locale/ar/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ast/LC_MESSAGES/libkpimtextedit.mo
+share/locale/bs/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ca/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ca@valencia/LC_MESSAGES/libkpimtextedit.mo
+share/locale/cs/LC_MESSAGES/libkpimtextedit.mo
+share/locale/da/LC_MESSAGES/libkpimtextedit.mo
+share/locale/de/LC_MESSAGES/libkpimtextedit.mo
+share/locale/el/LC_MESSAGES/libkpimtextedit.mo
+share/locale/en_GB/LC_MESSAGES/libkpimtextedit.mo
+share/locale/eo/LC_MESSAGES/libkpimtextedit.mo
+share/locale/es/LC_MESSAGES/libkpimtextedit.mo
+share/locale/et/LC_MESSAGES/libkpimtextedit.mo
+share/locale/fi/LC_MESSAGES/libkpimtextedit.mo
+share/locale/fr/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ga/LC_MESSAGES/libkpimtextedit.mo
+share/locale/gl/LC_MESSAGES/libkpimtextedit.mo
+share/locale/hu/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ia/LC_MESSAGES/libkpimtextedit.mo
+share/locale/it/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ja/LC_MESSAGES/libkpimtextedit.mo
+share/locale/kk/LC_MESSAGES/libkpimtextedit.mo
+share/locale/km/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ko/LC_MESSAGES/libkpimtextedit.mo
+share/locale/lt/LC_MESSAGES/libkpimtextedit.mo
+share/locale/lv/LC_MESSAGES/libkpimtextedit.mo
+share/locale/mr/LC_MESSAGES/libkpimtextedit.mo
+share/locale/nb/LC_MESSAGES/libkpimtextedit.mo
+share/locale/nds/LC_MESSAGES/libkpimtextedit.mo
+share/locale/nl/LC_MESSAGES/libkpimtextedit.mo
+share/locale/nn/LC_MESSAGES/libkpimtextedit.mo
+share/locale/pa/LC_MESSAGES/libkpimtextedit.mo
+share/locale/pl/LC_MESSAGES/libkpimtextedit.mo
+share/locale/pt/LC_MESSAGES/libkpimtextedit.mo
+share/locale/pt_BR/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ro/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ru/LC_MESSAGES/libkpimtextedit.mo
+share/locale/sk/LC_MESSAGES/libkpimtextedit.mo
+share/locale/sl/LC_MESSAGES/libkpimtextedit.mo
+share/locale/sr/LC_MESSAGES/libkpimtextedit.mo
+share/locale/sv/LC_MESSAGES/libkpimtextedit.mo
+share/locale/tr/LC_MESSAGES/libkpimtextedit.mo
+share/locale/ug/LC_MESSAGES/libkpimtextedit.mo
+share/locale/uk/LC_MESSAGES/libkpimtextedit.mo
+share/locale/zh_CN/LC_MESSAGES/libkpimtextedit.mo
+share/locale/zh_TW/LC_MESSAGES/libkpimtextedit.mo