aboutsummaryrefslogtreecommitdiff
path: root/net/l2tpd
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-10-23 13:21:53 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-10-23 13:21:53 +0000
commitb0506b02a8947f799d146b082a743e0b0794c5ea (patch)
tree3b79fced2a641fb08067d88534f8eae38a4fcabc /net/l2tpd
parent803d44a4a77ff916bcd03660e64d48ed945f325d (diff)
downloadports-b0506b02a8947f799d146b082a743e0b0794c5ea.tar.gz
ports-b0506b02a8947f799d146b082a743e0b0794c5ea.zip
Add l2tpd 0.64, an implementation of the layer two tunneling protocol.
Requested & beersponsored by: Yuri Babushkin <piton@united.net.ua>
Notes
Notes: svn path=/head/; revision=68654
Diffstat (limited to 'net/l2tpd')
-rw-r--r--net/l2tpd/Makefile35
-rw-r--r--net/l2tpd/distinfo1
-rw-r--r--net/l2tpd/files/patch-Makefile43
-rw-r--r--net/l2tpd/files/patch-aaa.c14
-rw-r--r--net/l2tpd/files/patch-avp.c13
-rw-r--r--net/l2tpd/files/patch-avpsend.c13
-rw-r--r--net/l2tpd/files/patch-call.c15
-rw-r--r--net/l2tpd/files/patch-control.c14
-rw-r--r--net/l2tpd/files/patch-doc::l2tpd.conf.sample14
-rw-r--r--net/l2tpd/files/patch-file.c13
-rw-r--r--net/l2tpd/files/patch-file.h16
-rw-r--r--net/l2tpd/files/patch-l2tp.h16
-rw-r--r--net/l2tpd/files/patch-l2tpd.829
-rw-r--r--net/l2tpd/files/patch-l2tpd.c14
-rw-r--r--net/l2tpd/files/patch-misc.c13
-rw-r--r--net/l2tpd/files/patch-network.c15
-rw-r--r--net/l2tpd/pkg-comment1
-rw-r--r--net/l2tpd/pkg-descr6
-rw-r--r--net/l2tpd/pkg-plist6
19 files changed, 291 insertions, 0 deletions
diff --git a/net/l2tpd/Makefile b/net/l2tpd/Makefile
new file mode 100644
index 000000000000..95909989acec
--- /dev/null
+++ b/net/l2tpd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: l2tpd
+# Date created: 22 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= l2tpd
+PORTVERSION= 0.64
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_REINPLACE= yes
+
+MAN8= l2tpd.8
+
+do-configure:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/l2tpd.8 \
+ ${WRKSRC}/doc/l2tpd.conf.sample
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/l2tpd ${PREFIX}/bin
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/l2tpd.8 ${PREFIX}/man/man8
+ ${MKDIR} ${PREFIX}/etc/l2tpd
+ ${INSTALL_DATA} ${WRKSRC}/doc/l2tpd.conf.sample ${PREFIX}/etc/l2tpd
+ ${INSTALL_DATA} ${WRKSRC}/doc/l2tp-secrets.sample ${PREFIX}/etc/l2tpd
+
+.include <bsd.port.mk>
diff --git a/net/l2tpd/distinfo b/net/l2tpd/distinfo
new file mode 100644
index 000000000000..2bcac894b0ca
--- /dev/null
+++ b/net/l2tpd/distinfo
@@ -0,0 +1 @@
+MD5 (l2tpd-0.64.tar.gz) = f2811ebafc727f2cd83e627c1ed037b2
diff --git a/net/l2tpd/files/patch-Makefile b/net/l2tpd/files/patch-Makefile
new file mode 100644
index 000000000000..c57da53c420e
--- /dev/null
+++ b/net/l2tpd/files/patch-Makefile
@@ -0,0 +1,43 @@
+
+$FreeBSD$
+
+--- Makefile.orig Fri Jan 11 17:54:44 2002
++++ Makefile Tue Oct 22 12:11:31 2002
+@@ -26,11 +26,11 @@
+ # become runtime options) debugging flags
+ #
+ #DFLAGS= -g -O2 -DDEBUG_PPPD
+-DFLAGS= -g -O2 -DDEBUG_PPPD -DDEBUG_CONTROL
++DFLAGS= -DDEBUG_PPPD -DDEBUG_CONTROL
+ #
+ # Uncomment the next line for Linux
+ #
+-OSFLAGS= -DLINUX -I/usr/include
++#OSFLAGS= -DLINUX -I/usr/include
+ #
+ # Uncomment the following to use the kernel interface under Linux
+ #
+@@ -38,7 +38,7 @@
+ #
+ # Uncomment the next line for FreeBSD
+ #
+-#OSFLAGS= -DFREEBSD
++OSFLAGS= -DFREEBSD -DPREFIX=\"$(PREFIX)\"
+ #
+ # Uncomment the next line for Solaris. For solaris, at least,
+ # we don't want to specify -I/usr/include because it is in
+@@ -48,7 +48,7 @@
+ #OSFLAGS= -DSOLARIS
+ #OSLIBS= -lnsl -lsocket
+
+-CFLAGS= $(DFLAGS) -Wall -DSANITY $(OSFLAGS)
++CFLAGS+= $(DFLAGS) -Wall -DSANITY $(OSFLAGS)
+ HDRS=l2tp.h avp.h misc.h control.h call.h scheduler.h file.h aaa.h md5.h
+ OBJS=l2tpd.o pty.o misc.o control.o avp.o call.o network.o avpsend.o scheduler.o file.o aaa.o md5.o
+ LIBS= $(OSLIB) # -lefence # efence for malloc checking
+@@ -62,4 +62,4 @@
+ rm -f $(OBJS) $(BIN)
+
+ $(BIN): $(OBJS) $(HDRS)
+- $(CC) -o $(BIN) $(DFLAGS) $(OBJS) $(LIBS)
++ $(CC) -o $(BIN) $(CFLAGS) $(DFLAGS) $(OBJS) $(LIBS)
diff --git a/net/l2tpd/files/patch-aaa.c b/net/l2tpd/files/patch-aaa.c
new file mode 100644
index 000000000000..d23fc4feb54c
--- /dev/null
+++ b/net/l2tpd/files/patch-aaa.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- aaa.c 2002/10/22 09:41:27 1.1
++++ aaa.c 2002/10/22 09:42:57
+@@ -14,8 +14,6 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+ #include <string.h>
+ #include <errno.h>
+ #include "l2tp.h"
diff --git a/net/l2tpd/files/patch-avp.c b/net/l2tpd/files/patch-avp.c
new file mode 100644
index 000000000000..ec8d1c93f245
--- /dev/null
+++ b/net/l2tpd/files/patch-avp.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- avp.c 2002/10/22 09:41:27 1.1
++++ avp.c 2002/10/22 09:43:02
+@@ -14,7 +14,6 @@
+ #include <string.h>
+ #include <stdio.h>
+ #include <errno.h>
+-#include <netinet/in.h>
+ #include "l2tp.h"
+
+ #define AVP_MAX 39
diff --git a/net/l2tpd/files/patch-avpsend.c b/net/l2tpd/files/patch-avpsend.c
new file mode 100644
index 000000000000..42f2f16ed12c
--- /dev/null
+++ b/net/l2tpd/files/patch-avpsend.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- avpsend.c 2002/10/22 09:41:27 1.1
++++ avpsend.c 2002/10/22 09:43:06
+@@ -13,7 +13,6 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-#include <netinet/in.h>
+ #include "l2tp.h"
+
+ /*
diff --git a/net/l2tpd/files/patch-call.c b/net/l2tpd/files/patch-call.c
new file mode 100644
index 000000000000..45dbdf362963
--- /dev/null
+++ b/net/l2tpd/files/patch-call.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- call.c 2002/10/22 09:41:27 1.1
++++ call.c 2002/10/22 09:43:13
+@@ -13,9 +13,6 @@
+
+ #include <stdio.h>
+ #include <fcntl.h>
+-#include <sys/socket.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+ #include <sys/wait.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/net/l2tpd/files/patch-control.c b/net/l2tpd/files/patch-control.c
new file mode 100644
index 000000000000..92d4e18601a2
--- /dev/null
+++ b/net/l2tpd/files/patch-control.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- control.c 2002/10/22 09:41:27 1.1
++++ control.c 2002/10/22 09:43:24
+@@ -15,8 +15,6 @@
+ #include <errno.h>
+ #include <string.h>
+ #include <stdio.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include "l2tp.h"
diff --git a/net/l2tpd/files/patch-doc::l2tpd.conf.sample b/net/l2tpd/files/patch-doc::l2tpd.conf.sample
new file mode 100644
index 000000000000..ba417a9d06ac
--- /dev/null
+++ b/net/l2tpd/files/patch-doc::l2tpd.conf.sample
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- doc/l2tpd.conf.sample 2002/10/22 09:59:52 1.1
++++ doc/l2tpd.conf.sample 2002/10/22 10:00:14
+@@ -10,7 +10,7 @@
+ ;
+ ; [global] ; Global parameters:
+ ; port = 1701 ; * Bind to port 1701
+-; auth file = /etc/l2tp/l2tp-secrets ; * Where our challenge secrets are
++; auth file = %%PREFIX%%/etc/l2tp/l2tp-secrets ; * Where our challenge secrets are
+ ; access control = yes ; * Refuse connections without IP match
+ ;
+ ; [lns default] ; Our fallthrough LNS definition
diff --git a/net/l2tpd/files/patch-file.c b/net/l2tpd/files/patch-file.c
new file mode 100644
index 000000000000..b3fe69846231
--- /dev/null
+++ b/net/l2tpd/files/patch-file.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- file.c 2002/10/22 09:41:27 1.1
++++ file.c 2002/10/22 09:43:30
+@@ -17,7 +17,6 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <netdb.h>
+-#include <netinet/in.h>
+
+ #include "l2tp.h"
+ struct lns *lnslist;
diff --git a/net/l2tpd/files/patch-file.h b/net/l2tpd/files/patch-file.h
new file mode 100644
index 000000000000..0bd349f81fee
--- /dev/null
+++ b/net/l2tpd/files/patch-file.h
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- file.h.orig Fri Jan 11 17:54:44 2002
++++ file.h Tue Oct 22 12:41:18 2002
+@@ -45,8 +45,8 @@
+ #define SENSE_ALLOW -1
+ #define SENSE_DENY 0
+
+-#define DEFAULT_AUTH_FILE "/etc/l2tp/l2tp-secrets"
+-#define CONFIG_FILE "/etc/l2tp/l2tpd.conf"
++#define DEFAULT_AUTH_FILE (PREFIX "/etc/l2tpd/l2tp-secrets")
++#define CONFIG_FILE (PREFIX "/etc/l2tpd/l2tpd.conf")
+
+ /* Definition of an LNS */
+ struct lns {
diff --git a/net/l2tpd/files/patch-l2tp.h b/net/l2tpd/files/patch-l2tp.h
new file mode 100644
index 000000000000..f94776599055
--- /dev/null
+++ b/net/l2tpd/files/patch-l2tp.h
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- l2tp.h.orig Tue Jan 15 18:59:27 2002
++++ l2tp.h Tue Oct 22 12:42:08 2002
+@@ -20,7 +20,10 @@
+
+ #define MAXSTRLEN 120 /* Maximum length of common strings */
+
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <termios.h>
+ #include "osport.h"
+ #include "scheduler.h"
diff --git a/net/l2tpd/files/patch-l2tpd.8 b/net/l2tpd/files/patch-l2tpd.8
new file mode 100644
index 000000000000..f8e060770652
--- /dev/null
+++ b/net/l2tpd/files/patch-l2tpd.8
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- l2tpd.8 2002/10/22 09:53:22 1.1
++++ l2tpd.8 2002/10/22 09:53:51
+@@ -28,20 +28,20 @@
+
+ .RS 3
+ Selects a different configuration file from the default, set at compile
+-time (typically /etc/l2tp/l2tpd.conf).
++time (typically %%PREFIX%%/etc/l2tp/l2tpd.conf).
+ See
+ .BR l2tpd.conf (5)
+ for more information.
+ .RE
+ .SH FILES
+
+-.B /etc/l2tp/l2tpd.conf
++.B %%PREFIX%%/etc/l2tp/l2tpd.conf
+ .RS 3
+ Configuration file for l2tpd, specifies virtually all information for its
+ operation.
+ .RE
+
+-.B /etc/l2tp/l2tp-secrets
++.B %%PREFIX%%/etc/l2tp/l2tp-secrets
+ .RS 3
+ Secrets used for challenge authentication and information hiding.
+ .RE
diff --git a/net/l2tpd/files/patch-l2tpd.c b/net/l2tpd/files/patch-l2tpd.c
new file mode 100644
index 000000000000..32d0f625ac1e
--- /dev/null
+++ b/net/l2tpd/files/patch-l2tpd.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- l2tpd.c.orig Fri Jan 11 17:54:44 2002
++++ l2tpd.c Tue Oct 22 12:43:45 2002
+@@ -33,8 +33,6 @@
+ #include <netdb.h>
+ #include <string.h>
+ #include <fcntl.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+ #ifdef USE_KERNEL
+ #include <sys/ioctl.h>
+ #endif
diff --git a/net/l2tpd/files/patch-misc.c b/net/l2tpd/files/patch-misc.c
new file mode 100644
index 000000000000..5fa3e7fb8276
--- /dev/null
+++ b/net/l2tpd/files/patch-misc.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- misc.c 2002/10/22 09:41:27 1.1
++++ misc.c 2002/10/22 09:43:50
+@@ -20,7 +20,6 @@
+ #if defined(SOLARIS)
+ # include <varargs.h>
+ #endif
+-#include <netinet/in.h>
+ #include "l2tp.h"
+
+ void log(int level, const char *fmt,...)
diff --git a/net/l2tpd/files/patch-network.c b/net/l2tpd/files/patch-network.c
new file mode 100644
index 000000000000..6943e0458ec2
--- /dev/null
+++ b/net/l2tpd/files/patch-network.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- network.c 2002/10/22 09:41:27 1.1
++++ network.c 2002/10/22 09:43:55
+@@ -13,9 +13,6 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
+-#include <sys/socket.h>
+-#include <netinet/in.h>
+-#include <arpa/inet.h>
+ #include <netdb.h>
+ #include <fcntl.h>
+ #include <unistd.h>
diff --git a/net/l2tpd/pkg-comment b/net/l2tpd/pkg-comment
new file mode 100644
index 000000000000..88017ac36100
--- /dev/null
+++ b/net/l2tpd/pkg-comment
@@ -0,0 +1 @@
+An implementation of the layer two tunneling protocol
diff --git a/net/l2tpd/pkg-descr b/net/l2tpd/pkg-descr
new file mode 100644
index 000000000000..4bfdb213ff34
--- /dev/null
+++ b/net/l2tpd/pkg-descr
@@ -0,0 +1,6 @@
+l2tpd is an implementation of the layer two tunneling protocol. It works in
+user space completely (although kernel work is planned after the userspace
+version is stablized). l2tpd works by opening a pseudo-tty for communicating
+with pppd(8).
+
+WWW: http://www.l2tpd.org/
diff --git a/net/l2tpd/pkg-plist b/net/l2tpd/pkg-plist
new file mode 100644
index 000000000000..5c702f3b9a6e
--- /dev/null
+++ b/net/l2tpd/pkg-plist
@@ -0,0 +1,6 @@
+bin/l2tpd
+etc/l2tpd/l2tp-secrets.sample
+etc/l2tpd/l2tpd.conf.sample
+share/doc/l2tpd/README
+@dirrm share/doc/l2tpd
+@dirrm etc/l2tpd