aboutsummaryrefslogtreecommitdiff
path: root/net/ldapscripts
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-06-15 09:57:55 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-06-15 09:57:55 +0000
commit4bab0482f00b8582cd04478ac5aa5bbae55a9b7c (patch)
tree1c030d896c81f83eb509240ebc1b49f2e3900d55 /net/ldapscripts
parente934bb942b4755e171622c3e942d622c1f20b53d (diff)
downloadports-4bab0482f00b8582cd04478ac5aa5bbae55a9b7c.tar.gz
ports-4bab0482f00b8582cd04478ac5aa5bbae55a9b7c.zip
- Switch to OptionsNg
- Swap LICENSE and *_DEPENDS to make portlint happy
Notes
Notes: svn path=/head/; revision=299329
Diffstat (limited to 'net/ldapscripts')
-rw-r--r--net/ldapscripts/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net/ldapscripts/Makefile b/net/ldapscripts/Makefile
index a487eb652572..37d2d6a7b0eb 100644
--- a/net/ldapscripts/Makefile
+++ b/net/ldapscripts/Makefile
@@ -15,6 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= martymac@FreeBSD.org
COMMENT= Scripts to manage posix accounts in an OpenLDAP directory
+LICENSE= GPLv2
+
RUN_DEPENDS= ldapadd:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client \
ldapsearch:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client \
ldapdelete:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client \
@@ -22,8 +24,6 @@ RUN_DEPENDS= ldapadd:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client \
ldapmodrdn:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client \
ldappasswd:${PORTSDIR}/net/openldap${OPENLDAP_VER}-client
-LICENSE= GPLv2
-
USE_OPENLDAP= yes
USE_ICONV= yes
LIBDIR= ${PREFIX}/lib/${PORTNAME}
@@ -41,6 +41,8 @@ MAN5= ldapscripts.5
PORTDOCS= README CHANGELOG VERSION TODO
+.include <bsd.port.options.mk>
+
# Unset 'all' target set by default to 'help'
# and set paths to OpenLDAP binaries
post-patch:
@@ -58,7 +60,7 @@ post-patch:
# Install remaining stuff
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}