aboutsummaryrefslogtreecommitdiff
path: root/net/lft
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2017-07-04 09:49:30 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2017-07-04 09:49:30 +0000
commit1702ea4d9050cc64965b5766671c067e06c781e2 (patch)
tree310a64c2a8e760242c7ba5e08a08d6ce2cde47b1 /net/lft
parent07c725bff4e484345321b7e5cff4cef0d72cb13f (diff)
downloadports-1702ea4d9050cc64965b5766671c067e06c781e2.tar.gz
ports-1702ea4d9050cc64965b5766671c067e06c781e2.zip
Unbreak on 11-STABLE and 12-CURRENT
- Remove reference to unused header file that caused build failure on 11.x+ - Fix the logic to create RAW sockets appropriately (reported by Andrew Wu) - Bump PORTREVISION PR: 219810 Reported by: Andrew Wu <yauhwawu@gmail.com> , dewayne@heuristicsystems.com.au Reviewed by: bapt Approved by: bapt Differential Revision: https://reviews.freebsd.org/D11072
Notes
Notes: svn path=/head/; revision=445013
Diffstat (limited to 'net/lft')
-rw-r--r--net/lft/Makefile3
-rw-r--r--net/lft/files/patch-lft__lib.h11
-rw-r--r--net/lft/files/patch-lft__types.h11
3 files changed, 23 insertions, 2 deletions
diff --git a/net/lft/Makefile b/net/lft/Makefile
index 18b3568e8a3d..cacf196ab807 100644
--- a/net/lft/Makefile
+++ b/net/lft/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lft
PORTVERSION= 3.79
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://pwhois.org/get/
@@ -15,8 +16,6 @@ LICENSE_NAME= VOSTROM
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror auto-accept
-BROKEN_FreeBSD_12= fails to compile: lft_types.h: pcap-int.h: No such file or directory
-
GNU_CONFIGURE= yes
PLIST_FILES= sbin/lft bin/whob man/man8/lft.8.gz man/man8/whob.8.gz
diff --git a/net/lft/files/patch-lft__lib.h b/net/lft/files/patch-lft__lib.h
new file mode 100644
index 000000000000..7b72bd67657d
--- /dev/null
+++ b/net/lft/files/patch-lft__lib.h
@@ -0,0 +1,11 @@
+--- lft_lib.h.orig 2017-07-04 09:02:47 UTC
++++ lft_lib.h
+@@ -277,7 +277,7 @@ typedef struct _incomicmpicmp
+ #define EVT_INCOMING_ICMP_ICMP 75
+ #define EVT_RCVD_ICMP_ICMP 76
+
+-#if defined(BSD_IP_STACK) && !defined(OPENBSD)
++#if defined(BSD_IP_STACK) && !defined(OPENBSD) && !defined(__FreeBSD__)
+ #define SCREWED_IP_LEN
+ #endif
+
diff --git a/net/lft/files/patch-lft__types.h b/net/lft/files/patch-lft__types.h
new file mode 100644
index 000000000000..d70832278c3c
--- /dev/null
+++ b/net/lft/files/patch-lft__types.h
@@ -0,0 +1,11 @@
+--- lft_types.h.orig 2016-05-02 14:31:54 UTC
++++ lft_types.h
+@@ -101,7 +101,7 @@ typedef signed long n_time;
+ #if !defined(DARWIN) && !defined(NETBSD)
+ #define HAVE_SNPRINTF
+ #define HAVE_VSNPRINTF
+-#if !defined(OPENBSD)
++#if !defined(OPENBSD) && !defined(__FreeBSD__)
+ #include <pcap-int.h>
+ #endif
+ #endif