aboutsummaryrefslogtreecommitdiff
path: root/net/lft
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-16 16:12:08 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-16 16:12:08 +0000
commit5fcd8f8072015ede9b2389a0973f52591c46e139 (patch)
tree5e68346fa9e4c20155ddc7b92bdec3cf817a9c17 /net/lft
parent7409a9c4237fa770ca6940514c32cf00f8b65857 (diff)
downloadports-5fcd8f8072015ede9b2389a0973f52591c46e139.tar.gz
ports-5fcd8f8072015ede9b2389a0973f52591c46e139.zip
- Update to 2.2
Submitted by: Kurt Jaeger <pi@complx.LF.net>, krion Approved by: maintainer
Notes
Notes: svn path=/head/; revision=87067
Diffstat (limited to 'net/lft')
-rw-r--r--net/lft/Makefile8
-rw-r--r--net/lft/distinfo2
-rw-r--r--net/lft/files/patch-lft.c64
-rw-r--r--net/lft/files/patch-lft_ifname.c10
4 files changed, 54 insertions, 30 deletions
diff --git a/net/lft/Makefile b/net/lft/Makefile
index 6a7b1f4276c1..da544874cc2d 100644
--- a/net/lft/Makefile
+++ b/net/lft/Makefile
@@ -6,21 +6,19 @@
#
PORTNAME= lft
-PORTVERSION= 2.0
+PORTVERSION= 2.2
CATEGORIES= net
MASTER_SITES= http://www.mainnerve.com/lft/ \
http://www.drkangel.org/sw/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= drkangel@drkangel.org
COMMENT= Layer 4 Traceroute program
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAKEFILE= Makefile.bsd
+GNU_CONFIGURE= yes
MAN8= lft.8
do-install:
- ${INSTALL} -c -s -m 0555 -o root -g wheel ${WRKSRC}/lft ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/lft ${PREFIX}/sbin
${INSTALL_MAN} ${WRKSRC}/lft.8 ${PREFIX}/man/man8
.include <bsd.port.mk>
diff --git a/net/lft/distinfo b/net/lft/distinfo
index 1a9706ef1f06..afeda74083e3 100644
--- a/net/lft/distinfo
+++ b/net/lft/distinfo
@@ -1 +1 @@
-MD5 (lft-2.0-src.tar.gz) = d7ae3bd202257f961bc24c2415d9a8bc
+MD5 (lft-2.2.tar.gz) = 75d2a4f0e224733156a668ca04881c4b
diff --git a/net/lft/files/patch-lft.c b/net/lft/files/patch-lft.c
index 5e21741241f7..8b8f70134b11 100644
--- a/net/lft/files/patch-lft.c
+++ b/net/lft/files/patch-lft.c
@@ -1,20 +1,56 @@
---- lft.c.orig Wed Mar 5 16:16:09 2003
-+++ lft.c Wed Mar 5 16:16:21 2003
-@@ -928,7 +928,7 @@
- // return; /* not for us */
+--- lft.c.orig Thu May 8 00:43:30 2003
++++ lft.c Fri Aug 15 13:50:43 2003
+@@ -76,6 +76,12 @@
+ #ifdef BSD
+ #include <machine/limits.h>
+ #endif
++#ifdef BSD_IP_STACK
++#include <errno.h>
++#include <sys/ioctl.h>
++#include <net/bpf.h>
++#include <pcap-int.h>
++#endif
+ #ifdef sun
+ #include <limits.h>
+@@ -961,7 +967,7 @@
+ return; * not for us */
-- if (noisy) printf ("ICMP %u\n", ntohl (tcp->th_seq));
-+ if (noisy) printf ("ICMP %lu\n", ntohl (tcp->th_seq));
+
+- if (noisy) printf ("ICMP SEQ=%u received\n", ntohl (tcp->th_seq));
++ if (noisy) printf ("ICMP SEQ=%lu received\n", ntohl (tcp->th_seq));
recv_packet (ntohl (tcp->th_seq) , orig_ip->ip_src,
(icmp->icmp_type == ICMP_TIMXCEED) ? -2 : icmp->icmp_code);
break;
-@@ -949,7 +949,7 @@
- if (noisy) printf (" ACK ");
- if (tcp->th_flags & TH_SYN)
- if (noisy) printf (" SYN ");
-- if (noisy) printf (" seq %u ack %u ", ntohl (tcp->th_seq), ntohl (tcp->th_ack));
-+ if (noisy) printf (" seq %lu ack %lu ", ntohl (tcp->th_seq), ntohl (tcp->th_ack));
- if (noisy) printf ("from %s\n", inet_ntoa (ip->ip_src));
+@@ -1046,6 +1052,9 @@
+ "LFT version 2.2 2003/05/07 compiled for " HOST_SYSTEM_TYPE "\n\n"
+ " Compile-time options:\n\n"
+ #if defined(BSD_IP_STACK)
++ " + BSDSTACK\n"
++#endif
++#if defined(BSD)
+ " + BSD\n"
+ #endif
+ #if defined(linux)
+@@ -1111,6 +1120,7 @@
+ int use_fins = 0;
+ char *cp;
+ struct timeval tb;
++ unsigned int bpfimmflag;
+
+ setbuf (stdout, NULL);
- //if (ntohl(tcp->th_ack) < seq_start || ntohl(tcp->th_ack) > seq_start + trace_packet_info_length + 1)
+@@ -1311,6 +1321,13 @@
+ fprintf (stderr, "%s\n", ebuf);
+ exit (1);
+ }
++#ifdef BSD_IP_STACK
++ bpfimmflag = 1;
++ if ( ioctl(pd->fd, BIOCIMMEDIATE, &bpfimmflag) < 0) {
++ fprintf(stderr, "BIOCIMMEDIATE: %s",
++ pcap_strerror(errno));
++ }
++#endif
+ #endif
+ init_address (hostname, pcap_dev);
+ open_sockets ();
diff --git a/net/lft/files/patch-lft_ifname.c b/net/lft/files/patch-lft_ifname.c
deleted file mode 100644
index caf12d1cd613..000000000000
--- a/net/lft/files/patch-lft_ifname.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lft_ifname.c.orig Wed Mar 5 16:16:49 2003
-+++ lft_ifname.c Wed Mar 5 16:17:05 2003
-@@ -19,6 +19,7 @@
- #ifndef linux
- #include <sys/sockio.h>
- #endif
-+#include <netinet/in.h>
- #include <arpa/inet.h>
- #include <netinet/in.h>
- #include <net/if.h>