aboutsummaryrefslogtreecommitdiff
path: root/net/lft
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-03-05 14:24:10 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-03-05 14:24:10 +0000
commitc7e70f06f48c14df18aa3dc066791bc59348f159 (patch)
tree11a48d48bbfe5adc03c43ffe296003af420e5bd5 /net/lft
parent83581ad08244e25dad780667869a47802dd8c9d8 (diff)
downloadports-c7e70f06f48c14df18aa3dc066791bc59348f159.tar.gz
ports-c7e70f06f48c14df18aa3dc066791bc59348f159.zip
Add LFT, the Level 4 Traceroute utility.
PR: 48475 Submitted by: Marco P. Rodrigues <drkangel@drkangel.org>
Notes
Notes: svn path=/head/; revision=76934
Diffstat (limited to 'net/lft')
-rw-r--r--net/lft/Makefile26
-rw-r--r--net/lft/distinfo1
-rw-r--r--net/lft/files/patch-lft.c20
-rw-r--r--net/lft/files/patch-lft_ifname.c10
-rw-r--r--net/lft/pkg-descr11
-rw-r--r--net/lft/pkg-plist1
6 files changed, 69 insertions, 0 deletions
diff --git a/net/lft/Makefile b/net/lft/Makefile
new file mode 100644
index 000000000000..fd1a36c56a77
--- /dev/null
+++ b/net/lft/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: lft
+# Date created: 19 Feb 2003
+# Whom: Marco P. Rodrigues <drkangel@drkangel.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lft
+PORTVERSION= 2.0
+CATEGORIES= net
+MASTER_SITES= http://www.mainnerve.com/lft/ \
+ http://www.drkangel.org/sw/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= drkangel@drkangel.org
+COMMENT= Layer 4 Traceroute program
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+MAKEFILE= Makefile.bsd
+MAN8= lft.8
+
+do-install:
+ ${INSTALL} -c -s -m 4755 -o root -g wheel ${WRKSRC}/lft ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/lft.8 ${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net/lft/distinfo b/net/lft/distinfo
new file mode 100644
index 000000000000..1a9706ef1f06
--- /dev/null
+++ b/net/lft/distinfo
@@ -0,0 +1 @@
+MD5 (lft-2.0-src.tar.gz) = d7ae3bd202257f961bc24c2415d9a8bc
diff --git a/net/lft/files/patch-lft.c b/net/lft/files/patch-lft.c
new file mode 100644
index 000000000000..5e21741241f7
--- /dev/null
+++ b/net/lft/files/patch-lft.c
@@ -0,0 +1,20 @@
+--- lft.c.orig Wed Mar 5 16:16:09 2003
++++ lft.c Wed Mar 5 16:16:21 2003
+@@ -928,7 +928,7 @@
+ // return; /* not for us */
+
+
+- if (noisy) printf ("ICMP %u\n", ntohl (tcp->th_seq));
++ if (noisy) printf ("ICMP %lu\n", ntohl (tcp->th_seq));
+ recv_packet (ntohl (tcp->th_seq) , orig_ip->ip_src,
+ (icmp->icmp_type == ICMP_TIMXCEED) ? -2 : icmp->icmp_code);
+ break;
+@@ -949,7 +949,7 @@
+ if (noisy) printf (" ACK ");
+ if (tcp->th_flags & TH_SYN)
+ if (noisy) printf (" SYN ");
+- if (noisy) printf (" seq %u ack %u ", ntohl (tcp->th_seq), ntohl (tcp->th_ack));
++ if (noisy) printf (" seq %lu ack %lu ", ntohl (tcp->th_seq), ntohl (tcp->th_ack));
+ if (noisy) printf ("from %s\n", inet_ntoa (ip->ip_src));
+
+ //if (ntohl(tcp->th_ack) < seq_start || ntohl(tcp->th_ack) > seq_start + trace_packet_info_length + 1)
diff --git a/net/lft/files/patch-lft_ifname.c b/net/lft/files/patch-lft_ifname.c
new file mode 100644
index 000000000000..caf12d1cd613
--- /dev/null
+++ b/net/lft/files/patch-lft_ifname.c
@@ -0,0 +1,10 @@
+--- lft_ifname.c.orig Wed Mar 5 16:16:49 2003
++++ lft_ifname.c Wed Mar 5 16:17:05 2003
+@@ -19,6 +19,7 @@
+ #ifndef linux
+ #include <sys/sockio.h>
+ #endif
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netinet/in.h>
+ #include <net/if.h>
diff --git a/net/lft/pkg-descr b/net/lft/pkg-descr
new file mode 100644
index 000000000000..8bbb55ca0974
--- /dev/null
+++ b/net/lft/pkg-descr
@@ -0,0 +1,11 @@
+LFT, short for Layer Four Traceroute, is a sort of 'traceroute' that often
+works much faster (than the commonly-used Van Jacobson method) and goes through
+many configurations of packet-filter based firewalls. More importantly, LFT
+implements numerous other features including AS number lookups, loose source
+routing, netblock name lookups, et al. Though LFT has been around since 1998,
+its development effort has just recently resumed.
+
+WWW: http://www.mainnerve.com/lft/
+
+Ported to FreeBSD by:
+Marco P. Rodrigues (drkangel@drkangel.org)
diff --git a/net/lft/pkg-plist b/net/lft/pkg-plist
new file mode 100644
index 000000000000..62333515d7ff
--- /dev/null
+++ b/net/lft/pkg-plist
@@ -0,0 +1 @@
+sbin/lft