aboutsummaryrefslogtreecommitdiff
path: root/net/libcmis
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-11 01:44:15 +0000
commit13fb0b92a29536c74fd1cea5b5e8e7fb8705be98 (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /net/libcmis
parent52a39feebd3a360c0a4633697006081ae2024197 (diff)
downloadports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.tar.gz
ports-13fb0b92a29536c74fd1cea5b5e8e7fb8705be98.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=472160
Diffstat (limited to 'net/libcmis')
-rw-r--r--net/libcmis/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/libcmis/Makefile b/net/libcmis/Makefile
index 2978ad585c3d..5e08ff74ed4f 100644
--- a/net/libcmis/Makefile
+++ b/net/libcmis/Makefile
@@ -12,15 +12,15 @@ COMMENT= Client library for the CMIS interface
LICENSE= LGPL20 MPL11 GPLv2
LICENSE_COMB= dual
+BROKEN_sparc64= cannot link with boost
+
LIB_DEPENDS= libcurl.so:ftp/curl
BUILD_DEPENDS= cppunit-config:devel/cppunit \
${LOCALBASE}/lib/libboost_regex.a:devel/boost-libs
-BROKEN_sparc64= cannot link with boost
-
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool pathfix pkgconfig
+USES= compiler:c++11-lib gmake libtool pathfix pkgconfig
USE_GNOME= libxml2
USE_LDCONFIG= yes