aboutsummaryrefslogtreecommitdiff
path: root/net/libdnet
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-04-27 15:32:07 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-04-27 15:32:07 +0000
commit888a04b606a58dad79315602f55a5eeb6c20bfda (patch)
treebc0eaf296489c67d06120bf81de6997450284504 /net/libdnet
parent09dc5f4878a5ac5ee38d9737e1098a7278617748 (diff)
downloadports-888a04b606a58dad79315602f55a5eeb6c20bfda.tar.gz
ports-888a04b606a58dad79315602f55a5eeb6c20bfda.zip
Update to 1.12
PR: ports/187977 Approved by: maintainer timeout (1 month)
Notes
Notes: svn path=/head/; revision=352433
Diffstat (limited to 'net/libdnet')
-rw-r--r--net/libdnet/Makefile28
-rw-r--r--net/libdnet/distinfo4
-rw-r--r--net/libdnet/files/patch-configure14
-rw-r--r--net/libdnet/files/patch-python__dnet.c20
-rw-r--r--net/libdnet/pkg-descr2
-rw-r--r--net/libdnet/pkg-plist3
6 files changed, 13 insertions, 58 deletions
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index f11f8fcecc22..89e4a94fe7b2 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -2,35 +2,25 @@
# $FreeBSD$
PORTNAME= libdnet
-PORTVERSION= 1.11
-PORTREVISION?= 3
+PORTVERSION= 1.12
CATEGORIES?= net
-MASTER_SITES= SF/libdnet/libdnet/libdnet-${PORTVERSION}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER?= onatan@gmail.com
-COMMENT= A simple interface to low level networking routines
+COMMENT= Simple interface to low level networking routines
+
+LICENSE= BSD3CLAUSE
GNU_CONFIGURE= yes
-USES= gmake
+CONFIGURE_ENV= ac_cv_dnet_bsd_bpf=yes
+USES= libtool:keepla tar:tgz
.if !defined(LIBDNET_SLAVE)
CONFIGURE_ARGS+= --without-python
USE_LDCONFIG= yes
.endif
-.include <bsd.port.pre.mk>
-
-.if !defined(LIBDNET_SLAVE)
-
post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
-
-post-build:
- @cd ${WRKSRC}/src ; ${CC} ${CFLAGS} -shared -o libdnet.so .libs/addr-util.o .libs/addr.o .libs/blob.o .libs/ip-util.o .libs/ip6.o .libs/rand.o .libs/arp-bsd.o .libs/eth-bsd.o .libs/fw-pf.o .libs/intf.o .libs/ip.o .libs/route-bsd.o .libs/tun-bsd.o
-
-post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/
- @${LN} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so.1
-.endif
+ @${REINPLACE_CMD} 's|shrext|shrext_cmds|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/libdnet/distinfo b/net/libdnet/distinfo
index e42e8cced799..76325884ce2a 100644
--- a/net/libdnet/distinfo
+++ b/net/libdnet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libdnet-1.11.tar.gz) = 0eb78415c8f2564c2f1e8ad36e98473348d9c94852f796a226360c716cc7ca53
-SIZE (libdnet-1.11.tar.gz) = 446233
+SHA256 (libdnet-1.12.tgz) = 83b33039787cf99990e977cef7f18a5d5e7aaffc4505548a83d31bd3515eb026
+SIZE (libdnet-1.12.tgz) = 970125
diff --git a/net/libdnet/files/patch-configure b/net/libdnet/files/patch-configure
deleted file mode 100644
index 3e94c4e5dad9..000000000000
--- a/net/libdnet/files/patch-configure
+++ /dev/null
@@ -1,14 +0,0 @@
---- configure.orig 2008-06-26 05:04:55.000000000 +0000
-+++ configure 2008-06-26 05:05:13.000000000 +0000
-@@ -21924,11 +21924,7 @@
- if test "${ac_cv_dnet_bsd_bpf+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-- if test -c /dev/bpf0 ; then
- ac_cv_dnet_bsd_bpf=yes
-- else
-- ac_cv_dnet_bsd_bpf=no
-- fi
- fi
-
- echo "$as_me:$LINENO: result: $ac_cv_dnet_bsd_bpf" >&5
diff --git a/net/libdnet/files/patch-python__dnet.c b/net/libdnet/files/patch-python__dnet.c
deleted file mode 100644
index 767d95ca9372..000000000000
--- a/net/libdnet/files/patch-python__dnet.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./python/dnet.c.orig Tue Jul 10 12:35:10 2007
-+++ ./python/dnet.c Tue Jul 10 12:35:59 2007
-@@ -2726,7 +2726,7 @@
- PyObject *__pyx_3 = 0;
- unsigned short __pyx_4;
- Py_INCREF(__pyx_v_self);
-- ((PyObject*)__pyx_v_next) = Py_None; Py_INCREF(((PyObject*)__pyx_v_next));
-+ __pyx_v_next = Py_None; Py_INCREF(((PyObject*)__pyx_v_next));
-
- /* "/Users/dugsong/projects/libdnet/python/./dnet.pyx":634 */
- __pyx_1 = (((struct __pyx_obj_4dnet___addr_ip4_iter *)__pyx_v_self)->cur <= ((struct __pyx_obj_4dnet___addr_ip4_iter *)__pyx_v_self)->max);
-@@ -2738,7 +2738,7 @@
- Py_DECREF(__pyx_2); __pyx_2 = 0;
- if (!__Pyx_TypeTest(__pyx_3, __pyx_ptype_4dnet_addr)) {__pyx_filename = __pyx_f[0]; __pyx_lineno = 635; goto __pyx_L1;}
- Py_DECREF(((PyObject *)__pyx_v_next));
-- ((PyObject *)__pyx_v_next) = __pyx_3;
-+ __pyx_v_next = __pyx_3;
- __pyx_3 = 0;
-
- /* "/Users/dugsong/projects/libdnet/python/./dnet.pyx":636 */
diff --git a/net/libdnet/pkg-descr b/net/libdnet/pkg-descr
index 7da2a378be78..7a1306aba6d8 100644
--- a/net/libdnet/pkg-descr
+++ b/net/libdnet/pkg-descr
@@ -5,4 +5,4 @@ firewalling, network interface lookup and manipulation, and raw IP
packet and Ethernet frame transmission. It is intended to complement
the functionality provided by pcap(3).
-WWW: http://libdnet.sourceforge.net/
+WWW: https://code.google.com/p/libdnet/
diff --git a/net/libdnet/pkg-plist b/net/libdnet/pkg-plist
index 97174f3b5f49..151c53b36808 100644
--- a/net/libdnet/pkg-plist
+++ b/net/libdnet/pkg-plist
@@ -1,11 +1,10 @@
sbin/dnet
bin/dnet-config
-lib/libdnet
-lib/libdnet.1
lib/libdnet.a
lib/libdnet.la
lib/libdnet.so
lib/libdnet.so.1
+lib/libdnet.so.1.0.1
include/dnet.h
include/dnet/addr.h
include/dnet/arp.h