aboutsummaryrefslogtreecommitdiff
path: root/net/libkvkontakte
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-07 20:26:52 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-02-07 20:26:52 +0000
commit4ba0c5b41e846e071d03b02a490a01b93ada7bdc (patch)
tree76a27a7c32eea000b49bf36e21bc3411ace30e36 /net/libkvkontakte
parent4dd376d603002903c14c463597d11e961b89ac6a (diff)
downloadports-4ba0c5b41e846e071d03b02a490a01b93ada7bdc.tar.gz
ports-4ba0c5b41e846e071d03b02a490a01b93ada7bdc.zip
Update to 4.12.0.
Since 4.11.0, libkvkontakte was split out of the digiKam tarball and is released independently. Submitted by: Tobias Berner <tcberner@gmail.com> via the area51 repository
Notes
Notes: svn path=/head/; revision=408452
Diffstat (limited to 'net/libkvkontakte')
-rw-r--r--net/libkvkontakte/Makefile14
-rw-r--r--net/libkvkontakte/distinfo2
-rw-r--r--net/libkvkontakte/pkg-plist35
3 files changed, 47 insertions, 4 deletions
diff --git a/net/libkvkontakte/Makefile b/net/libkvkontakte/Makefile
index 2c39e9815d5d..aeb6fe5b7e1f 100644
--- a/net/libkvkontakte/Makefile
+++ b/net/libkvkontakte/Makefile
@@ -1,16 +1,24 @@
# $FreeBSD$
PORTNAME= libkvkontakte
-PORTVERSION= ${DIGIKAM_VER}
+PORTVERSION= 4.12.0
CATEGORIES= net kde
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/digikam
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE library for accessing vk.com
-.include "${.CURDIR:H:H}/graphics/digikam-kde4/Makefile.common"
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
LIB_DEPENDS= libqjson.so:${PORTSDIR}/devel/qjson
+
+USES= cmake:outsource gettext pkgconfig tar:xz
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_KDE4= automoc4 kdeprefix kdelibs
USE_LDCONFIG= yes
-USES+= pkgconfig
+
+PLIST_SUB+= SHLIB_VER="${PORTVERSION}"
.include <bsd.port.mk>
diff --git a/net/libkvkontakte/distinfo b/net/libkvkontakte/distinfo
new file mode 100644
index 000000000000..a1936313c701
--- /dev/null
+++ b/net/libkvkontakte/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/digikam/libkvkontakte-4.12.0.tar.xz) = 4229f0e6b21451d04b9ff5cdc965a2eb9b9dd4a73d51ac52ec7b53ad2ec6cd02
+SIZE (KDE/digikam/libkvkontakte-4.12.0.tar.xz) = 57696
diff --git a/net/libkvkontakte/pkg-plist b/net/libkvkontakte/pkg-plist
index 02bcc3c3b291..1b6a07e67236 100644
--- a/net/libkvkontakte/pkg-plist
+++ b/net/libkvkontakte/pkg-plist
@@ -2,6 +2,7 @@ include/libkvkontakte/albuminfo.h
include/libkvkontakte/albumlistjob.h
include/libkvkontakte/allmessageslistjob.h
include/libkvkontakte/allnoteslistjob.h
+include/libkvkontakte/apppermissions.h
include/libkvkontakte/authenticationdialog.h
include/libkvkontakte/cidsnamesjob.h
include/libkvkontakte/createalbumjob.h
@@ -30,6 +31,7 @@ include/libkvkontakte/userinfo.h
include/libkvkontakte/userinfofulljob.h
include/libkvkontakte/userinfojob.h
include/libkvkontakte/version.h
+include/libkvkontakte/vkapi.h
include/libkvkontakte/vkontaktejobs.h
lib/cmake/LibKVkontakte/LibKVkontakteConfig.cmake
lib/cmake/LibKVkontakte/LibKVkontakteConfigVersion.cmake
@@ -37,4 +39,35 @@ lib/cmake/LibKVkontakte/LibKVkontakteTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/LibKVkontakte/LibKVkontakteTargets.cmake
lib/libkvkontakte.so
lib/libkvkontakte.so.1
-lib/libkvkontakte.so.1.0.0
+lib/libkvkontakte.so.%%SHLIB_VER%%
+share/locale/ar/LC_MESSAGES/libkvkontakte.mo
+share/locale/bs/LC_MESSAGES/libkvkontakte.mo
+share/locale/cs/LC_MESSAGES/libkvkontakte.mo
+share/locale/da/LC_MESSAGES/libkvkontakte.mo
+share/locale/de/LC_MESSAGES/libkvkontakte.mo
+share/locale/el/LC_MESSAGES/libkvkontakte.mo
+share/locale/en_GB/LC_MESSAGES/libkvkontakte.mo
+share/locale/es/LC_MESSAGES/libkvkontakte.mo
+share/locale/et/LC_MESSAGES/libkvkontakte.mo
+share/locale/fi/LC_MESSAGES/libkvkontakte.mo
+share/locale/fr/LC_MESSAGES/libkvkontakte.mo
+share/locale/gl/LC_MESSAGES/libkvkontakte.mo
+share/locale/hu/LC_MESSAGES/libkvkontakte.mo
+share/locale/it/LC_MESSAGES/libkvkontakte.mo
+share/locale/kk/LC_MESSAGES/libkvkontakte.mo
+share/locale/km/LC_MESSAGES/libkvkontakte.mo
+share/locale/ko/LC_MESSAGES/libkvkontakte.mo
+share/locale/nb/LC_MESSAGES/libkvkontakte.mo
+share/locale/nds/LC_MESSAGES/libkvkontakte.mo
+share/locale/nl/LC_MESSAGES/libkvkontakte.mo
+share/locale/pl/LC_MESSAGES/libkvkontakte.mo
+share/locale/pt/LC_MESSAGES/libkvkontakte.mo
+share/locale/pt_BR/LC_MESSAGES/libkvkontakte.mo
+share/locale/ro/LC_MESSAGES/libkvkontakte.mo
+share/locale/ru/LC_MESSAGES/libkvkontakte.mo
+share/locale/sk/LC_MESSAGES/libkvkontakte.mo
+share/locale/sl/LC_MESSAGES/libkvkontakte.mo
+share/locale/sv/LC_MESSAGES/libkvkontakte.mo
+share/locale/tr/LC_MESSAGES/libkvkontakte.mo
+share/locale/uk/LC_MESSAGES/libkvkontakte.mo
+share/locale/zh_TW/LC_MESSAGES/libkvkontakte.mo