aboutsummaryrefslogtreecommitdiff
path: root/net/libkvkontakte
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-09 13:36:04 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-09 13:36:04 +0000
commit647f6acdb688f7d4b9a8909b3c469d6031652998 (patch)
tree90cf2bb590e0ff73b0b9c559a83373a0efbaceb5 /net/libkvkontakte
parent99603ce64268fb8f6d145a03a4490bbba0ca5edf (diff)
downloadports-647f6acdb688f7d4b9a8909b3c469d6031652998.tar.gz
ports-647f6acdb688f7d4b9a8909b3c469d6031652998.zip
Add new port net/libkvkontakte:
Libkvkontakte is a KDE C++ interface for VK (http://vk.com). WWW: http://www.digikam.org Submitted by: Jason E. Hale <bsdkaffee at gmail.com> via area51 commit
Notes
Notes: svn path=/head/; revision=298857
Diffstat (limited to 'net/libkvkontakte')
-rw-r--r--net/libkvkontakte/Makefile30
-rw-r--r--net/libkvkontakte/distinfo2
-rw-r--r--net/libkvkontakte/pkg-descr3
-rw-r--r--net/libkvkontakte/pkg-plist42
4 files changed, 77 insertions, 0 deletions
diff --git a/net/libkvkontakte/Makefile b/net/libkvkontakte/Makefile
new file mode 100644
index 000000000000..2b31011d9475
--- /dev/null
+++ b/net/libkvkontakte/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libkvkontakte
+# Date created: 2012-05-12
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libkvkontakte
+PORTVERSION= 2.6.0
+CATEGORIES= net kde
+MASTER_SITES= SF/digikam/digikam/${PORTVERSION}
+DISTNAME= digikam-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE4 library for accessing vk.com
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdehier kdeprefix kdelibs
+USE_QT4= qmake_build moc_build rcc_build uic_build
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/extra/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/libkvkontakte/distinfo b/net/libkvkontakte/distinfo
new file mode 100644
index 000000000000..afb200f08f48
--- /dev/null
+++ b/net/libkvkontakte/distinfo
@@ -0,0 +1,2 @@
+SHA256 (digikam-2.6.0.tar.bz2) = 411ceaa3a489d9c9a5566d43c167927a07fb08fb4f613b0dbf1dec65b95736df
+SIZE (digikam-2.6.0.tar.bz2) = 55362029
diff --git a/net/libkvkontakte/pkg-descr b/net/libkvkontakte/pkg-descr
new file mode 100644
index 000000000000..2b5ae3b6f3e2
--- /dev/null
+++ b/net/libkvkontakte/pkg-descr
@@ -0,0 +1,3 @@
+Libkvkontakte is a KDE C++ interface for VK (http://vk.com).
+
+WWW: http://www.digikam.org
diff --git a/net/libkvkontakte/pkg-plist b/net/libkvkontakte/pkg-plist
new file mode 100644
index 000000000000..13ed40ee6d29
--- /dev/null
+++ b/net/libkvkontakte/pkg-plist
@@ -0,0 +1,42 @@
+include/libkvkontakte/albuminfo.h
+include/libkvkontakte/albumlistjob.h
+include/libkvkontakte/allmessageslistjob.h
+include/libkvkontakte/allnoteslistjob.h
+include/libkvkontakte/authenticationdialog.h
+include/libkvkontakte/cidsnamesjob.h
+include/libkvkontakte/createalbumjob.h
+include/libkvkontakte/deletealbumjob.h
+include/libkvkontakte/discussionslistjob.h
+include/libkvkontakte/editalbumjob.h
+include/libkvkontakte/friendlistjob.h
+include/libkvkontakte/getapplicationpermissionsjob.h
+include/libkvkontakte/getinfojob.h
+include/libkvkontakte/getvariablejob.h
+include/libkvkontakte/groupinfo.h
+include/libkvkontakte/grouplistjob.h
+include/libkvkontakte/libkvkontakte_export.h
+include/libkvkontakte/messageinfo.h
+include/libkvkontakte/messageslistjob.h
+include/libkvkontakte/noteaddjob.h
+include/libkvkontakte/noteinfo.h
+include/libkvkontakte/notejob.h
+include/libkvkontakte/noteslistjob.h
+include/libkvkontakte/photoinfo.h
+include/libkvkontakte/photojob.h
+include/libkvkontakte/photolistjob.h
+include/libkvkontakte/qintlist.h
+include/libkvkontakte/uploadphotosjob.h
+include/libkvkontakte/userinfo.h
+include/libkvkontakte/userinfofulljob.h
+include/libkvkontakte/userinfojob.h
+include/libkvkontakte/version.h
+include/libkvkontakte/vkontaktejobs.h
+lib/cmake/LibKVkontakte/LibKVkontakteConfig.cmake
+lib/cmake/LibKVkontakte/LibKVkontakteConfigVersion.cmake
+lib/cmake/LibKVkontakte/LibKVkontakteTargets-release.cmake
+lib/cmake/LibKVkontakte/LibKVkontakteTargets.cmake
+lib/libkvkontakte.so
+lib/libkvkontakte.so.1
+lib/libkvkontakte.so.1.0.0
+@dirrm lib/cmake/LibKVkontakte
+@dirrm include/libkvkontakte