aboutsummaryrefslogtreecommitdiff
path: root/net/libkvkontakte
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-27 15:06:23 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-27 15:06:23 +0000
commit6d8a528c3e67f5ff9694d91230992f432478d551 (patch)
tree150865be80091c65dd2adba905473ebf7b155f3c /net/libkvkontakte
parentab320585faae03ab647a389b24808132773422fc (diff)
downloadports-6d8a528c3e67f5ff9694d91230992f432478d551.tar.gz
ports-6d8a528c3e67f5ff9694d91230992f432478d551.zip
Unbreak after r436971.
kdelibs stopped setting several CMake policies to old values, as well as setting an old minium required CMake version. This causes the configuration stage to fail here, as libkvkontakte sets a higher minimum required CMake version that sets the CMP0022 policy to NEW and causes things to fail: CMake Error in libkvkontakte/CMakeLists.txt: Target "kvkontakte" has policy CMP0022 enabled, but also has old-style LINK_INTERFACE_LIBRARIES properties populated, but it was exported without the EXPORT_LINK_INTERFACE_LIBRARIES to export the old-style properties
Notes
Notes: svn path=/head/; revision=437049
Diffstat (limited to 'net/libkvkontakte')
-rw-r--r--net/libkvkontakte/files/patch-CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/net/libkvkontakte/files/patch-CMakeLists.txt b/net/libkvkontakte/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..64c45a2fe3ec
--- /dev/null
+++ b/net/libkvkontakte/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+Avoids the following error when configuring:
+
+CMake Error in libkvkontakte/CMakeLists.txt:
+ Target "kvkontakte" has policy CMP0022 enabled, but also has old-style
+ LINK_INTERFACE_LIBRARIES properties populated, but it was exported without
+ the EXPORT_LINK_INTERFACE_LIBRARIES to export the old-style properties
+
+which is caused by the project requiring a minimum CMake version that sets
+CMP0022 to NEW while the code in KDE4Macros.cmake (in kdelibs) still sets the
+deprecated LINK_INTERFACE_LIBRARIES property.
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -56,7 +56,7 @@ add_subdirectory(libkvkontakte)
+ # This file contains add_library(bar IMPORTED) statements for each target in the export set, so
+ # when loaded later on cmake will create "imported" library targets from these, which can be used
+ # in many ways in the same way as a normal library target created via a normal add_library().
+-install(EXPORT LibKVkontakteExport DESTINATION ${CMAKECONFIG_INSTALL_DIR} FILE LibKVkontakteTargets.cmake )
++install(EXPORT LibKVkontakteExport DESTINATION ${CMAKECONFIG_INSTALL_DIR} FILE LibKVkontakteTargets.cmake EXPORT_LINK_INTERFACE_LIBRARIES )
+
+ # figure out the relative path from the installed Config.cmake file to the install prefix (which may be at
+ # runtime different from the chosen CMAKE_INSTALL_PREFIX if under Windows the package was installed anywhere)