aboutsummaryrefslogtreecommitdiff
path: root/net/libnet
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-20 10:53:08 +0000
commit654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net/libnet
parent3dc362ac88ab73d6f0b3635628a59d9597e6da4e (diff)
downloadports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.tar.gz
ports-654ccc6aac9c7681ed39c2cd2d10d8360ec7a9bc.zip
Install net/libnet headers and libraries back in the location where other
ports expect it. The files were put in a different location to avoid a conflict with net/libnet10 but this port has been removed a while ago now. PR: 208122 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=411432
Diffstat (limited to 'net/libnet')
-rw-r--r--net/libnet/Makefile23
-rw-r--r--net/libnet/files/patch-Makefile.in10
-rw-r--r--net/libnet/pkg-plist26
3 files changed, 18 insertions, 41 deletions
diff --git a/net/libnet/Makefile b/net/libnet/Makefile
index ed0be52a87e8..da6c118eedb2 100644
--- a/net/libnet/Makefile
+++ b/net/libnet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libnet
PORTVERSION= 1.1.6
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF/libnet-dev
@@ -12,6 +12,7 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C library for creating IP packets
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/doc/COPYING
OPTIONS_DEFINE= BPF DOCS EXAMPLES
OPTIONS_DEFAULT=BPF
@@ -23,13 +24,9 @@ USE_CSTD= gnu89
USE_LDCONFIG= yes
USES= libtool
-SHORT_NAME= ${PORTNAME}11
-DOCSDIR= ${PREFIX}/share/doc/${SHORT_NAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/${SHORT_NAME}
-USE_LDCONFIG= ${PREFIX}/lib/${SHORT_NAME}
-PLIST_SUB= SNAME=${SHORT_NAME} VERSION=${PORTVERSION}
+PLIST_SUB= VERSION=${PORTVERSION}
-DOCS= README doc/CHANGELOG doc/CONTRIB doc/COPYING \
+DOCS= README doc/CHANGELOG doc/CONTRIB \
doc/DESIGN_NOTES doc/MIGRATION doc/PACKET_BUILDING doc/PORTED \
doc/RAWSOCKET_NON_SEQUITUR doc/TODO
EXAMPLES= sample/*.c
@@ -39,19 +36,11 @@ BPF_CONFIGURE_ON= --with-link-layer=bpf
post-patch:
@${REINPLACE_CMD} \
- -e 's|@LIBNET_CONFIG_LIBS@|@LIBNET_CONFIG_LIBS@ -L@prefix@/lib/${SHORT_NAME}|' \
- -e 's|@LIBNET_CONFIG_CFLAGS@|@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include/${SHORT_NAME}|' \
+ -e 's|@LIBNET_CONFIG_LIBS@|@LIBNET_CONFIG_LIBS@ -L@prefix@/lib|' \
+ -e 's|@LIBNET_CONFIG_CFLAGS@|@LIBNET_CONFIG_CFLAGS@ -I@prefix@/include|' \
${WRKSRC}/libnet-config.in
- @${REINPLACE_CMD} -e 's|^includedir =.*|includedir = @includedir@/${SHORT_NAME}|' \
- ${WRKSRC}/include/Makefile.in \
- ${WRKSRC}/include/libnet/Makefile.in
- @${REINPLACE_CMD} -e 's|^libdir =.*|libdir = @libdir@/${SHORT_NAME}|' \
- -e 's|^libnet_la_LDFLAGS =\(.*\)|libnet_la_LDFLAGS =\1 -soname=libnet-${SHORT_NAME}.so.1|' \
- ${WRKSRC}/src/Makefile.in
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/libnet-config ${STAGEDIR}${PREFIX}/bin/${SHORT_NAME}-config
- ${LN} -fs ${SHORT_NAME}/libnet.so.1 ${STAGEDIR}${PREFIX}/lib/libnet-${PORTVERSION}.so.1
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
diff --git a/net/libnet/files/patch-Makefile.in b/net/libnet/files/patch-Makefile.in
deleted file mode 100644
index 59863e03e93c..000000000000
--- a/net/libnet/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./Makefile.in.orig Thu Dec 2 21:27:39 2004
-+++ ./Makefile.in Sat Jan 20 14:10:35 2007
-@@ -208,7 +208,6 @@
- DISTCLEANFILES = *~
- SUBDIRS = include src sample
- EXTRA_DIST = Makefile.am.common
--bin_SCRIPTS = libnet-config
- all: all-recursive
-
- .SUFFIXES:
diff --git a/net/libnet/pkg-plist b/net/libnet/pkg-plist
index 843d06087115..1e12623458c9 100644
--- a/net/libnet/pkg-plist
+++ b/net/libnet/pkg-plist
@@ -1,22 +1,20 @@
-bin/%%SNAME%%-config
-include/%%SNAME%%/libnet.h
-include/%%SNAME%%/libnet/libnet-asn1.h
-include/%%SNAME%%/libnet/libnet-functions.h
-include/%%SNAME%%/libnet/libnet-headers.h
-include/%%SNAME%%/libnet/libnet-macros.h
-include/%%SNAME%%/libnet/libnet-structures.h
-include/%%SNAME%%/libnet/libnet-types.h
-lib/%%SNAME%%/libnet.a
-lib/%%SNAME%%/libnet.so
-lib/%%SNAME%%/libnet.so.1
-lib/%%SNAME%%/libnet.so.1.7.0
-lib/libnet-%%VERSION%%.so.1
+bin/libnet-config
+include/libnet.h
+include/libnet/libnet-asn1.h
+include/libnet/libnet-functions.h
+include/libnet/libnet-headers.h
+include/libnet/libnet-macros.h
+include/libnet/libnet-structures.h
+include/libnet/libnet-types.h
+lib/libnet.a
+lib/libnet.so
+lib/libnet.so.1
+lib/libnet.so.1.7.0
man/man3/libnet-functions.h.3.gz
man/man3/libnet-macros.h.3.gz
man/man3/libnet.h.3.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/DESIGN_NOTES
%%PORTDOCS%%%%DOCSDIR%%/MIGRATION
%%PORTDOCS%%%%DOCSDIR%%/PACKET_BUILDING