aboutsummaryrefslogtreecommitdiff
path: root/net/liboauth
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2010-10-30 23:27:31 +0000
committerJohan van Selst <johans@FreeBSD.org>2010-10-30 23:27:31 +0000
commit48afc03e29c3c989c41d8e38740b6b809492fad8 (patch)
tree504b79b76a2e2b7c2ac192d3860543fa58b6cf7e /net/liboauth
parent447684273120581c2d5292327956ae3c88af5299 (diff)
downloadports-48afc03e29c3c989c41d8e38740b6b809492fad8.tar.gz
ports-48afc03e29c3c989c41d8e38740b6b809492fad8.zip
Add a new port net/liboauth:
OAuth is an open protocol to allow secure API authorization in a simple and standard method from desktop and web applications. liboauth is a collection of POSIX-c functions implementing the OAuth Core RFC 5849 standard. liboauth provides functions to escape and encode parameters according to OAuth specification and offers high-level functionality to sign requests or verify OAuth signatures as well as perform HTTP requests. WWW: http://liboauth.sourceforge.net/
Notes
Notes: svn path=/head/; revision=263819
Diffstat (limited to 'net/liboauth')
-rw-r--r--net/liboauth/Makefile30
-rw-r--r--net/liboauth/distinfo2
-rw-r--r--net/liboauth/pkg-descr10
-rw-r--r--net/liboauth/pkg-plist6
4 files changed, 48 insertions, 0 deletions
diff --git a/net/liboauth/Makefile b/net/liboauth/Makefile
new file mode 100644
index 000000000000..80be077870b2
--- /dev/null
+++ b/net/liboauth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: liboauth
+# Date created: 30 October 2010
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboauth
+PORTVERSION= 0.9.1
+CATEGORIES= net
+MASTER_SITES= http://liboauth.sourceforge.net/pool/
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= C library implementing the OAuth Core standard
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+
+USE_OPENSSL= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+MAN3= oauth.3
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^if test/s/ == / = /' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/liboauth/distinfo b/net/liboauth/distinfo
new file mode 100644
index 000000000000..d8b3837dff74
--- /dev/null
+++ b/net/liboauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (liboauth-0.9.1.tar.gz) = 7e2eb08cfb0771e5fb79b458ac749a2f7a87d3d7d732bff7548ad8834aee013b
+SIZE (liboauth-0.9.1.tar.gz) = 395025
diff --git a/net/liboauth/pkg-descr b/net/liboauth/pkg-descr
new file mode 100644
index 000000000000..3379e8109065
--- /dev/null
+++ b/net/liboauth/pkg-descr
@@ -0,0 +1,10 @@
+OAuth is an open protocol to allow secure API authorization in
+a simple and standard method from desktop and web applications.
+
+liboauth is a collection of POSIX-c functions implementing the OAuth
+Core RFC 5849 standard. liboauth provides functions to escape and
+encode parameters according to OAuth specification and offers
+high-level functionality to sign requests or verify OAuth signatures
+as well as perform HTTP requests.
+
+WWW: http://liboauth.sourceforge.net/
diff --git a/net/liboauth/pkg-plist b/net/liboauth/pkg-plist
new file mode 100644
index 000000000000..5db67160f674
--- /dev/null
+++ b/net/liboauth/pkg-plist
@@ -0,0 +1,6 @@
+include/oauth.h
+lib/liboauth.so.8
+lib/liboauth.so
+lib/liboauth.la
+lib/liboauth.a
+libdata/pkgconfig/oauth.pc