aboutsummaryrefslogtreecommitdiff
path: root/net/libpcap
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-07-23 18:26:49 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-07-23 18:26:49 +0000
commit52e1c8b452e8ab030ca43fc74ac1c26f027b6cda (patch)
treed401a175a0bbdc88493a011bb2d231a7439bd0d9 /net/libpcap
parent39bc39b176acac91ea431ec8de67d7fb09db2f32 (diff)
downloadports-52e1c8b452e8ab030ca43fc74ac1c26f027b6cda.tar.gz
ports-52e1c8b452e8ab030ca43fc74ac1c26f027b6cda.zip
Update net/libpcap to 1.9.0
Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=475196
Diffstat (limited to 'net/libpcap')
-rw-r--r--net/libpcap/Makefile2
-rw-r--r--net/libpcap/distinfo6
-rw-r--r--net/libpcap/files/patch-Makefile.in14
-rw-r--r--net/libpcap/files/patch-gencode.c45
-rw-r--r--net/libpcap/pkg-plist7
5 files changed, 18 insertions, 56 deletions
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index 3b0f0762c6d1..c01835f418f6 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libpcap
-PORTVERSION= 1.8.1
+PORTVERSION= 1.9.0
CATEGORIES= net ipv6
MASTER_SITES= http://www.tcpdump.org/release/
diff --git a/net/libpcap/distinfo b/net/libpcap/distinfo
index 0a99fa3ee5aa..645bb9f86457 100644
--- a/net/libpcap/distinfo
+++ b/net/libpcap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477480513
-SHA256 (libpcap-1.8.1.tar.gz) = 673dbc69fdc3f5a86fb5759ab19899039a8e5e6c631749e48dcd9c6f0c83541e
-SIZE (libpcap-1.8.1.tar.gz) = 739163
+TIMESTAMP = 1532355961
+SHA256 (libpcap-1.9.0.tar.gz) = 2edb88808e5913fdaa8e9c1fcaf272e19b2485338742b5074b9fe44d68f37019
+SIZE (libpcap-1.9.0.tar.gz) = 832079
diff --git a/net/libpcap/files/patch-Makefile.in b/net/libpcap/files/patch-Makefile.in
index 4ddb577dc0aa..89c4d3ad20b1 100644
--- a/net/libpcap/files/patch-Makefile.in
+++ b/net/libpcap/files/patch-Makefile.in
@@ -1,13 +1,15 @@
---- Makefile.in.orig 2015-06-28 01:03:37 UTC
+--- Makefile.in.orig 2018-07-23 16:09:48 UTC
+++ Makefile.in
-@@ -569,51 +569,19 @@ install: install-shared install-archive
+@@ -558,7 +558,7 @@ install: install-shared install-archive libpcap.pc pca
$(DESTDIR)$(includedir)/$$i; done
[ -d $(DESTDIR)$(bindir) ] || \
(mkdir -p $(DESTDIR)$(bindir); chmod 755 $(DESTDIR)$(bindir))
- $(INSTALL_PROGRAM) pcap-config $(DESTDIR)$(bindir)/pcap-config
-+ $(INSTALL_DATA) pcap-config $(DESTDIR)$(bindir)/pcap-config
-+ chmod 755 $(DESTDIR)$(bindir)/pcap-config
- for i in $(MAN1); do \
++ $(BSD_INSTALL_SCRIPT) pcap-config $(DESTDIR)$(bindir)/pcap-config
+ [ -d $(DESTDIR)$(libdir)/pkgconfig ] || \
+ (mkdir -p $(DESTDIR)$(libdir)/pkgconfig; chmod 755 $(DESTDIR)$(libdir)/pkgconfig)
+ $(INSTALL_DATA) libpcap.pc $(DESTDIR)$(libdir)/pkgconfig/libpcap.pc
+@@ -566,46 +566,13 @@ install: install-shared install-archive libpcap.pc pca
$(INSTALL_DATA) $(srcdir)/$$i \
$(DESTDIR)$(mandir)/man1/$$i; done
for i in $(MAN3PCAP_NOEXPAND); do \
@@ -54,7 +56,7 @@
- $(LN_S) pcap_tstamp_type_val_to_name.3pcap pcap_tstamp_type_val_to_description.3pcap && \
- rm -f pcap_getnonblock.3pcap && \
- $(LN_S) pcap_setnonblock.3pcap pcap_getnonblock.3pcap)
-+ $(DESTDIR)$(mandir)/man3/$$j; done
++ $(DESTDIR)$(mandir)/man3/$$j; done
for i in $(MANFILE); do \
$(INSTALL_DATA) `echo $$i | sed 's/.manfile.in/.manfile/'` \
$(DESTDIR)$(mandir)/man@MAN_FILE_FORMATS@/`echo $$i | sed 's/.manfile.in/.@MAN_FILE_FORMATS@/'`; done
diff --git a/net/libpcap/files/patch-gencode.c b/net/libpcap/files/patch-gencode.c
deleted file mode 100644
index 222316cdf90c..000000000000
--- a/net/libpcap/files/patch-gencode.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- gencode.c.orig 2016-07-30 13:42:44 UTC
-+++ gencode.c
-@@ -523,7 +523,8 @@ static struct block *gen_host6(compiler_
- struct in6_addr *, int, int, int);
- #endif
- #ifndef INET6
--static struct block *gen_gateway(const u_char *, bpf_u_int32 **, int, int);
-+static struct block *gen_gateway(compiler_state_t *, const u_char *,
-+ bpf_u_int32 **, int, int);
- #endif
- static struct block *gen_ipfrag(compiler_state_t *);
- static struct block *gen_portatom(compiler_state_t *, int, bpf_int32);
-@@ -690,7 +691,9 @@ pcap_compile(pcap_t *p, struct bpf_progr
- }
- initchunks(&cstate);
- cstate.no_optimize = 0;
-+#ifdef INET6
- cstate.ai = NULL;
-+#endif
- cstate.ic.root = NULL;
- cstate.ic.cur_mark = 0;
- cstate.bpf_pcap = p;
-@@ -4846,11 +4849,8 @@ gen_host6(compiler_state_t *cstate, stru
-
- #ifndef INET6
- static struct block *
--gen_gateway(eaddr, alist, proto, dir)
-- const u_char *eaddr;
-- bpf_u_int32 **alist;
-- int proto;
-- int dir;
-+gen_gateway(compiler_state_t *cstate, const u_char *eaddr,
-+ bpf_u_int32 **alist, int proto, int dir)
- {
- struct block *b0, *b1, *tmp;
-
-@@ -6414,7 +6414,7 @@ gen_scode(compiler_state_t *cstate, cons
- alist = pcap_nametoaddr(name);
- if (alist == NULL || *alist == NULL)
- bpf_error(cstate, "unknown host '%s'", name);
-- b = gen_gateway(eaddr, alist, proto, dir);
-+ b = gen_gateway(cstate, eaddr, alist, proto, dir);
- free(eaddr);
- return b;
- #else
diff --git a/net/libpcap/pkg-plist b/net/libpcap/pkg-plist
index 3a13d8637fea..1f68d8d08942 100644
--- a/net/libpcap/pkg-plist
+++ b/net/libpcap/pkg-plist
@@ -5,11 +5,13 @@ include/pcap.h
include/pcap/bluetooth.h
include/pcap/bpf.h
include/pcap/can_socketcan.h
+include/pcap/compiler-tests.h
include/pcap/dlt.h
-include/pcap/export-defs.h
+include/pcap/funcattrs.h
include/pcap/ipnet.h
include/pcap/namedb.h
include/pcap/nflog.h
+include/pcap/pcap-inttypes.h
include/pcap/pcap.h
include/pcap/sll.h
include/pcap/usb.h
@@ -18,6 +20,7 @@ lib/libpcap.a
lib/libpcap.so
lib/libpcap.so.1
lib/libpcap.so.%%PORTVERSION%%
+libdata/pkgconfig/libpcap.pc
man/man1/pcap-config.1.gz
man/man3/pcap.3.gz
man/man3/pcap_activate.3.gz
@@ -39,6 +42,7 @@ man/man3/pcap_file.3.gz
man/man3/pcap_fileno.3.gz
man/man3/pcap_findalldevs.3.gz
man/man3/pcap_freecode.3.gz
+man/man3/pcap_get_required_select_timeout.3.gz
man/man3/pcap_get_selectable_fd.3.gz
man/man3/pcap_get_tstamp_precision.3.gz
man/man3/pcap_geterr.3.gz
@@ -60,6 +64,7 @@ man/man3/pcap_set_buffer_size.3.gz
man/man3/pcap_set_datalink.3.gz
man/man3/pcap_set_immediate_mode.3.gz
man/man3/pcap_set_promisc.3.gz
+man/man3/pcap_set_protocol_linux.3.gz
man/man3/pcap_set_rfmon.3.gz
man/man3/pcap_set_snaplen.3.gz
man/man3/pcap_set_timeout.3.gz