aboutsummaryrefslogtreecommitdiff
path: root/net/libpcap
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-01-24 22:14:45 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-01-24 22:14:45 +0000
commit632fdaa01599611825c05b62f845351b29b2f87c (patch)
tree8acedbb69c421f0c72a90cb83ad5095b5c6c5266 /net/libpcap
parent58eae5d99cbdce01c654209a59436da6dab4ef0f (diff)
downloadports-632fdaa01599611825c05b62f845351b29b2f87c.tar.gz
ports-632fdaa01599611825c05b62f845351b29b2f87c.zip
- Explictly declare when cloning is allowed.
Bump PORTREVISION to address this for older packages. - While here fix whitespace. Noticed by: csjp@
Notes
Notes: svn path=/head/; revision=248488
Diffstat (limited to 'net/libpcap')
-rw-r--r--net/libpcap/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index dbc4e62fd473..aa69dabf7fe9 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libpcap
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.tcpdump.org/release/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -84,7 +85,7 @@ MAN5= pcap-savefile.5
MAN7= pcap-filter.7 pcap-linktype.7
MLINKS= pcap_datalink_val_to_name.3 \
- pcap_datalink_val_to_description.3 \
+ pcap_datalink_val_to_description.3 \
pcap_dump_open.3 pcap_dump_fopen.3 \
pcap_geterr.3 pcap_perror.3 \
pcap_inject.3 pcap_sendpacket.3 \
@@ -123,6 +124,14 @@ post-install:
.include <bsd.port.pre.mk>
+# Packages are built on a kernel that has cloning, but the resulting
+# package will be run on a system that does not have cloning (7.x).
+# Always use bpf device, but specify CFLAGS if we have cloning.
+CONFIGURE_ARGS+= --with-pcap=bpf
+.if ${OSVERSION} > 800043
+CFLAGS+= -DHAVE_DEVICE_CLONING=1
+.endif
+
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif