aboutsummaryrefslogtreecommitdiff
path: root/net/libproxy
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-27 05:26:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-27 05:26:27 +0000
commit6b3986914a3155d162d7d2ddfcd936c38e3d1c7c (patch)
tree4a2f6db6267bfa2492846f519b422ef559409b6e /net/libproxy
parentfbf0ee5e6da42985c449e9db91624c7c5e344c58 (diff)
downloadports-6b3986914a3155d162d7d2ddfcd936c38e3d1c7c.tar.gz
ports-6b3986914a3155d162d7d2ddfcd936c38e3d1c7c.zip
Add libproxy, a library that provides automatic proxy configuration management.
Plug-ins are available for GNOME, KDE, Mozilla, and WebKit. WWW: http://code.google.com/p/libproxy/
Notes
Notes: svn path=/head/; revision=229131
Diffstat (limited to 'net/libproxy')
-rw-r--r--net/libproxy/Makefile34
-rw-r--r--net/libproxy/distinfo3
-rw-r--r--net/libproxy/files/patch-configure95
-rw-r--r--net/libproxy/files/patch-src_bin_Makefile.in11
-rw-r--r--net/libproxy/files/patch-src_lib_proxy_factory.c10
-rw-r--r--net/libproxy/files/patch-src_lib_url.c10
-rw-r--r--net/libproxy/files/patch-src_plugins_Makefile.in84
-rw-r--r--net/libproxy/files/patch-src_plugins_mozjs.c10
-rw-r--r--net/libproxy/files/patch-src_plugins_webkit.c10
-rw-r--r--net/libproxy/pkg-descr9
-rw-r--r--net/libproxy/pkg-plist13
11 files changed, 289 insertions, 0 deletions
diff --git a/net/libproxy/Makefile b/net/libproxy/Makefile
new file mode 100644
index 000000000000..df852c2696a7
--- /dev/null
+++ b/net/libproxy/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libproxy
+# Date created: 26 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libproxy
+PORTVERSION= 0.2.3
+PORTREVISION?= 0
+CATEGORIES?= net devel
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT?= Library that provides automatic proxy configuration management
+
+USE_GMAKE= yes
+USE_GNOME+= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS?=--without-gnome --without-kde --without-webkit \
+ --without-mozjs --without-networkmanager --with-python \
+ --with-envvar --with-file
+
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+.if !defined(LIBPROXY_SLAVE)
+USE_LDCONFIG= yes
+USE_PYTHON= yes
+CONFLICTS= libmonetra-[0-9]*
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/libproxy/distinfo b/net/libproxy/distinfo
new file mode 100644
index 000000000000..bf5e6bafaea2
--- /dev/null
+++ b/net/libproxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (libproxy-0.2.3.tar.gz) = 86b635e1eb2d665cfbef4c6134fe6604
+SHA256 (libproxy-0.2.3.tar.gz) = 59ded160b3547d29e37cc9d06359f7f37d94112214e4532430cd65e704c1339a
+SIZE (libproxy-0.2.3.tar.gz) = 378773
diff --git a/net/libproxy/files/patch-configure b/net/libproxy/files/patch-configure
new file mode 100644
index 000000000000..86ec7097bf13
--- /dev/null
+++ b/net/libproxy/files/patch-configure
@@ -0,0 +1,95 @@
+--- configure.orig 2009-02-27 00:08:46.000000000 -0500
++++ configure 2009-02-27 00:09:25.000000000 -0500
+@@ -20509,16 +20509,16 @@ fi
+ if test "${with_gnome+set}" = set; then
+ withval=$with_gnome;
+ else
+- test x$have_gconf == xyes &&
+- test x$have_x11 == xyes &&
+- test x$have_xmu == xyes &&
++ test x$have_gconf = xyes &&
++ test x$have_x11 = xyes &&
++ test x$have_xmu = xyes &&
+ with_gnome=yes
+ fi
+
+ if test x$with_gnome = xyes; then
+- if test x$have_gconf == xyes && \
+- test x$have_x11 == xyes && \
+- test x$have_xmu == xyes; then
++ if test x$have_gconf = xyes && \
++ test x$have_x11 = xyes && \
++ test x$have_xmu = xyes; then
+ GNOME_CFLAGS="$x11_CFLAGS $xmu_CFLAGS $gconf_CFLAGS"
+ GNOME_LIBS="$x11_LIBS $xmu_LIBS $gconf_LIBS"
+
+@@ -20545,14 +20545,14 @@ fi
+ if test "${with_kde+set}" = set; then
+ withval=$with_kde;
+ else
+- test x$have_x11 == xyes &&
+- test x$have_xmu == xyes &&
++ test x$have_x11 = xyes &&
++ test x$have_xmu = xyes &&
+ with_kde=yes
+ fi
+
+ if test x$with_kde = xyes; then
+- if test x$have_x11 == xyes && \
+- test x$have_xmu == xyes; then
++ if test x$have_x11 = xyes && \
++ test x$have_xmu = xyes; then
+ KDE_CFLAGS="$x11_CFLAGS $xmu_CFLAGS"
+ KDE_LIBS="$x11_LIBS $xmu_LIBS"
+
+@@ -20579,11 +20579,11 @@ fi
+ if test "${with_webkit+set}" = set; then
+ withval=$with_webkit;
+ else
+- test x$have_webkit == xyes && with_webkit=yes
++ test x$have_webkit = xyes && with_webkit=yes
+ fi
+
+ if test x$with_webkit = xyes; then
+- if test x$have_webkit == xyes; then
++ if test x$have_webkit = xyes; then
+ WEBKIT_CFLAGS="$webkit_CFLAGS"
+ WEBKIT_LIBS="$webkit_LIBS"
+
+@@ -20610,11 +20610,11 @@ fi
+ if test "${with_mozjs+set}" = set; then
+ withval=$with_mozjs;
+ else
+- test x$have_mozjs == xyes && with_mozjs=yes
++ test x$have_mozjs = xyes && with_mozjs=yes
+ fi
+
+ if test x$with_mozjs = xyes; then
+- if test x$have_mozjs == xyes; then
++ if test x$have_mozjs = xyes; then
+ MOZJS_CFLAGS="$mozjs_CFLAGS"
+ MOZJS_LIBS="$mozjs_LIBS"
+
+@@ -20641,11 +20641,11 @@ fi
+ if test "${with_networkmanager+set}" = set; then
+ withval=$with_networkmanager;
+ else
+- test x$have_networkmanager == xyes && with_networkmanager=yes
++ test x$have_networkmanager = xyes && with_networkmanager=yes
+ fi
+
+ if test x$with_networkmanager = xyes; then
+- if test x$have_networkmanager == xyes; then
++ if test x$have_networkmanager = xyes; then
+ NETWORKMANAGER_CFLAGS="$NetworkManager_CFLAGS"
+ NETWORKMANAGER_LIBS="$NetworkManager_LIBS"
+
+@@ -21610,7 +21610,7 @@ fi
+
+ PLUGINDIR=$libdir/$PACKAGE_NAME/$PACKAGE_VERSION/plugins
+
+-CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\" -D_POSIX_C_SOURCE=1"
++CFLAGS="-g -std=c99 $CFLAGS -DPLUGINDIR=\\\"$PLUGINDIR\\\" -DSYSCONFDIR=\\\"$sysconfdir\\\""
+
+ ### Checks for library functions.
+
diff --git a/net/libproxy/files/patch-src_bin_Makefile.in b/net/libproxy/files/patch-src_bin_Makefile.in
new file mode 100644
index 000000000000..3cf5ea2e84ff
--- /dev/null
+++ b/net/libproxy/files/patch-src_bin_Makefile.in
@@ -0,0 +1,11 @@
+--- src/bin/Makefile.in.orig 2009-02-26 23:50:56.000000000 -0500
++++ src/bin/Makefile.in 2009-02-26 23:51:00.000000000 -0500
+@@ -210,7 +210,7 @@ xmu_LIBS = @xmu_LIBS@
+ # Command line interface to libproxy
+ proxy_SOURCES = proxy.c
+ proxy_CFLAGS = -I$(top_srcdir)/src/lib
+-proxy_LDFLAGS = -ldl
++proxy_LDFLAGS =
+ proxy_LDADD = ../lib/libproxy.la
+ all: all-am
+
diff --git a/net/libproxy/files/patch-src_lib_proxy_factory.c b/net/libproxy/files/patch-src_lib_proxy_factory.c
new file mode 100644
index 000000000000..bdc815461ee8
--- /dev/null
+++ b/net/libproxy/files/patch-src_lib_proxy_factory.c
@@ -0,0 +1,10 @@
+--- src/lib/proxy_factory.c.orig 2009-02-26 23:49:38.000000000 -0500
++++ src/lib/proxy_factory.c 2009-02-26 23:49:58.000000000 -0500
+@@ -26,6 +26,7 @@
+ #include <dlfcn.h>
+ #include <math.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <pthread.h>
+
diff --git a/net/libproxy/files/patch-src_lib_url.c b/net/libproxy/files/patch-src_lib_url.c
new file mode 100644
index 000000000000..0ca5714efef5
--- /dev/null
+++ b/net/libproxy/files/patch-src_lib_url.c
@@ -0,0 +1,10 @@
+--- src/lib/url.c.orig 2009-02-26 23:45:38.000000000 -0500
++++ src/lib/url.c 2009-02-26 23:47:25.000000000 -0500
+@@ -25,6 +25,7 @@
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <arpa/inet.h>
+
+ #include "misc.h"
diff --git a/net/libproxy/files/patch-src_plugins_Makefile.in b/net/libproxy/files/patch-src_plugins_Makefile.in
new file mode 100644
index 000000000000..62aada090868
--- /dev/null
+++ b/net/libproxy/files/patch-src_plugins_Makefile.in
@@ -0,0 +1,84 @@
+--- src/plugins/Makefile.in.orig 2009-02-27 00:10:06.000000000 -0500
++++ src/plugins/Makefile.in 2009-02-27 00:10:56.000000000 -0500
+@@ -70,21 +70,21 @@ file_la_LINK = $(LIBTOOL) --tag=CC $(AM_
+ --mode=link $(CCLD) $(file_la_CFLAGS) $(CFLAGS) \
+ $(file_la_LDFLAGS) $(LDFLAGS) -o $@
+ @WITH_FILE_TRUE@am_file_la_rpath = -rpath $(plugindir)
+-gnome_la_DEPENDENCIES = ../lib/libproxy.la
++gnome_la_DEPENDENCIES =
+ am_gnome_la_OBJECTS = gnome_la-gnome.lo gnome_la-xhasclient.lo
+ gnome_la_OBJECTS = $(am_gnome_la_OBJECTS)
+ gnome_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CCLD) $(gnome_la_CFLAGS) $(CFLAGS) \
+ $(gnome_la_LDFLAGS) $(LDFLAGS) -o $@
+ @WITH_GNOME_TRUE@am_gnome_la_rpath = -rpath $(plugindir)
+-kde_la_DEPENDENCIES = ../lib/libproxy.la
++kde_la_DEPENDENCIES =
+ am_kde_la_OBJECTS = kde_la-kde.lo kde_la-xhasclient.lo
+ kde_la_OBJECTS = $(am_kde_la_OBJECTS)
+ kde_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CCLD) $(kde_la_CFLAGS) $(CFLAGS) \
+ $(kde_la_LDFLAGS) $(LDFLAGS) -o $@
+ @WITH_KDE_TRUE@am_kde_la_rpath = -rpath $(plugindir)
+-mozjs_la_DEPENDENCIES = ../lib/libproxy.la
++mozjs_la_DEPENDENCIES =
+ am_mozjs_la_OBJECTS = mozjs_la-mozjs.lo
+ nodist_mozjs_la_OBJECTS =
+ mozjs_la_OBJECTS = $(am_mozjs_la_OBJECTS) $(nodist_mozjs_la_OBJECTS)
+@@ -92,7 +92,7 @@ mozjs_la_LINK = $(LIBTOOL) --tag=CC $(AM
+ --mode=link $(CCLD) $(mozjs_la_CFLAGS) $(CFLAGS) \
+ $(mozjs_la_LDFLAGS) $(LDFLAGS) -o $@
+ @WITH_MOZJS_TRUE@am_mozjs_la_rpath = -rpath $(plugindir)
+-networkmanager_la_DEPENDENCIES = ../lib/libproxy.la
++networkmanager_la_DEPENDENCIES =
+ am_networkmanager_la_OBJECTS = networkmanager_la-networkmanager.lo
+ networkmanager_la_OBJECTS = $(am_networkmanager_la_OBJECTS)
+ networkmanager_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \
+@@ -101,7 +101,7 @@ networkmanager_la_LINK = $(LIBTOOL) --ta
+ $(networkmanager_la_LDFLAGS) $(LDFLAGS) -o $@
+ @WITH_NETWORKMANAGER_TRUE@am_networkmanager_la_rpath = -rpath \
+ @WITH_NETWORKMANAGER_TRUE@ $(plugindir)
+-webkit_la_DEPENDENCIES = ../lib/libproxy.la
++webkit_la_DEPENDENCIES =
+ am_webkit_la_OBJECTS = webkit_la-webkit.lo
+ nodist_webkit_la_OBJECTS =
+ webkit_la_OBJECTS = $(am_webkit_la_OBJECTS) \
+@@ -293,33 +293,33 @@ file_la_LDFLAGS = -module -avoid-version
+ # GConf/GNOME Config Plugin
+ gnome_la_SOURCES = gnome.c xhasclient.c
+ gnome_la_CFLAGS = -I$(top_srcdir)/src/lib @GNOME_CFLAGS@
+-gnome_la_LIBADD = ../lib/libproxy.la
++gnome_la_LIBADD = -lproxy
+ gnome_la_LDFLAGS = -module -avoid-version @GNOME_LIBS@
+
+ # KDE Config Plugin
+ kde_la_SOURCES = kde.c xhasclient.c
+ kde_la_CFLAGS = -I$(top_srcdir)/src/lib @KDE_CFLAGS@
+-kde_la_LIBADD = ../lib/libproxy.la
++kde_la_LIBADD = -lproxy
+ kde_la_LDFLAGS = -module -avoid-version @KDE_LIBS@
+
+ # WebKit (JavaScriptCore) based PAC runner
+ webkit_la_SOURCES = webkit.c
+ webkit_la_CFLAGS = -I$(top_srcdir)/src/lib @WEBKIT_CFLAGS@
+-webkit_la_LIBADD = ../lib/libproxy.la
++webkit_la_LIBADD = -lproxy
+ webkit_la_LDFLAGS = -module -avoid-version @WEBKIT_LIBS@
+ nodist_webkit_la_SOURCES = pacutils.h
+
+ # Mozilla (Spidermonkey) based PAC runner
+ mozjs_la_SOURCES = mozjs.c
+ mozjs_la_CFLAGS = -I$(top_srcdir)/src/lib @MOZJS_CFLAGS@
+-mozjs_la_LIBADD = ../lib/libproxy.la
++mozjs_la_LIBADD = -lproxy
+ mozjs_la_LDFLAGS = -module -avoid-version @MOZJS_LIBS@
+ nodist_mozjs_la_SOURCES = pacutils.h
+
+ # NetworkManager Plugin
+ networkmanager_la_SOURCES = networkmanager.c
+ networkmanager_la_CFLAGS = -I$(top_srcdir)/src/lib @NETWORKMANAGER_CFLAGS@
+-networkmanager_la_LIBADD = ../lib/libproxy.la
++networkmanager_la_LIBADD = -lproxy
+ networkmanager_la_LDFLAGS = -module -avoid-version @NETWORKMANAGER_LIBS@
+ BUILT_SOURCES = pacutils.h
+ CLEANFILES = pacutils.h
diff --git a/net/libproxy/files/patch-src_plugins_mozjs.c b/net/libproxy/files/patch-src_plugins_mozjs.c
new file mode 100644
index 000000000000..b2c5aa67088d
--- /dev/null
+++ b/net/libproxy/files/patch-src_plugins_mozjs.c
@@ -0,0 +1,10 @@
+--- src/plugins/mozjs.c.orig 2009-02-27 00:18:46.000000000 -0500
++++ src/plugins/mozjs.c 2009-02-27 00:18:56.000000000 -0500
+@@ -23,6 +23,7 @@
+ #include <sys/socket.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+ #define __USE_BSD
+ #include <unistd.h>
+
diff --git a/net/libproxy/files/patch-src_plugins_webkit.c b/net/libproxy/files/patch-src_plugins_webkit.c
new file mode 100644
index 000000000000..9fb65909a18c
--- /dev/null
+++ b/net/libproxy/files/patch-src_plugins_webkit.c
@@ -0,0 +1,10 @@
+--- src/plugins/webkit.c.orig 2009-02-27 00:22:39.000000000 -0500
++++ src/plugins/webkit.c 2009-02-27 00:22:50.000000000 -0500
+@@ -21,6 +21,7 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #include <netdb.h>
+ #include <arpa/inet.h>
+ #define __USE_BSD
diff --git a/net/libproxy/pkg-descr b/net/libproxy/pkg-descr
new file mode 100644
index 000000000000..a542311ccbff
--- /dev/null
+++ b/net/libproxy/pkg-descr
@@ -0,0 +1,9 @@
+Libproxy exists to answer the question: Given a network resource, how do I
+reach it? It handles all the details, enabling you to get back to
+programming.
+
+GNOME? KDE? Command line? WPAD? PAC? Network changed? It doesn't matter!
+Just ask libproxy what proxy to use: you get simple code and your users
+get correct, consistant behavior and broad infrastructure compatibility.
+
+WWW: http://code.google.com/p/libproxy/
diff --git a/net/libproxy/pkg-plist b/net/libproxy/pkg-plist
new file mode 100644
index 000000000000..a018b864b2c4
--- /dev/null
+++ b/net/libproxy/pkg-plist
@@ -0,0 +1,13 @@
+bin/proxy
+include/proxy.h
+lib/libproxy.a
+lib/libproxy.la
+lib/libproxy.so
+lib/libproxy.so.0
+lib/libproxy/%%VERSION%%/plugins/envvar.so
+lib/libproxy/%%VERSION%%/plugins/file.so
+libdata/pkgconfig/libproxy-1.0.pc
+%%PYTHON_SITELIBDIR%%/libproxy.py
+@dirrmtry lib/libproxy/%%VERSION%%/plugins
+@dirrmtry lib/libproxy/%%VERSION%%
+@dirrmtry lib/libproxy