aboutsummaryrefslogtreecommitdiff
path: root/net/libproxy
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-12-04 15:45:07 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-12-04 15:45:07 +0000
commitcb95fe07522e6f70708a116cefd008b07bb2785c (patch)
tree833bd70372561440ef27e4970b315011db6b2433 /net/libproxy
parentf0edf2ebcb5657c8f3958b7830de6a157599a2e2 (diff)
downloadports-cb95fe07522e6f70708a116cefd008b07bb2785c.tar.gz
ports-cb95fe07522e6f70708a116cefd008b07bb2785c.zip
Fix linking with libperl.so.xx.y.
With hat: perl@ Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=373961
Diffstat (limited to 'net/libproxy')
-rw-r--r--net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt b/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt
new file mode 100644
index 000000000000..741a5f669aa6
--- /dev/null
+++ b/net/libproxy/files/patch-bindings_perl_src_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- bindings/perl/src/CMakeLists.txt.orig 2010-09-01 20:23:34 UTC
++++ bindings/perl/src/CMakeLists.txt
+@@ -12,6 +12,7 @@ set(Libproxy_LIB_SRCS Libproxy.c)
+
+ set(CMAKE_C_COMPILER ${CMAKE_CXX_COMPILER})
+ set(CMAKE_C_FLAGS ${PERL_CXX_FLAGS} )
++SET(CMAKE_INSTALL_RPATH ${PERL_INCLUDE_DIR})
+
+ set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/perl/blib/arch/auto/Net)
+ add_library(PLlibproxy SHARED ${Libproxy_LIB_SRCS})