aboutsummaryrefslogtreecommitdiff
path: root/net/librsync
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-03 06:44:05 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-03 06:44:05 +0000
commit0b9b0e3df4a1e60723c460d7a580e88641b98d71 (patch)
tree93e6862a22f56b91775a0938eac363d2d0376d19 /net/librsync
parent5b0cb4432a33fb156c7c84444ace7bc0463c2d23 (diff)
downloadports-0b9b0e3df4a1e60723c460d7a580e88641b98d71.tar.gz
ports-0b9b0e3df4a1e60723c460d7a580e88641b98d71.zip
- Do not install useless .la files
PR: 35498 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=55450
Diffstat (limited to 'net/librsync')
-rw-r--r--net/librsync/Makefile7
-rw-r--r--net/librsync/files/patch-ltmain.sh42
-rw-r--r--net/librsync/pkg-plist1
3 files changed, 44 insertions, 6 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
index a6c6a85e9cab..10a447b6dbe5 100644
--- a/net/librsync/Makefile
+++ b/net/librsync/Makefile
@@ -8,6 +8,7 @@
PORTNAME= librsync
PORTVERSION= 0.9.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= rproxy
@@ -19,18 +20,14 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include"
CONFIGURE_ARGS= --enable-shared --disable-trace
-
USE_GMAKE= yes
INSTALLS_SHLIB= yes
MAN1= rdiff.1
MAN3= librsync.3
-pre-build:
- @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/net/librsync/files/patch-ltmain.sh b/net/librsync/files/patch-ltmain.sh
new file mode 100644
index 000000000000..478bd58c315c
--- /dev/null
+++ b/net/librsync/files/patch-ltmain.sh
@@ -0,0 +1,42 @@
+--- ltmain.sh.orig Fri Sep 7 03:45:46 2001
++++ ltmain.sh Sat Mar 2 15:45:11 2002
+@@ -1040,7 +1040,7 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ test "X$arg" = "X-lc" && continue
+ ;;
+@@ -1048,7 +1048,7 @@
+ fi
+ if test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -2439,7 +2439,7 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
+- *-*-openbsd*)
++ *-*-openbsd* | *-*-freebsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
+ *)
+@@ -4208,10 +4208,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/net/librsync/pkg-plist b/net/librsync/pkg-plist
index 9ce7bd2185c4..4be1fc74746d 100644
--- a/net/librsync/pkg-plist
+++ b/net/librsync/pkg-plist
@@ -1,6 +1,5 @@
bin/rdiff
include/rsync.h
lib/librsync.a
-lib/librsync.la
lib/librsync.so
lib/librsync.so.1