aboutsummaryrefslogtreecommitdiff
path: root/net/librsync
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-07-01 01:19:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-07-01 01:19:27 +0000
commit362459a8d26ba4b9149d0decb2cd821e2765ee08 (patch)
tree7b688951b760242b1cd732c166d5aa5afbcc9b0c /net/librsync
parent728e982e48d868bd59955770be70b479415cd715 (diff)
downloadports-362459a8d26ba4b9149d0decb2cd821e2765ee08.tar.gz
ports-362459a8d26ba4b9149d0decb2cd821e2765ee08.zip
clang-with-ports fix: Declare USE_CSTD=gnu89.
Split out CPPFLAGS from CONFIGURE_ENV.
Notes
Notes: svn path=/head/; revision=276758
Diffstat (limited to 'net/librsync')
-rw-r--r--net/librsync/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
index ea34d384df95..933708506f00 100644
--- a/net/librsync/Makefile
+++ b/net/librsync/Makefile
@@ -19,9 +19,10 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
+USE_CSTD= gnu89
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-shared --disable-trace
USE_LDCONFIG= yes