aboutsummaryrefslogtreecommitdiff
path: root/net/librsync
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-02 11:58:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-02 11:58:44 +0000
commit452a10af6cfcbcd01883507fcb9017934a4af241 (patch)
treefce77126e9f645dc368fce601c1812a28e3cb7ee /net/librsync
parent5d749b104341c1ffbcef04fd389db5a1301e64f4 (diff)
downloadports-452a10af6cfcbcd01883507fcb9017934a4af241.tar.gz
ports-452a10af6cfcbcd01883507fcb9017934a4af241.zip
Move net/librsync2 to net/librsync
- Bump PORTREVISION of dependent ports for dependency change net/librsync was removed from ports tree almost 3 years ago. from MOVED: net/librsync|net/librsync2|2017-04-28|Unmaintained, CVE-2014-8242, use net/librsync2 instead
Notes
Notes: svn path=/head/; revision=530278
Diffstat (limited to 'net/librsync')
-rw-r--r--net/librsync/Makefile26
-rw-r--r--net/librsync/distinfo3
-rw-r--r--net/librsync/files/patch-CMakeLists.txt28
-rw-r--r--net/librsync/pkg-descr8
-rw-r--r--net/librsync/pkg-plist8
5 files changed, 73 insertions, 0 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
new file mode 100644
index 000000000000..0417c40f27da
--- /dev/null
+++ b/net/librsync/Makefile
@@ -0,0 +1,26 @@
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= librsync
+PORTVERSION= 2.2.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net devel
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Library for delta compression of streams
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libpopt.so:devel/popt
+
+USES= compiler:c11 cmake
+USE_LDCONFIG= yes
+USE_GITHUB= yes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librsync.so.${PORTVERSION}
+ ${INSTALL_MAN} ${WRKSRC}/doc/librsync.3 ${STAGEDIR}${MANPREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/doc/rdiff.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/librsync/distinfo b/net/librsync/distinfo
new file mode 100644
index 000000000000..6197d601a9b1
--- /dev/null
+++ b/net/librsync/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1572485097
+SHA256 (librsync-librsync-v2.2.1_GH0.tar.gz) = b5ab8e2092b82b7d7bb9c1dd52e6a77083a89f8ad9b9309da611f490d0b49a71
+SIZE (librsync-librsync-v2.2.1_GH0.tar.gz) = 180649
diff --git a/net/librsync/files/patch-CMakeLists.txt b/net/librsync/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9dd6b24bd2d9
--- /dev/null
+++ b/net/librsync/files/patch-CMakeLists.txt
@@ -0,0 +1,28 @@
+--- CMakeLists.txt.orig 2019-11-01 17:45:34.100156000 -0400
++++ CMakeLists.txt 2019-11-01 17:46:14.856811000 -0400
+@@ -158,6 +158,12 @@
+ message (STATUS "BUILD_HOSTNAME = ${BUILD_HOSTNAME}")
+ message (STATUS "CMAKE_SYSTEM = ${CMAKE_SYSTEM}")
+
++# We need to be able to #include "file" from a few places,
++# * The original source dir
++# * The generated source dir
++include_directories(${CMAKE_CURRENT_BINARY_DIR}/src)
++include_directories(${CMAKE_CURRENT_SOURCE_DIR}/src)
++
+ # Find POPT
+ find_package(POPT)
+ if (POPT_FOUND)
+@@ -314,12 +320,6 @@
+
+ # Create conf files
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config.h)
+-
+-# We need to be able to #include "file" from a few places,
+-# * The original source dir
+-# * The generated source dir
+-include_directories(${CMAKE_CURRENT_BINARY_DIR}/src)
+-include_directories(${CMAKE_CURRENT_SOURCE_DIR}/src)
+
+
+ ########### next target ###############
diff --git a/net/librsync/pkg-descr b/net/librsync/pkg-descr
new file mode 100644
index 000000000000..6fc405821cd0
--- /dev/null
+++ b/net/librsync/pkg-descr
@@ -0,0 +1,8 @@
+The librsync library implements network delta-compression of streams and
+files. The algorithm is similar to that used in the rsync(1) and xdelta(2)
+programs, but specialized for transfer of arbitrary-length octet streams.
+Unlike most diff programs, librsync does not require access to both of the
+files on the same machine, but rather only a short ``signature'' of the
+old file and the complete contents of the new file.
+
+WWW: https://github.com/librsync/librsync
diff --git a/net/librsync/pkg-plist b/net/librsync/pkg-plist
new file mode 100644
index 000000000000..49a8a420afc3
--- /dev/null
+++ b/net/librsync/pkg-plist
@@ -0,0 +1,8 @@
+bin/rdiff
+include/librsync.h
+include/librsync_export.h
+lib/librsync.so
+lib/librsync.so.2
+lib/librsync.so.2.2.1
+man/man1/rdiff.1.gz
+man/man3/librsync.3.gz