aboutsummaryrefslogtreecommitdiff
path: root/net/librsync
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-05-17 09:28:49 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-05-17 09:28:49 +0000
commit84281e0dac6e19be8bc5f51c99fa0cf11a7bfe44 (patch)
treeab5724cd7129149013d74d19a38bbb876145d58d /net/librsync
parentd932c98957d102efa17ad85fa3958fe1fa509170 (diff)
downloadports-84281e0dac6e19be8bc5f51c99fa0cf11a7bfe44.tar.gz
ports-84281e0dac6e19be8bc5f51c99fa0cf11a7bfe44.zip
net/librsync: bring "make test" fix closer to original port
Feedback https://github.com/librsync/librsync/issues/199 and second investigation shows that only the shebang line of said test file needs fixing. Approved by: (blanket)
Notes
Notes: svn path=/head/; revision=535536
Diffstat (limited to 'net/librsync')
-rw-r--r--net/librsync/Makefile5
-rw-r--r--net/librsync/files/patch-tests_rdiff__bad__option.sh5
-rwxr-xr-xnet/librsync/files/rdiff_bad_option.sh32
3 files changed, 5 insertions, 37 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
index 4fdeea08fcd7..001ad4f0b16f 100644
--- a/net/librsync/Makefile
+++ b/net/librsync/Makefile
@@ -13,7 +13,6 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpopt.so:devel/popt
-TEST_DEPENDS= bash:shells/bash
USES= cmake compiler:c11 localbase:ldflags
@@ -25,8 +24,4 @@ TEST_TARGET= check
PLIST_SUB= PORTVERSION=${PORTVERSION}
-pre-test:
- ${CP} ${FILESDIR}/rdiff_bad_option.sh ${WRKSRC}/tests/
- ${CHMOD} +x ${WRKSRC}/tests/rdiff_bad_option.sh
-
.include <bsd.port.mk>
diff --git a/net/librsync/files/patch-tests_rdiff__bad__option.sh b/net/librsync/files/patch-tests_rdiff__bad__option.sh
new file mode 100644
index 000000000000..1e29918594d0
--- /dev/null
+++ b/net/librsync/files/patch-tests_rdiff__bad__option.sh
@@ -0,0 +1,5 @@
+--- tests/rdiff_bad_option.sh.orig 2020-04-07 06:57:48 UTC
++++ tests/rdiff_bad_option.sh
+@@ -1,1 +1,1 @@
+-#! /bin/bash -ex
++#! /bin/sh -ex
diff --git a/net/librsync/files/rdiff_bad_option.sh b/net/librsync/files/rdiff_bad_option.sh
deleted file mode 100755
index fe8b62b5ec76..000000000000
--- a/net/librsync/files/rdiff_bad_option.sh
+++ /dev/null
@@ -1,32 +0,0 @@
-#! /usr/bin/env bash
-
-# taken from https://github.com/librsync/librsync/blob/master/tests/rdiff_bad_option.sh
-# and adapted to suit the FreeBSD ports build rig by Matthias Andree, 2020-05-16
-
-# librsync -- the library for network deltas
-
-# Copyright (C) 2016 by Martin Pool
-
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU Lesser General Public License
-# as published by the Free Software Foundation; either version 2.1 of
-# the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-
-
-# Bad command-line options return an error and print a message.
-
-set -ex
-errout=`mktemp -t rdiff_bad_option_test_XXXXXXX`
-trap "rm $errout" EXIT
-! $1/rdiff --imaginary-option 2>"$errout"
-cat "$errout"
-grep 'unknown option: --imaginary-option' "$errout"