aboutsummaryrefslogtreecommitdiff
path: root/net/libstorj
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-17 14:27:50 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-17 14:27:50 +0000
commit551dda72403745f8377aaac65ff2b89ae3e2a5b5 (patch)
treebbda46ec4dbd67d32d52ac3448c98a53248eb8bb /net/libstorj
parent098b598e0387c22b24ebc0537c968fed024dedb2 (diff)
downloadports-551dda72403745f8377aaac65ff2b89ae3e2a5b5.tar.gz
ports-551dda72403745f8377aaac65ff2b89ae3e2a5b5.zip
net/libstorj: fix build on non-x86
Use GCC, tested on powerpc64 but should also fix other architectes.
Notes
Notes: svn path=/head/; revision=568663
Diffstat (limited to 'net/libstorj')
-rw-r--r--net/libstorj/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net/libstorj/Makefile b/net/libstorj/Makefile
index 92d057f9ee9e..14762b8ee348 100644
--- a/net/libstorj/Makefile
+++ b/net/libstorj/Makefile
@@ -11,13 +11,6 @@ COMMENT= C library and CLI for encrypted file transfer on the Storj network
LICENSE= LGPL21+
-BROKEN_aarch64= fails to build: invokes x86 assembler
-BROKEN_armv6= fails to build: invokes x86 assembler
-BROKEN_armv7= fails to build: invokes x86 assembler
-BROKEN_mips= fails to build: invokes x86 assembler
-BROKEN_mips64= fails to build: invokes x86 assembler
-BROKEN_riscv64= fails to build: invokes x86 assembler
-
LIB_DEPENDS= libjson-c.so:devel/json-c \
libuv.so:devel/libuv \
libcurl.so:ftp/curl \
@@ -37,4 +30,10 @@ MAKE_JOBS_UNSAFE= yes # ./storjtests.h:10:10: fatal error: 'mockbridgeinfo.json
#CFLAGS+= -I. -I${LOCALBASE}/include
#LDFLAGS+= -L. -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+USE_GCC= yes
+.endif
+
.include <bsd.port.mk>