aboutsummaryrefslogtreecommitdiff
path: root/net/libtrace/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-09 09:22:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-09 09:22:06 +0000
commitf30ad1e5481b3ad97d99f9576d6701b33acc8193 (patch)
treebdde6939f36c217b4e31ef4c032c97285099b2ff /net/libtrace/Makefile
parent4bd3fabff926478fa04d851e726ed4f7fdefc986 (diff)
downloadports-f30ad1e5481b3ad97d99f9576d6701b33acc8193.tar.gz
ports-f30ad1e5481b3ad97d99f9576d6701b33acc8193.zip
Notes
Diffstat (limited to 'net/libtrace/Makefile')
-rw-r--r--net/libtrace/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/libtrace/Makefile b/net/libtrace/Makefile
new file mode 100644
index 000000000000..9f8c49968313
--- /dev/null
+++ b/net/libtrace/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libtrace
+# Date created: Mon Oct 8 20:32:57 PDT 2007
+# Whom: Matt Peterson <matt@peterson.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtrace
+PORTVERSION= 3.0.3
+CATEGORIES= net
+MASTER_SITES= http://research.wand.net.nz/software/libtrace/ \
+ http://matt.peterson.org/FreeBSD/ports/
+
+MAINTAINER= matt@peterson.org
+COMMENT= C library for network device, raw & compressed network flows
+
+CONFIGURE_ARGS= --with-libpcap=${LOCALBASE}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+
+MAN1= traceanon.1 tracemerge.1 tracesplit.1 tracefilter.1 traceconvert.1 \
+ tracesplit_dir.1 tracepktdump.1 tracertstats.1 tracestats.1 \
+ tracesummary.1 tracereport.1 traceflow.1
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>