aboutsummaryrefslogtreecommitdiff
path: root/net/licq
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-08-09 18:42:48 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-08-09 18:42:48 +0000
commitd4e17048ac1ae92b07dd0d5380ee30376b06abe5 (patch)
tree4683561c6e58883656902a1f7896ee2dd9e6eeed /net/licq
parentff557b9f3359700f3756cfbe5a1e980de27efa0c (diff)
downloadports-d4e17048ac1ae92b07dd0d5380ee30376b06abe5.tar.gz
ports-d4e17048ac1ae92b07dd0d5380ee30376b06abe5.zip
Notes
Diffstat (limited to 'net/licq')
-rw-r--r--net/licq/Makefile6
-rw-r--r--net/licq/Makefile.inc19
-rw-r--r--net/licq/distinfo2
-rw-r--r--net/licq/files/patch-ad48
-rw-r--r--net/licq/files/patch-socket.cpp40
-rw-r--r--net/licq/pkg-plist3
6 files changed, 50 insertions, 68 deletions
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 5e9e1d290c6c..eede69776e3e 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -32,12 +32,6 @@ CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
.endif
.endif
-post-patch:
- @${PERL5} -pi -e 's|<wait.h>|<sys/wait.h>|g' \
- ${WRKSRC}/src/sighandler.c
- @${PERL5} -pi -e 's|.program_transform_name.|s,x,x,|' \
- ${WRKSRC}/src/Makefile.in
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net/licq/Makefile.inc b/net/licq/Makefile.inc
index 5d1ad736d3ec..5862b3e094dc 100644
--- a/net/licq/Makefile.inc
+++ b/net/licq/Makefile.inc
@@ -2,25 +2,20 @@
# $FreeBSD$
PKGNAMEPREFIX= licq-
-LICQ_VER= 1.0.4
-QT_LICQ_VER= ${LICQ_VER}
-RMS_LICQ_VER= 0.23
-CONSOLE_LICQ_VER= 1.0.4
-AUTO_REPLY_LICQ_VER= 1.0.2
-FORWARDER_LICQ_VER= 1.0.1
+LICQ_VER= 1.2.0a
+QT_LICQ_VER= 1.2.0
+RMS_LICQ_VER= 0.33
+CONSOLE_LICQ_VER= 1.2.0
+JONS_GTK_LICQ_VER= 0.20
.if ${PORTNAME} != "base"
RUN_DEPENDS+= licq:${PORTSDIR}/net/licq
.endif
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ftp://ftp.wibble.net/pub/licq/srcs/ \
- ftp://licq.darkorb.net/srcs/ \
- ftp://ftp.fanfic.org/pub/licq/srcs/ \
- ftp://ftp.inter-i.uni-mainz.de/pub/licq/srcs/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= licq
DISTNAME= ${PKGNAMEPREFIX}${LICQ_VER}
DISTFILES= ${DISTNAME}.tar.bz2
GNU_CONFIGURE= yes
-MD5_FILE= ${PORTSDIR}/net/licq/distinfo
+MD5_FILE?= ${PORTSDIR}/net/licq/distinfo
# USE_LIBTOOL doesn't work for these ports
#USE_LIBTOOL= yes
USE_GMAKE= yes
diff --git a/net/licq/distinfo b/net/licq/distinfo
index 07ec3269d3b8..aad2721a8dd4 100644
--- a/net/licq/distinfo
+++ b/net/licq/distinfo
@@ -1 +1 @@
-MD5 (licq-1.0.4.tar.bz2) = df3e50c1b03aa0cf2ecd1c27af3588e7
+MD5 (licq-1.2.0a.tar.bz2) = 3f977d83b36b26d1bc716be3e3336315
diff --git a/net/licq/files/patch-ad b/net/licq/files/patch-ad
deleted file mode 100644
index 7bf734c85ce6..000000000000
--- a/net/licq/files/patch-ad
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/socket.cpp.orig Tue Jul 4 20:51:50 2000
-+++ src/socket.cpp Mon Jul 24 03:32:56 2000
-@@ -12,6 +12,7 @@
- #include <netdb.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <osreldate.h>
-
- #ifndef MSG_DONTWAIT
- #define MSG_DONTWAIT 0
-@@ -288,7 +289,12 @@
- bool INetSocket::SetLocalAddress(bool bIp)
- {
- // Setup the local structure
-+
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- if (getsockname(m_nDescriptor, (struct sockaddr *)&m_sLocalAddr, &sizeofSockaddr) < 0)
- {
- m_nErrorType = SOCK_ERROR_errno;
-@@ -372,7 +378,11 @@
- m_sRemoteAddr.sin_family = AF_INET;
-
- // if connect fails then call CloseConnection to clean up before returning
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr);
-+#endif
- if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
- {
- // errno has been set
-@@ -504,7 +514,11 @@
- *---------------------------------------------------------------------------*/
- void TCPSocket::RecvConnection(TCPSocket &newSocket)
- {
-- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
-+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- newSocket.m_nDescriptor = accept(m_nDescriptor, (struct sockaddr *)&newSocket.m_sRemoteAddr, &sizeofSockaddr);
- newSocket.SetLocalAddress();
- }
diff --git a/net/licq/files/patch-socket.cpp b/net/licq/files/patch-socket.cpp
new file mode 100644
index 000000000000..4d39b2ff7103
--- /dev/null
+++ b/net/licq/files/patch-socket.cpp
@@ -0,0 +1,40 @@
+--- src/socket.cpp.orig Tue Jul 23 12:22:13 2002
++++ src/socket.cpp Thu Aug 8 03:07:32 2002
+@@ -13,6 +13,7 @@
+ #include <netdb.h>
+ #include <fcntl.h>
+ #include <unistd.h>
++#include <osreldate.h>
+
+ #ifdef HAVE_INET_ATON
+ #include <arpa/inet.h>
+@@ -304,6 +305,8 @@
+ // Setup the local structure
+ #ifdef USE_SOCKS5
+ int sizeofSockaddr = sizeof(struct sockaddr_in);
++#elif __FreeBSD_version < 400013
++ int sizeofSockaddr = sizeof(struct sockaddr_in);
+ #else
+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
+ #endif
+@@ -416,7 +419,11 @@
+ m_sRemoteAddr.sin_family = AF_INET;
+
+ // if connect fails then call CloseConnection to clean up before returning
++#if __FreeBSD_version < 400013
++ int sizeofSockaddr = sizeof(struct sockaddr);
++#else
+ socklen_t sizeofSockaddr = sizeof(struct sockaddr);
++#endif
+ if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
+ {
+ // errno has been set
+@@ -691,6 +698,8 @@
+ void TCPSocket::RecvConnection(TCPSocket &newSocket)
+ {
+ #ifdef USE_SOCKS5
++ int sizeofSockaddr = sizeof(struct sockaddr_in);
++#elif __FreeBSD_version < 400013
+ int sizeofSockaddr = sizeof(struct sockaddr_in);
+ #else
+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
diff --git a/net/licq/pkg-plist b/net/licq/pkg-plist
index ae5ddc74ce01..6876b88d1359 100644
--- a/net/licq/pkg-plist
+++ b/net/licq/pkg-plist
@@ -21,7 +21,7 @@ include/licq/licq_onevent.h
include/licq/licq_packets.h
include/licq/licq_plugin.h
include/licq/licq_plugind.h
-include/licq/licq_remoteserver.h
+include/licq/licq_proxy.h
include/licq/licq_sar.h
include/licq/licq_sighandler.h
include/licq/licq_socket.h
@@ -78,6 +78,7 @@ share/licq/translations/SWEDISH
share/licq/translations/SWEDISH_NAMES
share/licq/translations/SWEDISH_NAMES_COM
share/licq/translations/SWISS
+share/licq/translations/UKRAINIAN_WIN
share/licq/translations/UNITED_KINGDOM
share/licq/translations/UNITED_KINGDOM_COM
share/licq/utilities/BackOrifice.utility