aboutsummaryrefslogtreecommitdiff
path: root/net/linphone-base
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-03 09:28:02 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-03 09:28:02 +0000
commit12e432053c2d75620942a261f36e0cf9d2360e22 (patch)
tree4446340b0f465cbea0798ff9810f033168e0a28a /net/linphone-base
parentfa0540abce9abc735e913915b2899ae7d3ac85fd (diff)
downloadports-12e432053c2d75620942a261f36e0cf9d2360e22.tar.gz
ports-12e432053c2d75620942a261f36e0cf9d2360e22.zip
Notes
Diffstat (limited to 'net/linphone-base')
-rw-r--r--net/linphone-base/Makefile12
-rw-r--r--net/linphone-base/distinfo6
-rw-r--r--net/linphone-base/files/patch-coreapi::linphonecore.c15
-rw-r--r--net/linphone-base/files/patch-gtk-glade__Makefile.in16
-rw-r--r--net/linphone-base/pkg-plist5
-rw-r--r--net/linphone-base/pkg-plist.gui2
6 files changed, 34 insertions, 22 deletions
diff --git a/net/linphone-base/Makefile b/net/linphone-base/Makefile
index 285bc3b81c7e..8ab79aa547a3 100644
--- a/net/linphone-base/Makefile
+++ b/net/linphone-base/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= linphone
-PORTVERSION= 3.0.0
+PORTVERSION= 3.1.0
PORTEPOCH= 1
CATEGORIES?= net
MASTER_SITES= SAVANNAH/${PORTNAME}/stable/sources
@@ -45,8 +45,8 @@ PLIST_SUB+= NLS=""
.endif
.if defined(LINPHONE_GUI)
-BUILD_DEPENDS+= linphone-base>=3.0.0:${PORTSDIR}/net/linphone-base
-RUN_DEPENDS+= linphone-base>=3.0.0:${PORTSDIR}/net/linphone-base
+BUILD_DEPENDS+= linphone-base>=3.1.0:${PORTSDIR}/net/linphone-base
+RUN_DEPENDS+= linphone-base>=3.1.0:${PORTSDIR}/net/linphone-base
DESCR= ${PKGDIR}/pkg-descr.gui
PLIST= ${PKGDIR}/pkg-plist.gui
USE_GNOME+= libglade2
@@ -65,10 +65,10 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s| =| ?=|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^imgdir =/s|(datadir)|(pkgdatadir)|g' \
${WRKSRC}/mediastreamer2/src/Makefile.in
-.for file in configure src/gsm.c
+ @${REINPLACE_CMD} -e 's|gsm/gsm\.h|gsm.h|g ; \
+ s| -O2 -g ||g' ${WRKSRC}/mediastreamer2/configure
@${REINPLACE_CMD} -e 's|gsm/gsm\.h|gsm.h|g' \
- ${WRKSRC}/mediastreamer2/${file}
-.endfor
+ ${WRKSRC}/mediastreamer2/src/gsm.c
post-install:
.if defined(LINPHONE_GUI)
diff --git a/net/linphone-base/distinfo b/net/linphone-base/distinfo
index 4f0f64fd7d5f..78adff18b868 100644
--- a/net/linphone-base/distinfo
+++ b/net/linphone-base/distinfo
@@ -1,3 +1,3 @@
-MD5 (linphone-3.0.0.tar.gz) = 8c883bb267da5d2b6c7c2a5c52641a35
-SHA256 (linphone-3.0.0.tar.gz) = 68657f5efe147bd00ec1375daf3fe13ae1c81f906bf9d81ab4fad8f0ef1fabec
-SIZE (linphone-3.0.0.tar.gz) = 7577336
+MD5 (linphone-3.1.0.tar.gz) = ed40cf4088c306400b005bbd63ac36be
+SHA256 (linphone-3.1.0.tar.gz) = e41e99925e8c81a9e6c7f4cf399da1d9f571927413196898af46ecbebee6a91b
+SIZE (linphone-3.1.0.tar.gz) = 7794213
diff --git a/net/linphone-base/files/patch-coreapi::linphonecore.c b/net/linphone-base/files/patch-coreapi::linphonecore.c
index 2262f2a72ea5..8e823e6cf30e 100644
--- a/net/linphone-base/files/patch-coreapi::linphonecore.c
+++ b/net/linphone-base/files/patch-coreapi::linphonecore.c
@@ -1,5 +1,5 @@
---- coreapi/linphonecore.c.orig 2008-02-12 20:18:04.000000000 +0900
-+++ coreapi/linphonecore.c 2008-02-14 02:54:42.000000000 +0900
+--- coreapi/linphonecore.c.orig 2009-03-10 00:22:47.000000000 +0900
++++ coreapi/linphonecore.c 2009-03-26 01:38:40.000000000 +0900
@@ -29,11 +29,9 @@
#include "exevents.h"
@@ -12,7 +12,7 @@
#ifdef WIN32
#define HAVE_EXOSIP_GET_VERSION 1
-@@ -318,7 +316,7 @@
+@@ -341,7 +339,7 @@
const char **devices;
int ndev;
int i;
@@ -21,3 +21,12 @@
/*alsadev let the user use custom alsa device within linphone*/
devid=lp_config_get_string(lc->config,"sound","alsadev",NULL);
if (devid){
+@@ -2108,7 +2106,7 @@
+ if (olddev!=NULL && olddev!=lc->video_conf.device){
+ toggle_video_preview(lc,FALSE);/*restart the video local preview*/
+ }
+- if (lc->ready){
++ if (lc->ready && lc->video_conf.device){
+ vd=ms_web_cam_get_string_id(lc->video_conf.device);
+ if (vd && strstr(vd,"Static picture")!=NULL){
+ vd=NULL;
diff --git a/net/linphone-base/files/patch-gtk-glade__Makefile.in b/net/linphone-base/files/patch-gtk-glade__Makefile.in
index 0f8f075ce767..861c472c5847 100644
--- a/net/linphone-base/files/patch-gtk-glade__Makefile.in
+++ b/net/linphone-base/files/patch-gtk-glade__Makefile.in
@@ -1,6 +1,6 @@
---- gtk-glade/Makefile.in.orig 2008-10-10 21:54:08.000000000 +0900
-+++ gtk-glade/Makefile.in 2008-10-20 05:14:41.000000000 +0900
-@@ -67,9 +67,6 @@
+--- gtk-glade/Makefile.in.orig 2009-03-17 21:12:10.000000000 +0900
++++ gtk-glade/Makefile.in 2009-03-17 21:17:21.000000000 +0900
+@@ -69,9 +69,6 @@
linphone_3_OBJECTS = $(am_linphone_3_OBJECTS)
am__DEPENDENCIES_1 =
@BUILD_GLADE_UI_TRUE@linphone_3_DEPENDENCIES = \
@@ -10,8 +10,8 @@
@BUILD_GLADE_UI_TRUE@ $(am__DEPENDENCIES_1) \
@BUILD_GLADE_UI_TRUE@ $(am__DEPENDENCIES_1) \
@BUILD_GLADE_UI_TRUE@ $(am__DEPENDENCIES_1)
-@@ -310,9 +307,9 @@
- @BUILD_GLADE_UI_TRUE@ logging.c \
+@@ -315,9 +312,9 @@
+ @BUILD_GLADE_UI_TRUE@ buddylookup.c \
@BUILD_GLADE_UI_TRUE@ linphone.h
-@BUILD_GLADE_UI_TRUE@linphone_3_LDADD = $(top_builddir)/oRTP/src/libortp.la \
@@ -23,13 +23,13 @@
@BUILD_GLADE_UI_TRUE@ $(LIBGTK_LIBS) $(INTLLIBS) \
@BUILD_GLADE_UI_TRUE@ $(LIBGLADE_LIBS)
-@@ -324,10 +321,12 @@
+@@ -329,10 +326,12 @@
#gtk-linphone.ui: gtk-linphone.glade
# gtk-builder-convert gtk-linphone.glade $@
--AM_CFLAGS = -I$(top_srcdir)/coreapi/ \
+-AM_CFLAGS = -DIN_LINPHONE -I$(top_srcdir)/coreapi/ \
- -I$(top_srcdir)/mediastreamer2/include/ \
-+AM_CFLAGS = \
++AM_CFLAGS = -DIN_LINPHONE \
+ `$(PKG_CONFIG) --cflags ortp` \
+ `$(PKG_CONFIG) --cflags mediastreamer` \
+ `$(PKG_CONFIG) --cflags linphone` \
diff --git a/net/linphone-base/pkg-plist b/net/linphone-base/pkg-plist
index 21464a7fcd8e..ce20e4e38ede 100644
--- a/net/linphone-base/pkg-plist
+++ b/net/linphone-base/pkg-plist
@@ -1,8 +1,10 @@
bin/linphonec
+bin/linphonecsh
bin/sipomatic
include/linphone/config.h
include/linphone/linphonecore.h
include/linphone/lpconfig.h
+include/linphone/sipsetup.h
include/mediastreamer2/allfilters.h
include/mediastreamer2/dtmfgen.h
include/mediastreamer2/ice.h
@@ -41,7 +43,7 @@ include/ortp/telephonyevents.h
lib/liblinphone.a
lib/liblinphone.la
lib/liblinphone.so
-lib/liblinphone.so.3
+lib/liblinphone.so.4
lib/libmediastreamer.a
lib/libmediastreamer.la
lib/libmediastreamer.so
@@ -75,6 +77,7 @@ libexec/mediastream
%%NLS%%share/locale/nl/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/pl/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/linphone.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/linphone.mo
%%NLS%%share/locale/sv/LC_MESSAGES/linphone.mo
share/mediastreamer/images/nowebcamCIF.jpg
@dirrm share/mediastreamer/images
diff --git a/net/linphone-base/pkg-plist.gui b/net/linphone-base/pkg-plist.gui
index 19a738771f45..0a2b8cb89ab2 100644
--- a/net/linphone-base/pkg-plist.gui
+++ b/net/linphone-base/pkg-plist.gui
@@ -2,10 +2,10 @@ bin/linphone
bin/linphone-3
share/applications/linphone.desktop
%%DATADIR%%/about.glade
+%%DATADIR%%/buddylookup.glade
%%DATADIR%%/call_logs.glade
%%DATADIR%%/chatroom.glade
%%DATADIR%%/contact.glade
-%%DATADIR%%/gtk-linphone.glade
%%DATADIR%%/incoming_call.glade
%%DATADIR%%/linphone.png
%%DATADIR%%/linphone2.png