aboutsummaryrefslogtreecommitdiff
path: root/net/linphone
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-01-09 15:30:09 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-01-09 15:30:09 +0000
commit4bf50485e6a161bc1406fdd29d4bc5ce88287359 (patch)
treec9433f2e8e4ff99d257ac551d579dec12a1260e6 /net/linphone
parente8f16d34958d4dc16b91f4c4f0ef5acce7b6d65b (diff)
downloadports-4bf50485e6a161bc1406fdd29d4bc5ce88287359.tar.gz
ports-4bf50485e6a161bc1406fdd29d4bc5ce88287359.zip
- Fix build when audio/speex isn't installed by adding --disable-speex to
CONFIGURE_ARGS. This does not actually disable Speex support because the port doesn't use the bundled mediastreamer. - Remove --enable-zrtp because the port doesn't use the bundled ortp. - Take maintainership
Notes
Notes: svn path=/head/; revision=376616
Diffstat (limited to 'net/linphone')
-rw-r--r--net/linphone/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index a6f584a3f52a..187d7fa4f05f 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -7,7 +7,7 @@ PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/3.7.x/sources
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tijl@FreeBSD.org
COMMENT= SIP client supporting voice/video calls and text messaging
LIB_DEPENDS= libbellesip.so:${PORTSDIR}/net/belle-sip \
@@ -19,17 +19,16 @@ LIB_DEPENDS= libbellesip.so:${PORTSDIR}/net/belle-sip \
CONFLICTS_INSTALL= linphone-base-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-deplibs-link --disable-strict --disable-tutorials \
+CONFIGURE_ARGS= --disable-deplibs-link --disable-speex --disable-strict \
+ --disable-tutorials \
--enable-external-mediastreamer --enable-external-ortp \
- --enable-zrtp \
--with-readline=${LOCALBASE}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig readline:port
-USE_GNOME= gtk20 intltool libxml2
+USE_GNOME= gtk20 intltool libxml2
USE_LDCONFIG= yes
-EXTRACT_AFTER_ARGS+=--exclude mediastreamer2 --exclude oRTP
OPTIONS_DEFINE= IPV6 NLS NOTIFY UPNP VIDEO
OPTIONS_DEFAULT=NOTIFY UPNP VIDEO