aboutsummaryrefslogtreecommitdiff
path: root/net/linphone
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-11-21 11:20:17 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-11-21 11:20:17 +0000
commit64e9632aa51668f69ce2acada327a85346154860 (patch)
tree84f5340b3fffa5f745815517d69bdc193a5c4f19 /net/linphone
parentc80b3c9ec1a38db7204c7f28e37a5adee0c2e720 (diff)
downloadports-64e9632aa51668f69ce2acada327a85346154860.tar.gz
ports-64e9632aa51668f69ce2acada327a85346154860.zip
Add patches to unbundle Noto fonts.
PR: 232392
Notes
Notes: svn path=/head/; revision=485509
Diffstat (limited to 'net/linphone')
-rw-r--r--net/linphone/Makefile2
-rw-r--r--net/linphone/files/patch-resources.qrc16
-rw-r--r--net/linphone/files/patch-src-app-AppController.cpp11
3 files changed, 28 insertions, 1 deletions
diff --git a/net/linphone/Makefile b/net/linphone/Makefile
index b4bd4ff06e23..eed7c9058eff 100644
--- a/net/linphone/Makefile
+++ b/net/linphone/Makefile
@@ -2,7 +2,7 @@
PORTNAME= linphone
PORTVERSION= 4.1.1
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= https://www.linphone.org/releases/sources/linphoneqt/
diff --git a/net/linphone/files/patch-resources.qrc b/net/linphone/files/patch-resources.qrc
new file mode 100644
index 000000000000..3a2bae3e4cb0
--- /dev/null
+++ b/net/linphone/files/patch-resources.qrc
@@ -0,0 +1,16 @@
+--- resources.qrc.orig 2017-06-29 09:20:37 UTC
++++ resources.qrc
+@@ -1,13 +1,5 @@
+ <!DOCTYPE RCC><RCC version="1.0">
+ <qresource prefix="/">
+- <file>assets/fonts/NotoSans-hinted/NotoSans-BoldItalic.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSans-Bold.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSans-Italic.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSans-Regular.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSansUI-BoldItalic.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSansUI-Bold.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSansUI-Italic.ttf</file>
+- <file>assets/fonts/NotoSans-hinted/NotoSansUI-Regular.ttf</file>
+ <file>assets/images/add_disabled.svg</file>
+ <file>assets/images/add_hovered.svg</file>
+ <file>assets/images/add_normal.svg</file>
diff --git a/net/linphone/files/patch-src-app-AppController.cpp b/net/linphone/files/patch-src-app-AppController.cpp
new file mode 100644
index 000000000000..a18ff3f74a92
--- /dev/null
+++ b/net/linphone/files/patch-src-app-AppController.cpp
@@ -0,0 +1,11 @@
+--- src/app/AppController.cpp.orig 2018-11-11 20:28:45 UTC
++++ src/app/AppController.cpp
+@@ -34,7 +34,7 @@
+ #define APPLICATION_VERSION "4.1.1"
+ #define APPLICATION_MINIMAL_QT_VERSION "5.9.0"
+
+-#define DEFAULT_FONT "Noto Sans"
++#define DEFAULT_FONT "sans-serif"
+
+ using namespace std;
+