aboutsummaryrefslogtreecommitdiff
path: root/net/liveMedia
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-02 09:52:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-02 09:52:58 +0000
commit7586f063e1c30999be3319fbf80ea9161d3d1d66 (patch)
treec37c89cbe0a6e5cc9262f7fca885f70477923866 /net/liveMedia
parent824e62e4c43101cd3fa075593626baf57633522c (diff)
downloadports-7586f063e1c30999be3319fbf80ea9161d3d1d66.tar.gz
ports-7586f063e1c30999be3319fbf80ea9161d3d1d66.zip
net/liveMedia: update to 2019.12.30
2019.12.30: - Moved the definition of "class tcpStreamRecord" inside "RTPInterface.cpp", to make it clear that this class is intended to be used only to implement "RTPInterface". - Added the "EXT-X-INDEPENDENT-SEGMENTS" tag to the playlist header generated by the "testH264VideoToHLSSegments" and "live555HLSProxy" demo applications. 2019.12.27: - Added a new demo application "live555HLSProxy" to "testProgs". (Because this is still 'work in progress', it is described/documented only on our developers' mailing list, for now.) 2019.12.13: - In the file "win32config" (used for generating Makefiles for Windows), moved "-DNO_OPENSSL=1" from "C_FLAGS" to "COMPILE_OPTS", following a suggestion. - Changed the type of the "data" parameter in the (private) member function "RTSPClient::write()" from "const u_int8_t*" to "const char*", following a suggestion. (Ditto for "TLSState::write()".) - Removed some stray (unused) files that had accidentally got left in the "liveMedia" directory. 2019.12.10: - Improved the handling of "npt" (Normal Play Time) times in the RTSP "Range:" header. (Thanks to Denis Genestier.) 2019.12.07: - Added support to "RTSPClient" for connecting to the server via TLS (encrypted TCP). "RTSPClient" will now connect via TLS if the URL begins with "rtsps://", or if the URL's port number is 322 (the port number reserved for RTSP over TLS), or if the "useTLS()" function is called on the "RTSPClient" object before the first RTSP command is sent. (Note that only RTSP client support for TLS is implemented for now; our RTSP server implementation currently does not support connections over TLS.) Note that because applications now link with "-lssl -lcrypto", you *must* re-run "genMakefiles" (to generate a new Makefile) after upgrading to this version of the software. (If you don't wish to support RTSP-over-TLS (or if you don't have "OpenSSL"), you can avoid this by compling with "-DNO_OPENSSL=1")
Notes
Notes: svn path=/head/; revision=521821
Diffstat (limited to 'net/liveMedia')
-rw-r--r--net/liveMedia/Makefile9
-rw-r--r--net/liveMedia/distinfo6
-rw-r--r--net/liveMedia/pkg-plist2
3 files changed, 12 insertions, 5 deletions
diff --git a/net/liveMedia/Makefile b/net/liveMedia/Makefile
index a0bf26bf98a8..aba0887eeab9 100644
--- a/net/liveMedia/Makefile
+++ b/net/liveMedia/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= liveMedia
-PORTVERSION= 2019.12.05
+PORTVERSION= 2019.12.30
PORTEPOCH= 2
CATEGORIES= net devel
MASTER_SITES= http://www.live555.com/liveMedia/public/ \
@@ -25,7 +25,7 @@ HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= genMakefiles
CONFIGURE_ARGS= fixed-freebsd
-USES= compiler:c++11-lang gmake
+USES= compiler:c++11-lang gmake ssl
USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
@@ -39,6 +39,11 @@ CFLAGS+= -fpic
post-extract:
${CP} ${FILESDIR}/config.fixed-freebsd ${WRKSRC}
+post-patch:
+ # LIBS_FOR_CONSOLE_APPLICATION = -lssl -lcrypto
+ ${REINPLACE_CMD} '/LIBS_FOR_CONSOLE_APPLICATION/s|$$|-L${OPENSSLLIB} -lssl -lcrypto|' \
+ ${WRKSRC}/config.fixed-freebsd
+
.if ${PREFIX} != "/usr/local"
post-configure:
${REINPLACE_CMD} -e 's,^PREFIX = /usr/local,PREFIX = "${PREFIX}",' \
diff --git a/net/liveMedia/distinfo b/net/liveMedia/distinfo
index 501b48dc4f3a..4e3a79133253 100644
--- a/net/liveMedia/distinfo
+++ b/net/liveMedia/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575625409
-SHA256 (live.2019.12.05.tar.gz) = 8b186ce4c450d91b1efe1a476630748c773a82569372ecdeda909c71cbc42e04
-SIZE (live.2019.12.05.tar.gz) = 3189093
+TIMESTAMP = 1577957472
+SHA256 (live.2019.12.30.tar.gz) = 65e5a6ca671023e8783b28894ffd8e290ca7b40bb282554e2af802ff4c8d03b0
+SIZE (live.2019.12.30.tar.gz) = 661560
diff --git a/net/liveMedia/pkg-plist b/net/liveMedia/pkg-plist
index 87506ef0e1a0..59d80602c404 100644
--- a/net/liveMedia/pkg-plist
+++ b/net/liveMedia/pkg-plist
@@ -1,4 +1,5 @@
bin/MPEG2TransportStreamIndexer
+bin/live555HLSProxy
bin/live555MediaServer
bin/live555ProxyServer
bin/openRTSP
@@ -195,6 +196,7 @@ include/liveMedia/SimpleRTPSource.hh
include/liveMedia/StreamReplicator.hh
include/liveMedia/T140TextRTPSink.hh
include/liveMedia/TCPStreamSink.hh
+include/liveMedia/TLSState.hh
include/liveMedia/TextRTPSink.hh
include/liveMedia/TheoraVideoRTPSink.hh
include/liveMedia/TheoraVideoRTPSource.hh