aboutsummaryrefslogtreecommitdiff
path: root/net/lualdap
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-04-14 15:49:36 +0000
commitbeb1c1fe19992999ef068d0dcb07c0d02f4aea71 (patch)
tree464f76d8fe2b9fd7499e26491ee739bfe0a5444e /net/lualdap
parent496124accdd4d4221bb883770cd6fe27184bfc96 (diff)
downloadports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.tar.gz
ports-beb1c1fe19992999ef068d0dcb07c0d02f4aea71.zip
USES=lua gained flavors.
Ports using USES=lua:module or lua:flavors will be flavored. A range of supported lua versions can be set using XX-YY (or XX-, or -YY, or simply ZZ) for ports not supporting all lua versions. USES=lua sets LUA_FLAVOR that needs to be used on all dependencies of flavored lua ports, in a similar way as PHP or Python flavors. PR: 245038 Submitted by: andrew tao11 riddles org uk Reviewed by: mat, kevans, russ haley gmail com Approved by: mat (portmgr) Differential Revision: https://reviews.freebsd.org/D16494
Notes
Notes: svn path=/head/; revision=531700
Diffstat (limited to 'net/lualdap')
-rw-r--r--net/lualdap/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/lualdap/Makefile b/net/lualdap/Makefile
index 99f995a087cf..45169564c410 100644
--- a/net/lualdap/Makefile
+++ b/net/lualdap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lualdap
PORTVERSION= 1.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://files.luaforge.net/releases/${PORTNAME}/${PORTNAME}/LuaLDAP${PORTVERSION}/
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
MAINTAINER= pf@itwf.pl
COMMENT= LDAP support for the Lua language
-USES?= gmake lua
+USES= gmake lua:-52,module
USE_OPENLDAP= yes
# the CPPFLAGS fixes builds where PREFIX != LOCALBASE
@@ -26,6 +26,8 @@ ALL_TARGET=
OPTIONS_DEFINE= DOCS
+DOCSDIR= ${LUA_DOCSDIR}
+
do-install:
@${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/lualdap.so.${PORTVERSION} ${STAGEDIR}${LUA_MODLIBDIR}/${PORTNAME}.so